summaryrefslogtreecommitdiff
path: root/trisquel-etiona/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'trisquel-etiona/PKGBUILD')
-rw-r--r--trisquel-etiona/PKGBUILD22
1 files changed, 21 insertions, 1 deletions
diff --git a/trisquel-etiona/PKGBUILD b/trisquel-etiona/PKGBUILD
index 97f1f0c..aa6ba4c 100644
--- a/trisquel-etiona/PKGBUILD
+++ b/trisquel-etiona/PKGBUILD
@@ -8,7 +8,7 @@ _suite=etiona
pkgname="${_distro}-${_suite}"
pkgver=9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Trisquel docker image(s)"
arch=('x86_64')
url='https://trisquel.info'
@@ -19,12 +19,19 @@ depends=('debuerreotype'
# The FSDG itself is under the CC-BY-ND-4.0
source=('free-system-distribution-guidelines.html'
'CC-BY-ND-4.0.txt'
+ "https://gitlab.trisquel.org/trisquel/package-helpers/-/raw/${_suite}/helpers/DATA/apt/trisquel/sources.list.in"
"${pkgname}.tar.xz.sha512")
sha512sums=('SKIP'
'SKIP'
+ '6650ab124609b42235145c247dbf496cc1e8d2e5dad4ba9105f42f0042d343851a09055def03edf06ad5553daf8285b956885fbba17b88afbb4b66d2030f6703'
'SKIP')
build(){
+ # Generate sources.list without ${_suite}-security and ${_suite}-updates
+ # to make sure that the image is reproducible
+ sed "s/&trisquel-codename;/${_suite}/" sources.list.in | \
+ grep " ${_suite} " > sources.list
+
install -d rootfs
# debuerreotype really requires root, see the following bug report for
@@ -32,7 +39,20 @@ build(){
# https://github.com/debuerreotype/debuerreotype/issues/66
sudo debuerreotype-init --non-debian rootfs "${_suite}" https://archive.trisquel.info/trisquel
sudo debuerreotype-minimizing-config rootfs
+
+ # Add /etc/apt/sources.list
+ sudo install -m644 \
+ --owner=root --group=root \
+ -t rootfs/etc/apt sources.list
+
+ sudo debuerreotype-apt-get rootfs update
+ sudo debuerreotype-apt-get rootfs install -y dpkg-dev # for dpkg-source
+
+ sudo debuerreotype-apt-get rootfs source -y \
+ $(dpkg --root rootfs --get-selections | cut -f 1)
+
sudo debuerreotype-tar rootfs "${_distro}-${_suite}.tar"
+
# docker import ${_distro}-${_suite}.tar.xz works, so it's better to
# have the smallest file possible as xz compresses quite well and we
# will at least have one docker image per FSDG distribution if