summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-03-25 00:10:31 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2018-03-26 16:14:30 -0400
commit4075f9ed3631ac04042678ffeffa74e166d12b15 (patch)
tree6bf8050633be3bb4edd80292f82fdf431d6571cd
parent6062c23eed56e1bfbc67af6ff55636e29a17285a (diff)
test/: Disable non-applicable testsparabola/20180326
- db-update: Disable the test for split packages, we comment that bit out. - `rm test/cases/testing2x.bats` -- we've dropped testing2x
-rwxr-xr-xtest/cases/db-update.bats1
-rwxr-xr-xtest/cases/testing2x.bats20
2 files changed, 1 insertions, 20 deletions
diff --git a/test/cases/db-update.bats b/test/cases/db-update.bats
index 3008e60..37dfbc9 100755
--- a/test/cases/db-update.bats
+++ b/test/cases/db-update.bats
@@ -130,6 +130,7 @@ load ../lib/common
@test "add incomplete split package" {
+ skip # commented out with "This is fucking obnoxious" -- abslibre is broken
local repo='extra'
local pkgbase='pkg-split-a'
local arch
diff --git a/test/cases/testing2x.bats b/test/cases/testing2x.bats
deleted file mode 100755
index 95de46d..0000000
--- a/test/cases/testing2x.bats
+++ /dev/null
@@ -1,20 +0,0 @@
-load ../lib/common
-
-@test "testing2x any package" {
- releasePackage core pkg-any-a any
- db-update
-
- pushd "${TMP}/svn-packages-copy/pkg-any-a/trunk/" >/dev/null
- sed 's/pkgrel=1/pkgrel=2/g' -i PKGBUILD
- svn commit -q -m"update pkg to pkgrel=2" >/dev/null
- __buildPackage any
- popd >/dev/null
-
- releasePackage testing pkg-any-a any
- db-update
-
- testing2x pkg-any-a
-
- checkAnyPackage core pkg-any-a-1-2-any.pkg.tar.xz any
- checkRemovedAnyPackage testing pkg-any-a
-}