summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-05-28 19:45:15 -0400
committerEli Schwartz <eschwartz@archlinux.org>2018-06-19 16:01:09 -0400
commit05dd9be0db06d7f7cea0eff9f9f6f1993eb6d463 (patch)
tree017f50f922e75c3f83d72886bbd132aa05df8ba6
parent2c68135f4ab9db048db460bc949322ad7bb418eb (diff)
test: BUILDDIR must be owned by build user
pacman 5.1 enforces this restriction. OTOH it is a simpler setup to set this as the user homedir directly in account creation (just like makechrootpkg has always done) than to create an additional, world-writable, directory. dockerfile: don't use tmpfs for /build
-rw-r--r--Makefile2
-rw-r--r--test/Dockerfile3
2 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 677bc39..988d335 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
IMAGE:=dbscripts/test
-RUN_OPTIONS:=--rm --network=none -v $(PWD):/dbscripts:ro --tmpfs=/tmp:exec --tmpfs=/build -w /dbscripts/test
+RUN_OPTIONS:=--rm --network=none -v $(PWD):/dbscripts:ro --tmpfs=/tmp:exec -w /dbscripts/test
test-image:
docker build --pull -t $(IMAGE) test
diff --git a/test/Dockerfile b/test/Dockerfile
index 3913f00..83c8449 100644
--- a/test/Dockerfile
+++ b/test/Dockerfile
@@ -2,8 +2,7 @@ FROM archlinux/base
RUN pacman -Syu --noconfirm --needed sudo fakeroot awk subversion make kcov bash-bats gettext grep
RUN pacman-key --init
RUN echo '%wheel ALL=(ALL) NOPASSWD: ALL' > /etc/sudoers.d/wheel
-RUN useradd -N -g users -G wheel -m tester
-RUN install -d -m 1777 /build
+RUN useradd -N -g users -G wheel -d /build -m tester
USER tester
RUN echo -e "\
Key-Type: RSA\n\