summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-03-21 12:09:21 -0400
committerEli Schwartz <eschwartz@archlinux.org>2018-05-28 19:23:39 -0400
commit2c68135f4ab9db048db460bc949322ad7bb418eb (patch)
tree5eb6d41cf38d277b360f073301c3385122246eb5
parent656fd6d5d8f455492b1e51add9e6e1da8f911a7c (diff)
pacman 5.1 compatibility
The print_all_package_names function changed its behavior, adapt
-rw-r--r--test/lib/common.bash9
1 files changed, 4 insertions, 5 deletions
diff --git a/test/lib/common.bash b/test/lib/common.bash
index 36c735f..738cc97 100644
--- a/test/lib/common.bash
+++ b/test/lib/common.bash
@@ -30,7 +30,7 @@ __buildPackage() {
local cache
local pkgarches
local tarch
- local pkgnames
+ local pkgfiles
if [[ -n ${BUILDDIR} ]]; then
cache=${BUILDDIR}/$(__getCheckSum PKGBUILD)
@@ -45,14 +45,14 @@ __buildPackage() {
for tarch in ${pkgarches[@]}; do
if [ "${tarch}" == 'any' ]; then
PKGDEST=${pkgdest} PKGEXT=${PKGEXT} makepkg -c
+ mapfile -tO "${#pkgfiles[@]}" pkgfiles < <(PKGDEST=${pkgdest} PKGEXT=${PKGEXT} makepkg --packagelist)
else
PKGDEST=${pkgdest} PKGEXT=${PKGEXT} CARCH=${tarch} makepkg -c
+ mapfile -tO "${#pkgfiles[@]}" pkgfiles < <(PKGDEST=${pkgdest} PKGEXT=${PKGEXT} CARCH=${tarch} makepkg --packagelist)
fi
done
- pkgnames=($(. PKGBUILD; print_all_package_names))
- pushd ${pkgdest}
- for p in ${pkgnames[@]/%/${PKGEXT}}; do
+ for p in ${pkgfiles[@]}; do
# Manually sign packages as "makepkg --sign" is buggy
gpg -v --detach-sign --no-armor --use-agent ${p}
@@ -60,7 +60,6 @@ __buildPackage() {
cp -Lv ${p}{,.sig} ${cache}/
fi
done
- popd
}
__archrelease() {