summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-06-17 11:43:45 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2018-10-07 18:15:03 -0400
commit96db855c1044b397235baccc46cc18e010c97464 (patch)
tree65ba9275cdfab45173328d5a54d455144d33f6a3
parent170bd7c6502f033f42961728fe9a0f236a6b6b95 (diff)
testing2x: Discover correct repos based on the DBEXT files, not SVN
testing2x needs to: 1. Verify that the new version of the package is found in TESTING_REPO 2. Determine which of STABLE_REPOS the old version of the package is in Currently, to do those things, it checks for the existence of PKGBUILD files in SVN. That information is already stored in the DBEXT files; get it from there, instead of talking to SVN. "Ignore space change" might be useful when viewing this diff.
-rwxr-xr-xtesting2x40
1 files changed, 17 insertions, 23 deletions
diff --git a/testing2x b/testing2x
index d3b096b..99280b5 100755
--- a/testing2x
+++ b/testing2x
@@ -19,31 +19,25 @@ done
declare -A pkgs
for pkgbase in "$@"; do
- if [[ ! -d ${WORKDIR}/${pkgbase} ]]; then
- arch_svn export -q "${SVNREPO}/${pkgbase}/repos" "${WORKDIR}/${pkgbase}" >/dev/null
-
- found_source=false
- for pkgarch in "${ARCHES[@]}" 'any'; do
- svnrepo_from="${WORKDIR}/${pkgbase}/${TESTING_REPO}-${pkgarch}"
- if [[ -r ${svnrepo_from}/PKGBUILD ]]; then
- found_source=true
- break
+ found_source=false
+ for tarch in "${ARCHES[@]}"; do
+ if [[ -n $(arch_expac_pkgbase "$TESTING_REPO" "$tarch" '%n' "$pkgbase") ]]; then
+ found_source=true
+ break
+ fi
+ done
+ [[ $found_source = true ]] || die "%s not found in [%s]" "$pkgbase" "$TESTING_REPO"
+ found_target=false
+ for tarch in "${ARCHES[@]}"; do
+ for repo in "${STABLE_REPOS[@]}"; do
+ if [[ -n $(arch_expac_pkgbase "$repo" "$tarch" '%n' "$pkgbase") ]]; then
+ found_target=true
+ pkgs[${repo}]+="${pkgbase} "
+ break 2
fi
done
- [[ $found_source = true ]] || die "%s not found in [%s]" "$pkgbase" "$TESTING_REPO"
- found_target=false
- for pkgarch in "${ARCHES[@]}" 'any'; do
- for repo in "${STABLE_REPOS[@]}"; do
- svnrepo_to="${WORKDIR}/${pkgbase}/${repo}-${pkgarch}"
- if [[ -r ${svnrepo_to}/PKGBUILD ]]; then
- found_target=true
- pkgs[${repo}]+="${pkgbase} "
- break 2
- fi
- done
- done
- [[ $found_target = true ]] || die "%s not found in any of these repos: %s" "$pkgbase" "${STABLE_REPOS[*]}"
- fi
+ done
+ [[ $found_target = true ]] || die "%s not found in any of these repos: %s" "$pkgbase" "${STABLE_REPOS[*]}"
done
for pkgarch in "${ARCHES[@]}"; do