summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-06-22 13:33:20 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2018-10-07 19:11:28 -0400
commit733f470f3315a258b6be99d04cc3f2cac686e7dc (patch)
tree8914133139fb1bfbe96e38693d5df801a63f74a6
parent0e4c8101b3d3461c3eb69c140ea7eee197ae3b8f (diff)
Makefile: `make check` instead of `make test`, per GNU conventions
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index ecb78c9..66913dc 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,13 @@
all:
.PHONY: all
-test:
+check:
$(MAKE) -C test test
-
-test-coverage:
+check-coverage:
rm -rf ${PWD}/coverage
$(MAKE) -C test test-coverage
+.PHONY: check check-coverage
+test: check
+test-coverage: check-coverage
.PHONY: test test-coverage