summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--test/Dockerfile3
2 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 677bc39..988d335 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
IMAGE:=dbscripts/test
-RUN_OPTIONS:=--rm --network=none -v $(PWD):/dbscripts:ro --tmpfs=/tmp:exec --tmpfs=/build -w /dbscripts/test
+RUN_OPTIONS:=--rm --network=none -v $(PWD):/dbscripts:ro --tmpfs=/tmp:exec -w /dbscripts/test
test-image:
docker build --pull -t $(IMAGE) test
diff --git a/test/Dockerfile b/test/Dockerfile
index 3913f00..83c8449 100644
--- a/test/Dockerfile
+++ b/test/Dockerfile
@@ -2,8 +2,7 @@ FROM archlinux/base
RUN pacman -Syu --noconfirm --needed sudo fakeroot awk subversion make kcov bash-bats gettext grep
RUN pacman-key --init
RUN echo '%wheel ALL=(ALL) NOPASSWD: ALL' > /etc/sudoers.d/wheel
-RUN useradd -N -g users -G wheel -m tester
-RUN install -d -m 1777 /build
+RUN useradd -N -g users -G wheel -d /build -m tester
USER tester
RUN echo -e "\
Key-Type: RSA\n\