summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xtesting2x40
1 files changed, 17 insertions, 23 deletions
diff --git a/testing2x b/testing2x
index d3b096b..e90adb0 100755
--- a/testing2x
+++ b/testing2x
@@ -19,31 +19,25 @@ done
declare -A pkgs
for pkgbase in "$@"; do
- if [[ ! -d ${WORKDIR}/${pkgbase} ]]; then
- arch_svn export -q "${SVNREPO}/${pkgbase}/repos" "${WORKDIR}/${pkgbase}" >/dev/null
-
- found_source=false
- for pkgarch in "${ARCHES[@]}" 'any'; do
- svnrepo_from="${WORKDIR}/${pkgbase}/${TESTING_REPO}-${pkgarch}"
- if [[ -r ${svnrepo_from}/PKGBUILD ]]; then
- found_source=true
- break
+ found_source=false
+ for tarch in "${ARCHES[@]}"; do
+ if [[ -n $(getdbinfo "$TESTING_REPO" "$tarch" "$pkgbase" pkg.name) ]]; then
+ found_source=true
+ break
+ fi
+ done
+ [[ $found_source = true ]] || die "%s not found in [%s]" "$pkgbase" "$TESTING_REPO"
+ found_target=false
+ for tarch in "${ARCHES[@]}"; do
+ for repo in "${STABLE_REPOS[@]}"; do
+ if [[ -n $(getdbinfo "$repo" "$tarch" "$pkgbase" pkg.name) ]]; then
+ found_target=true
+ pkgs[${repo}]+="${pkgbase} "
+ break 2
fi
done
- [[ $found_source = true ]] || die "%s not found in [%s]" "$pkgbase" "$TESTING_REPO"
- found_target=false
- for pkgarch in "${ARCHES[@]}" 'any'; do
- for repo in "${STABLE_REPOS[@]}"; do
- svnrepo_to="${WORKDIR}/${pkgbase}/${repo}-${pkgarch}"
- if [[ -r ${svnrepo_to}/PKGBUILD ]]; then
- found_target=true
- pkgs[${repo}]+="${pkgbase} "
- break 2
- fi
- done
- done
- [[ $found_target = true ]] || die "%s not found in any of these repos: %s" "$pkgbase" "${STABLE_REPOS[*]}"
- fi
+ done
+ [[ $found_target = true ]] || die "%s not found in any of these repos: %s" "$pkgbase" "${STABLE_REPOS[*]}"
done
for pkgarch in "${ARCHES[@]}"; do