summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2017-04-20 13:49:19 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2018-05-20 21:57:40 -0400
commiteed44fd867a4afdcd406ae6dfc10876a90fb8706 (patch)
tree97d208df70f768bed6fbf0a6821ed2b83b82d6a8
parent4096e1e35d9dae102084c0e8e5327779383b96c4 (diff)
makechrootpkg: Also build --allsource packages
It also sets SRCEXT="-$pkgarch$SRCEXT", so that two runs of makechrootpkg on different architectures don't overwrite eachothers source packages.
-rw-r--r--makechrootpkg.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/makechrootpkg.in b/makechrootpkg.in
index 98cd1b5..09c047e 100644
--- a/makechrootpkg.in
+++ b/makechrootpkg.in
@@ -260,10 +260,25 @@ _chrootbuild() {
# shellcheck source=/dev/null
. /etc/profile
+ local srcext
+ srcext="$(
+ # shellcheck source=makepkg-x86_64.conf
+ . /etc/makepkg.conf || exit
+ # shellcheck source=PKGBUILD.proto
+ . /startdir/PKGBUILD || exit
+ if [ "$arch" = any ]; then
+ pkgarch=any
+ else
+ pkgarch=$CARCH
+ fi
+ printf '%s\n' "-$pkgarch$SRCEXT"
+ )" || return
+
# Beware, there are some stupid arbitrary rules on how you can
# use "$" in arguments to commands with "sudo -i". ${foo} or
# ${1} is OK, but $foo or $1 isn't.
# https://bugzilla.sudo.ws/show_bug.cgi?id=765
+ sudo --preserve-env=SOURCE_DATE_EPOCH -iu builduser bash -c 'cd /startdir; SRCEXT="${1}" makepkg "${@:2}" --allsource' -bash "$srcext" "$@" || return
sudo --preserve-env=SOURCE_DATE_EPOCH -iu builduser bash -c 'cd /startdir; makepkg "$@" --noextract --noprepare' -bash "$@"
}