summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-05-29 15:12:48 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2018-05-29 15:12:48 -0400
commitfdf7ec7616e06870c7c30205578e98b43aa34482 (patch)
tree9a56c8795fb645bd7ac5dd502b90c047eb848522
parent779a9020f1d290d8ce0517ef1e6d624b4135d01d (diff)
parentee8e2b74bbb82b11a1d14d981384151106d48eb8 (diff)
Merge branch 'lukeshu/rebase/master'libretools-20180530
-rw-r--r--Makefile2
-rw-r--r--arch-nspawn.in3
-rw-r--r--makechrootpkg.in8
3 files changed, 4 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index f69d613..f1cf54d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-V=20171108
+V=20180528
PREFIX = /usr/local
diff --git a/arch-nspawn.in b/arch-nspawn.in
index c448056..96b3e38 100644
--- a/arch-nspawn.in
+++ b/arch-nspawn.in
@@ -58,8 +58,9 @@ else
cache_dirs=("$cache_dir")
fi
+pacconf_cmd=$(command -v pacman-conf || command -v pacconf)
# shellcheck disable=2016
-host_mirror=$(pacman --cachedir /doesnt/exist -Sddp extra/devtools 2>/dev/null | sed -r 's#(.*/)extra/os/.*#\1$repo/os/$arch#')
+host_mirror=$($pacconf_cmd --repo extra Server 2> /dev/null | head -1 | sed -r 's#(.*/)extra/os/.*#\1$repo/os/$arch#')
# shellcheck disable=2016
[[ $host_mirror == *file://* ]] && host_mirror_path=$(echo "$host_mirror" | sed -r 's#file://(/.*)/\$repo/os/\$arch#\1#g')
diff --git a/makechrootpkg.in b/makechrootpkg.in
index 09c047e..4cfc6b4 100644
--- a/makechrootpkg.in
+++ b/makechrootpkg.in
@@ -181,13 +181,7 @@ prepare_chroot() {
printf >>"$copydir/etc/passwd" 'builduser:x:%d:%d:builduser:/build:/bin/bash\n' "$builduser_uid" "$builduser_gid"
printf >>"$copydir/etc/shadow" 'builduser:!!:%d::::::\n' "$(( $(date -u +%s) / 86400 ))"
- $install -d "$copydir"/{build,build/.gnupg,startdir,{pkg,srcpkg,src,log}dest}
-
- for x in .gnupg/pubring.{kbx,gpg}; do
- [[ -r $USER_HOME/$x ]] || continue
- $install -m 644 "$USER_HOME/$x" "$copydir/build/$x"
- done
- $install -m644 /dev/stdin "$copydir/build/.gnupg/gpg.conf" <<<'keyserver-options auto-key-retrieve'
+ $install -d "$copydir"/{build,startdir,{pkg,srcpkg,src,log}dest}
sed -e '/^MAKEFLAGS=/d' -e '/^PACKAGER=/d' -i "$copydir/etc/makepkg.conf"
for x in BUILDDIR=/build PKGDEST=/pkgdest SRCPKGDEST=/srcpkgdest SRCDEST=/srcdest LOGDEST=/logdest \