summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-03-09 20:52:33 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-03-09 20:52:33 +0100
commit62a92d254fa97339c4d26d9fd8fd7d1e2e29e4e2 (patch)
treeff9d9e5bc5fd04fc09bffc09cdbededf23d6de60
parent23c668a68bed14ed652daea00d76edbc0256784c (diff)
updated branding patches for icedove-60.5.160.5-1
-rwxr-xr-xrelease.sh2
-rw-r--r--src/app-icons/icedove128.pngbin22441 -> 0 bytes
-rw-r--r--src/app-icons/icedove16.pngbin920 -> 0 bytes
-rw-r--r--src/app-icons/icedove22.pngbin1518 -> 0 bytes
-rw-r--r--src/app-icons/icedove24.pngbin1773 -> 0 bytes
-rw-r--r--src/app-icons/icedove256.pngbin59103 -> 0 bytes
-rw-r--r--src/app-icons/icedove32.pngbin2733 -> 0 bytes
-rw-r--r--src/app-icons/icedove48.pngbin5499 -> 0 bytes
-rw-r--r--src/app-icons/icedove64.pngbin8513 -> 0 bytes
-rw-r--r--src/app-icons/icedove_big.svg (renamed from src/app-icons/icedovebig.svg)0
-rw-r--r--src/app-icons/icedove_small.svg (renamed from src/app-icons/icedovesmall.svg)0
-rw-r--r--src/icedove-branding/Makefile.in29
-rw-r--r--src/icedove-branding/branding.nsi21
-rw-r--r--src/icedove-branding/configure.sh4
-rw-r--r--src/icedove-branding/jar.mn7
-rw-r--r--src/icedove-branding/locales/Makefile.in48
-rw-r--r--src/icedove-branding/locales/en-US/brand.dtd5
-rw-r--r--src/icedove-branding/locales/en-US/brand.properties5
-rw-r--r--src/icedove-branding/moz.build11
-rw-r--r--src/icedove-branding/thunderbird-branding.js11
-rw-r--r--src/patches/debian-hacks/Icedove-branding.patch24
-rw-r--r--src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch101
-rw-r--r--src/patches/icedove/fix-installdir.patch17
-rw-r--r--src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch18
24 files changed, 114 insertions, 189 deletions
diff --git a/release.sh b/release.sh
index 1dc0117..6755301 100755
--- a/release.sh
+++ b/release.sh
@@ -3,7 +3,7 @@
set -eu
pkgname=icedove
-brandingver=52.1
+brandingver=60.5
brandingrel=1
srcdir=src
diff --git a/src/app-icons/icedove128.png b/src/app-icons/icedove128.png
deleted file mode 100644
index b7d711e..0000000
--- a/src/app-icons/icedove128.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedove16.png b/src/app-icons/icedove16.png
deleted file mode 100644
index 412c0aa..0000000
--- a/src/app-icons/icedove16.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedove22.png b/src/app-icons/icedove22.png
deleted file mode 100644
index 29904ba..0000000
--- a/src/app-icons/icedove22.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedove24.png b/src/app-icons/icedove24.png
deleted file mode 100644
index 1ba411a..0000000
--- a/src/app-icons/icedove24.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedove256.png b/src/app-icons/icedove256.png
deleted file mode 100644
index 5147e89..0000000
--- a/src/app-icons/icedove256.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedove32.png b/src/app-icons/icedove32.png
deleted file mode 100644
index 0b6ff34..0000000
--- a/src/app-icons/icedove32.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedove48.png b/src/app-icons/icedove48.png
deleted file mode 100644
index 6472c47..0000000
--- a/src/app-icons/icedove48.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedove64.png b/src/app-icons/icedove64.png
deleted file mode 100644
index 9702924..0000000
--- a/src/app-icons/icedove64.png
+++ /dev/null
Binary files differ
diff --git a/src/app-icons/icedovebig.svg b/src/app-icons/icedove_big.svg
index 54519df..54519df 100644
--- a/src/app-icons/icedovebig.svg
+++ b/src/app-icons/icedove_big.svg
diff --git a/src/app-icons/icedovesmall.svg b/src/app-icons/icedove_small.svg
index 82869ed..82869ed 100644
--- a/src/app-icons/icedovesmall.svg
+++ b/src/app-icons/icedove_small.svg
diff --git a/src/icedove-branding/Makefile.in b/src/icedove-branding/Makefile.in
index 456df11..1573672 100644
--- a/src/icedove-branding/Makefile.in
+++ b/src/icedove-branding/Makefile.in
@@ -6,13 +6,24 @@
include $(topsrcdir)/config/rules.mk
-export::
+MAIL_APP_FILES = \
+ default16.png \
+ default22.png \
+ default24.png \
+ default32.png \
+ default48.png \
+ default256.png \
+ $(NULL)
+
+GARBAGE += $(MAIL_APP_FILES)
+
+export:: $(MAIL_APP_FILES)
$(NSINSTALL) -D $(DIST)/branding
-ifdef MOZ_WIDGET_TOOLKIT
- cp $(srcdir)/mailicon16.png $(DIST)/branding/default16.png
- cp $(srcdir)/mailicon22.png $(DIST)/branding/default22.png
- cp $(srcdir)/mailicon24.png $(DIST)/branding/default24.png
- cp $(srcdir)/mailicon32.png $(DIST)/branding/default32.png
- cp $(srcdir)/mailicon48.png $(DIST)/branding/default48.png
- cp $(srcdir)/mailicon256.png $(DIST)/branding/default256.png
-endif
+ cp $^ $(DIST)/branding/
+
+default16.png: SIZE=16
+default22.png: SIZE=22
+default24.png: SIZE=24
+default32.png: SIZE=32
+default48.png: SIZE=48
+default256.png: SIZE=256
diff --git a/src/icedove-branding/branding.nsi b/src/icedove-branding/branding.nsi
index 89e1acf..3ad1594 100644
--- a/src/icedove-branding/branding.nsi
+++ b/src/icedove-branding/branding.nsi
@@ -4,20 +4,13 @@
# NSIS defines for nightly builds.
# The release build branding.nsi is located in other-license/branding/thunderbird/
-!define BrandShortName "Icedove"
# BrandFullNameInternal is used for some registry and file system values
# instead of BrandFullName and typically should not be modified.
-!define BrandFullNameInternal "Icedove Mail/News"
-!define CompanyName "debian.org"
-!define URLInfoAbout "http://www.mozilla.org/"
-!define URLUpdateInfo "http://www.mozilla.org/products/thunderbird/"
-!define SurveyURL "https://survey.mozilla.com/1/Mozilla%20Thunderbird/${AppVersion}/${AB_CD}/exit.html"
-
-# Everything below this line may be modified for Alpha / Beta releases.
-!define BrandFullName "Icedove"
-
-# Add !define NO_INSTDIR_FROM_REG to prevent finding a non-default installation
-# directory in the registry and using that as the default. This prevents
-# Beta releases built with official branding from finding an existing install
-# of an official release and defaulting to its installation directory.
+!define BrandFullNameInternal "Parabola Icedove"
+!define BrandFullName "Parabola Icedove"
+!define CompanyName "Parabola GNU/Linux-libre"
+!define URLInfoAbout "https://wiki.parabola.nu/Icedove"
+!define URLUpdateInfo "https://wiki.parabola.nu/Icedove"
+!define URLSystemRequirements "https://wiki.parabola.nu/Icedove"
+!define SurveyURL "https://wiki.parabola.nu/Icedove"
diff --git a/src/icedove-branding/configure.sh b/src/icedove-branding/configure.sh
index 7d16233..d8c4968 100644
--- a/src/icedove-branding/configure.sh
+++ b/src/icedove-branding/configure.sh
@@ -1,5 +1 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
MOZ_APP_DISPLAYNAME=Icedove
diff --git a/src/icedove-branding/jar.mn b/src/icedove-branding/jar.mn
index d3ceefb..434d05a 100644
--- a/src/icedove-branding/jar.mn
+++ b/src/icedove-branding/jar.mn
@@ -8,8 +8,7 @@ messenger.jar:
content/branding/about-logo.png (content/about-logo.png)
content/branding/about-wordmark.png (content/about-wordmark.png)
content/branding/about.png (content/about.png)
- content/branding/icon48.png (content/icon48.png)
- content/branding/icon64.png (content/icon64.png)
- content/branding/featureConfigurator.jpg (content/featureConfigurator.jpg)
+ content/branding/icon48.png (default48.png)
+ content/branding/icon64.png (default64.png)
content/branding/aboutDialog.css (content/aboutDialog.css)
- ../classic/skin/classic/messenger/icons/new-mail-alert.png (content/icon48.png)
+ ../classic/skin/classic/messenger/icons/new-mail-alert.png (default48.png)
diff --git a/src/icedove-branding/locales/Makefile.in b/src/icedove-branding/locales/Makefile.in
deleted file mode 100644
index be2acfa..0000000
--- a/src/icedove-branding/locales/Makefile.in
+++ /dev/null
@@ -1,48 +0,0 @@
-# ***** BEGIN LICENSE BLOCK *****
-# Version: MPL 1.1/GPL 2.0/LGPL 2.1
-#
-# The contents of this file are subject to the Mozilla Public License Version
-# 1.1 (the "License"); you may not use this file except in compliance with
-# the License. You may obtain a copy of the License at
-# http://www.mozilla.org/MPL/
-#
-# Software distributed under the License is distributed on an "AS IS" basis,
-# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
-# for the specific language governing rights and limitations under the
-# License.
-#
-# The Original Code is Thunderbird unofficial branding.
-#
-# The Initial Developer of the Original Code is
-# Mozilla Messaging
-# Portions created by the Initial Developer are Copyright (C) 2008
-# the Initial Developer. All Rights Reserved.
-#
-# Contributor(s):
-# Mark Banner <bugzilla@standard8.plus.com>
-#
-# Alternatively, the contents of this file may be used under the terms of
-# either the GNU General Public License Version 2 or later (the "GPL"), or
-# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
-# in which case the provisions of the GPL or the LGPL are applicable instead
-# of those above. If you wish to allow use of your version of this file only
-# under the terms of either the GPL or the LGPL, and not to allow others to
-# use your version of this file under the terms of the MPL, indicate your
-# decision by deleting the provisions above and replace them with the notice
-# and other provisions required by the GPL or the LGPL. If you do not delete
-# the provisions above, a recipient may use your version of this file under
-# the terms of any one of the MPL, the GPL or the LGPL.
-#
-# ***** END LICENSE BLOCK *****
-
-DEPTH = @DEPTH@
-topsrcdir = @top_srcdir@
-srcdir = @srcdir@
-VPATH = @srcdir@
-relativesrcdir = mail/branding/icedove/locales
-
-include $(DEPTH)/config/autoconf.mk
-
-DEFINES += -DAB_CD=$(AB_CD) -DMOZ_DISTRIBUTION_ID_UNQUOTED=$(MOZ_DISTRIBUTION_ID)
-
-include $(topsrcdir)/config/rules.mk
diff --git a/src/icedove-branding/locales/en-US/brand.dtd b/src/icedove-branding/locales/en-US/brand.dtd
index 54fcfe4..0abd6d6 100644
--- a/src/icedove-branding/locales/en-US/brand.dtd
+++ b/src/icedove-branding/locales/en-US/brand.dtd
@@ -1,4 +1,5 @@
<!ENTITY brandShortName "Icedove">
-<!ENTITY brandFullName "Icedove">
-<!ENTITY vendorShortName "Mozilla">
+<!ENTITY brandShorterName "Icedove">
+<!ENTITY brandFullName "Parabola Icedove">
+<!ENTITY vendorShortName "Parabola">
<!ENTITY trademarkInfo.part1 " ">
diff --git a/src/icedove-branding/locales/en-US/brand.properties b/src/icedove-branding/locales/en-US/brand.properties
index 44bf191..34ed2a6 100644
--- a/src/icedove-branding/locales/en-US/brand.properties
+++ b/src/icedove-branding/locales/en-US/brand.properties
@@ -1,3 +1,4 @@
brandShortName=Icedove
-brandFullName=Icedove
-vendorShortName=Mozilla
+brandShorterName=Icedove
+brandFullName=Parabola Icedove
+vendorShortName=Parabola
diff --git a/src/icedove-branding/moz.build b/src/icedove-branding/moz.build
index 1da4292..e53e1c4 100644
--- a/src/icedove-branding/moz.build
+++ b/src/icedove-branding/moz.build
@@ -8,3 +8,14 @@ DIRS += ['locales']
JAR_MANIFESTS += ['jar.mn']
JS_PREFERENCE_FILES += ['thunderbird-branding.js']
+
+FINAL_TARGET_FILES.chrome.icons.default += [
+ 'default128.png',
+ 'default16.png',
+ 'default22.png',
+ 'default24.png',
+ 'default256.png',
+ 'default32.png',
+ 'default48.png',
+ 'default64.png',
+]
diff --git a/src/icedove-branding/thunderbird-branding.js b/src/icedove-branding/thunderbird-branding.js
index cf45edb..a6d9e73 100644
--- a/src/icedove-branding/thunderbird-branding.js
+++ b/src/icedove-branding/thunderbird-branding.js
@@ -1,17 +1,8 @@
-/* This Source Code Form is subject to the terms of the Mozilla Public
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
// Default start page
-//pref("mailnews.start_page.url", "chrome://messenger/content/start.xhtml");
pref("mailnews.start_page.url", "about:");
-// first launch welcome page
-//pref("mailnews.start_page.welcome_url", "chrome://messenger/content/start.xhtml");
-pref("mailnews.start_page.welcome_url", "about:");
-
// start page override to load after an update
-//pref("mailnews.start_page.override_url", "chrome://messenger/content/start.xhtml");
pref("mailnews.start_page.override_url", "about:");
-pref("app.vendorURL", "http://www.mozillamessaging.com/%LOCALE%/thunderbird/");
+pref("app.vendorURL", "about:");
diff --git a/src/patches/debian-hacks/Icedove-branding.patch b/src/patches/debian-hacks/Icedove-branding.patch
index bc57894..2535c7c 100644
--- a/src/patches/debian-hacks/Icedove-branding.patch
+++ b/src/patches/debian-hacks/Icedove-branding.patch
@@ -7,10 +7,10 @@ Subject: Icedove branding
mail/confvars.sh | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
-diff --git a/im/app/application.ini b/im/app/application.ini
+diff --git a/comm/im/app/application.ini b/comm/im/app/application.ini
index 856b900..9ffa5d8 100644
---- a/im/app/application.ini
-+++ b/im/app/application.ini
+--- a/comm/im/app/application.ini
++++ b/comm/im/app/application.ini
@@ -4,7 +4,7 @@
#filter substitution
@@ -18,20 +18,20 @@ index 856b900..9ffa5d8 100644
-Name=Instantbird
+Name=Icedove
Version=@APP_VERSION@
- BuildID=@GRE_BUILDID@
+ BuildID=@MOZ_BUILDID@
#ifdef MOZ_SOURCE_REPO
-diff --git a/mail/confvars.sh b/mail/confvars.sh
+diff --git a/comm/mail/confvars.sh b/comm/mail/confvars.sh
index bbf6f2d..57d0097 100644
---- a/mail/confvars.sh
-+++ b/mail/confvars.sh
-@@ -3,8 +3,8 @@
- # License, v. 2.0. If a copy of the MPL was not distributed with this
- # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+--- a/comm/mail/confvars.sh
++++ b/comm/mail/confvars.sh
+@@ -5,8 +5,8 @@
+
+ . ${_topsrcdir}/$MOZ_BUILD_APP/../comm-confvars.sh
-MOZ_APP_BASENAME=Thunderbird
-MOZ_APP_NAME=thunderbird
+MOZ_APP_BASENAME=Icedove
+MOZ_APP_NAME=icedove
MOZ_UPDATER=1
- MOZ_THUNDERBIRD=1
- MOZ_APP_STATIC_INI=1
+
+ if test "$OS_ARCH" = "WINNT" -o \
diff --git a/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch b/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
index 55f8fd2..9fa8507 100644
--- a/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
+++ b/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
@@ -12,99 +12,76 @@ Closes: #565559
.../en-US/chrome/messenger/accountCreation.dtd | 2 +-
2 files changed, 18 insertions(+), 17 deletions(-)
-diff --git a/mail/app/profile/all-thunderbird.js b/mail/app/profile/all-thunderbird.js
+diff --git a/comm/mail/app/profile/all-thunderbird.js b/comm/mail/app/profile/all-thunderbird.js
index db3b25d..ac240c6 100644
---- a/mail/app/profile/all-thunderbird.js
-+++ b/mail/app/profile/all-thunderbird.js
-@@ -118,7 +118,7 @@ pref("app.update.url", "https://aus5.mozilla.org/update/6/%PRODUCT%/%VERSION%/%B
- pref("app.update.url.manual", "http://www.getthunderbird.com");
+--- a/comm/mail/app/profile/all-thunderbird.js
++++ b/comm/mail/app/profile/all-thunderbird.js
+@@ -98,7 +98,7 @@ pref("app.update.url", "https://aus5.moz
+ pref("app.update.url.manual", "https://www.thunderbird.net");
// A default value for the "More information about this update" link
// supplied in the "An update is available" page of the update wizard.
--pref("app.update.url.details", "https://www.mozilla.org/%LOCALE%/%APP%/releases/");
-+pref("app.update.url.details", "https://www.mozilla.org/%LOCALE%/thunderbird/releases/");
+-pref("app.update.url.details", "https://www.thunderbird.net/%LOCALE%/%APP%/releases/");
++pref("app.update.url.details", "https://www.thunderbird.net/%LOCALE%/thunderbird/releases/");
// app.update.promptWaitTime is in branding section
-@@ -140,14 +140,14 @@ pref("app.update.service.enabled", true);
+@@ -111,14 +111,14 @@ pref("app.update.service.enabled", true)
#endif
// Release notes URL
--pref("app.releaseNotesURL", "https://live.mozillamessaging.com/%APP%/releasenotes?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
-+pref("app.releaseNotesURL", "https://live.mozillamessaging.com/thunderbird/releasenotes?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
+-pref("app.releaseNotesURL", "https://live.thunderbird.net/%APP%/releasenotes?locale=%LOCALE%&version=%VERSION%&channel=%CHANNEL%&os=%OS%&buildid=%APPBUILDID%");
++pref("app.releaseNotesURL", "https://live.thunderbird.net/thunderbird/releasenotes?locale=%LOCALE%&version=%VERSION%&channel=%CHANNEL%&os=%OS%&buildid=%APPBUILDID%");
// URL for "Learn More" for Crash Reporter.
pref("toolkit.crashreporter.infoURL",
- "https://www.mozilla.org/thunderbird/legal/privacy/#crash-reporter");");
+ "https://www.mozilla.org/thunderbird/legal/privacy/#crash-reporter");
// Base URL for web-based support pages.
--pref("app.support.baseURL", "https://support.live.mozillamessaging.com/%LOCALE%/%APP%/%APPBUILDID%/");
-+pref("app.support.baseURL", "https://support.live.mozillamessaging.com/%LOCALE%/thunderbird/%APPBUILDID%/");
+-pref("app.support.baseURL", "https://support.thunderbird.net/%LOCALE%/%APP%/%APPBUILDID%/");
++pref("app.support.baseURL", "https://support.thunderbird.net/%LOCALE%/thunderbird/%APPBUILDID%/");
// Show error messages in error console.
pref("javascript.options.showInConsole", true);
-@@ -177,20 +177,20 @@ pref("extensions.autoDisableScopes", 15);
- // Preferences for AMO integration
- pref("extensions.getAddons.cache.enabled", true);
+@@ -165,11 +165,11 @@ pref("extensions.getAddons.cache.enabled
pref("extensions.getAddons.maxResults", 15);
--pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%");
--pref("extensions.getAddons.getWithPerformance.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
--pref("extensions.getAddons.link.url", "https://addons.mozilla.org/%LOCALE%/%APP%/");
--pref("extensions.getAddons.recommended.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
--pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/%APP%/search?q=%TERMS%");
--pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
--pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/%APP%/discovery/pane/%VERSION%/%OS%");
-+pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%");
-+pref("extensions.getAddons.getWithPerformance.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
-+pref("extensions.getAddons.link.url", "https://addons.mozilla.org/%LOCALE%/thunderbird/");
-+pref("extensions.getAddons.recommended.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
-+pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/search?q=%TERMS%");
-+pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
-+pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/discovery/pane/%VERSION%/%OS%");
-
- // Blocklist preferences
- pref("extensions.blocklist.enabled", true);
- pref("extensions.blocklist.interval", 86400);
- pref("extensions.blocklist.url", "https://blocklist.addons.mozilla.org/blocklist/3/%APP_ID%/%APP_VERSION%/%PRODUCT%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/%PING_COUNT%/%TOTAL_PING_COUNT%/%DAYS_SINCE_LAST_PING%/");
--pref("extensions.blocklist.detailsURL", "https://addons.mozilla.org/%LOCALE%/%APP%/blocked/");
--pref("extensions.blocklist.itemURL", "https://blocklist.addons.mozilla.org/%LOCALE%/%APP%/blocked/%blockID%");
-+pref("extensions.blocklist.detailsURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/blocked/");
-+pref("extensions.blocklist.itemURL", "https://blocklist.addons.mozilla.org/%LOCALE%/thunderbird/blocked/%blockID%");
-
- // Enables some extra Extension System Logging (can reduce performance)
- pref("extensions.logging.enabled", false);
-@@ -210,7 +210,8 @@ pref("extensions.update.background.url", "https://versioncheck-bg.addons.mozilla
- pref("extensions.update.interval", 86400); // Check for updates to Extensions and
- // Themes every day
-
--pref("extensions.dss.enabled", false); // Dynamic Skin Switching
-+pref("extensions.getMoreThemesURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/themes/");
-+pref("extensions.dss.enabled", false); // Dynamic Skin Switching
- pref("extensions.dss.switchPending", false); // Non-dynamic switch pending after next
-
- pref("extensions.{972ce4c6-7e08-4474-a285-3208198ce6fd}.name", "chrome://messenger/locale/messenger.properties");
-@@ -429,7 +430,7 @@ pref("browser.helperApps.deleteTempFileOnExit", true);
+ pref("extensions.getAddons.get.url", "https://services.addons.thunderbird.net/api/v3/addons/search/?guid=%IDS%&lang=%LOCALE%");
+ pref("extensions.getAddons.compatOverides.url", "https://services.addons.thunderbird.net/api/v3/addons/compat-override/?guid=%IDS%&lang=%LOCALE%");
+-pref("extensions.getAddons.link.url", "https://addons.thunderbird.net/%LOCALE%/%APP%/");
+-pref("extensions.getAddons.recommended.url", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
+-pref("extensions.getAddons.search.browseURL", "https://addons.thunderbird.net/%LOCALE%/%APP%/search/?q=%TERMS%");
+-pref("extensions.getAddons.search.url", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
+-pref("extensions.webservice.discoverURL", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/discovery/pane/%VERSION%/%OS%");
++pref("extensions.getAddons.link.url", "https://addons.thunderbird.net/%LOCALE%/thunderbird/");
++pref("extensions.getAddons.recommended.url", "https://services.addons.thunderbird.net/%LOCALE%/thunderbird/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
++pref("extensions.getAddons.search.browseURL", "https://addons.thunderbird.net/%LOCALE%/thunderbird/search/?q=%TERMS%");
++pref("extensions.getAddons.search.url", "https://services.addons.thunderbird.net/%LOCALE%/thunderbird/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
++pref("extensions.webservice.discoverURL", "https://services.addons.thunderbird.net/%LOCALE%/thunderbird/discovery/pane/%VERSION%/%OS%");
+ pref("extensions.getAddons.themes.browseURL", "https://addons.thunderbird.net/%LOCALE%/thunderbird/themes/?src=thunderbird");
+ pref("extensions.getAddons.siteRegExp", "^https://.*addons\\.thunderbird\\.net");
+
+@@ -426,7 +426,7 @@ pref("browser.helperApps.deleteTempFileO
pref("spellchecker.dictionary", "");
// Dictionary download preference
--pref("spellchecker.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/%APP%/dictionaries/");
-+pref("spellchecker.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/thunderbird/dictionaries/");
+-pref("spellchecker.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/%APP%/dictionaries/");
++pref("spellchecker.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/thunderbird/dictionaries/");
// profile.force.migration can be used to bypass the migration wizard, forcing migration from a particular
// mail application without any user intervention. Possible values are:
-@@ -756,7 +757,7 @@ pref("plugins.hide_infobar_for_carbon_failure_plugin", false);
+@@ -747,7 +747,7 @@ pref("plugins.hide_infobar_for_carbon_fa
pref("plugins.update.url", "https://www.mozilla.org/%LOCALE%/plugincheck/");
pref("plugins.update.notifyUser", false);
--pref("plugins.crash.supportUrl", "https://live.mozillamessaging.com/%APP%/plugin-crashed?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
-+pref("plugins.crash.supportUrl", "https://live.mozillamessaging.com/thunderbird/plugin-crashed?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
+-pref("plugins.crash.supportUrl", "https://live.thunderbird.net/%APP%/plugin-crashed?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
++pref("plugins.crash.supportUrl", "https://live.thunderbird.net/thunderbird/plugin-crashed?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
// Click-to-play has not been ported for TB yet, see bug 814168.
// The default plugin state should be changed to "ask to activate" when this
-diff --git a/mail/locales/en-US/chrome/messenger/accountCreation.dtd b/mail/locales/en-US/chrome/messenger/accountCreation.dtd
+diff --git a/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd b/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd
index 3a9c30c..65e6203 100644
---- a/mail/locales/en-US/chrome/messenger/accountCreation.dtd
-+++ b/mail/locales/en-US/chrome/messenger/accountCreation.dtd
-@@ -78,7 +78,7 @@
+--- a/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd
++++ b/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd
+@@ -80,7 +80,7 @@
<!ENTITY changeSettings.label "Change Settings">
<!ENTITY changeSettings.accesskey "S">
diff --git a/src/patches/icedove/fix-installdir.patch b/src/patches/icedove/fix-installdir.patch
index 0ad46c6..73654be 100644
--- a/src/patches/icedove/fix-installdir.patch
+++ b/src/patches/icedove/fix-installdir.patch
@@ -6,13 +6,13 @@ Subject: fix installdir
mail/app/Makefile.in | 9 +++++++++
1 file changed, 9 insertions(+)
-diff --git a/mail/app/Makefile.in b/mail/app/Makefile.in
+diff --git a/comm/mail/app/Makefile.in b/comm/mail/app/Makefile.in
index 74c164b..1c9ea15 100644
---- a/mail/app/Makefile.in
-+++ b/mail/app/Makefile.in
-@@ -100,11 +100,20 @@ libs:: $(addprefix icons/$(MOZ_WIDGET_TOOLKIT)/,$(DESKTOP_ICON_FILES))
+--- a/comm/mail/app/Makefile.in
++++ b/comm/mail/app/Makefile.in
+@@ -100,6 +100,13 @@ libs:: $(addprefix icons/$(MOZ_WIDGET_TO
- libs:: $(addprefix $(DIST)/branding/,$(BRANDED_ICON_FILES))
+ libs:: $(topsrcdir)/$(MOZ_BRANDING_DIRECTORY)/messengerWindow.ico
$(INSTALL) $(IFLAGS1) $^ $(DIST)/bin/chrome/icons/default
+
+install:: $(addprefix icons/$(MOZ_WIDGET_TOOLKIT)/,$(DESKTOP_ICON_FILES))
@@ -20,14 +20,7 @@ index 74c164b..1c9ea15 100644
+
+install:: $(addprefix $(DIST)/branding,$(BRANDED_ICON_FILES))
+ $(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(installdir)/chrome/icons/default
- endif
-
- ifneq (,$(filter gtk%,$(MOZ_WIDGET_TOOLKIT)))
- libs::
- $(INSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DIST)/bin/chrome/icons/default
+
-+install::
-+ $(SYSINSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DESTDIR)$(installdir)/chrome/icons/default
endif
libs:: $(srcdir)/profile/prefs.js
diff --git a/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch b/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
index 6f01f4f..cac8e7b 100644
--- a/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
+++ b/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
@@ -8,10 +8,10 @@ Subject: Change extension's name to Iceowl
calendar/locales/en-US/chrome/lightning/lightning.properties | 8 ++++----
3 files changed, 6 insertions(+), 6 deletions(-)
-diff --git a/calendar/lightning/install.rdf b/calendar/lightning/install.rdf
+diff --git a/comm/calendar/lightning/install.rdf b/comm/calendar/lightning/install.rdf
index ae6dbd2..f71d848 100644
---- a/calendar/lightning/install.rdf
-+++ b/calendar/lightning/install.rdf
+--- a/comm/calendar/lightning/install.rdf
++++ b/comm/calendar/lightning/install.rdf
@@ -30,7 +30,7 @@
</em:targetApplication>
@@ -21,10 +21,10 @@ index ae6dbd2..f71d848 100644
<em:version>@LIGHTNING_VERSION@</em:version> <!-- BuildID=@MOZ_BUILDID@ -->
<em:description>Integrated Calendaring &amp; Scheduling for your Email client</em:description>
#ifdef LIGHTNING_PRERELEASE_VERSION
-diff --git a/calendar/locales/en-US/chrome/calendar/timezones.properties b/calendar/locales/en-US/chrome/calendar/timezones.properties
+diff --git a/comm/calendar/locales/en-US/chrome/calendar/timezones.properties b/comm/calendar/locales/en-US/chrome/calendar/timezones.properties
index f15d3ab..ee96858 100644
---- a/calendar/locales/en-US/chrome/calendar/timezones.properties
-+++ b/calendar/locales/en-US/chrome/calendar/timezones.properties
+--- a/comm/calendar/locales/en-US/chrome/calendar/timezones.properties
++++ b/comm/calendar/locales/en-US/chrome/calendar/timezones.properties
@@ -4,7 +4,7 @@
# extension:
@@ -34,10 +34,10 @@ index f15d3ab..ee96858 100644
extensions.calendar-timezones@mozilla.org.creator=Mozilla Calendar Project
pref.timezone.floating=Local Time
-diff --git a/calendar/locales/en-US/chrome/lightning/lightning.properties b/calendar/locales/en-US/chrome/lightning/lightning.properties
+diff --git a/comm/calendar/locales/en-US/chrome/lightning/lightning.properties b/comm/calendar/locales/en-US/chrome/lightning/lightning.properties
index 3c61d82..2089f1c 100644
---- a/calendar/locales/en-US/chrome/lightning/lightning.properties
-+++ b/calendar/locales/en-US/chrome/lightning/lightning.properties
+--- a/comm/calendar/locales/en-US/chrome/lightning/lightning.properties
++++ b/comm/calendar/locales/en-US/chrome/lightning/lightning.properties
@@ -3,12 +3,12 @@
# file, You can obtain one at http://mozilla.org/MPL/2.0/.