summaryrefslogtreecommitdiff
path: root/src/icedove-branding/Makefile.in
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2017-05-09 07:21:40 +0200
committerAndreas Grapentin <andreas@grapentin.org>2017-05-09 07:21:40 +0200
commitc46005ffeaeca6442a59db492c9201de86a87f2c (patch)
tree43fee9e19f433da6253908c384eae772892e7adb /src/icedove-branding/Makefile.in
parent3281e841d34b2680c84ac5962bf0b374b8e5f27d (diff)
importing 38.6.0-1 sources from https://repomirror.parabola.nu/other/icedove/icedove_38.6.0-1.branding.tar.xz38.6.0-1
Diffstat (limited to 'src/icedove-branding/Makefile.in')
-rw-r--r--src/icedove-branding/Makefile.in58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/icedove-branding/Makefile.in b/src/icedove-branding/Makefile.in
new file mode 100644
index 0000000..f307264
--- /dev/null
+++ b/src/icedove-branding/Makefile.in
@@ -0,0 +1,58 @@
+# ***** BEGIN LICENSE BLOCK *****
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
+#
+# The contents of this file are subject to the Mozilla Public License Version
+# 1.1 (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+# http://www.mozilla.org/MPL/
+#
+# Software distributed under the License is distributed on an "AS IS" basis,
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
+# for the specific language governing rights and limitations under the
+# License.
+#
+# The Original Code is Thunderbird unofficial branding.
+#
+# The Initial Developer of the Original Code is
+# Mozilla Messaging
+# Portions created by the Initial Developer are Copyright (C) 2008
+# the Initial Developer. All Rights Reserved.
+#
+# Contributor(s):
+# Mark Banner <bugzilla@standard8.plus.com>
+#
+# Alternatively, the contents of this file may be used under the terms of
+# either the GNU General Public License Version 2 or later (the "GPL"), or
+# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
+# in which case the provisions of the GPL or the LGPL are applicable instead
+# of those above. If you wish to allow use of your version of this file only
+# under the terms of either the GPL or the LGPL, and not to allow others to
+# use your version of this file under the terms of the MPL, indicate your
+# decision by deleting the provisions above and replace them with the notice
+# and other provisions required by the GPL or the LGPL. If you do not delete
+# the provisions above, a recipient may use your version of this file under
+# the terms of any one of the MPL, the GPL or the LGPL.
+#
+# ***** END LICENSE BLOCK *****
+
+# Branding Makefile for Icedove branding
+
+DEPTH = @DEPTH@
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+include $(DEPTH)/config/autoconf.mk
+
+include $(topsrcdir)/config/rules.mk
+
+export::
+ $(NSINSTALL) -D $(DIST)/branding
+ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
+ cp $(srcdir)/mailicon16.png $(DIST)/branding/default16.png
+ cp $(srcdir)/mailicon22.png $(DIST)/branding/default22.png
+ cp $(srcdir)/mailicon24.png $(DIST)/branding/default24.png
+ cp $(srcdir)/mailicon32.png $(DIST)/branding/default32.png
+ cp $(srcdir)/mailicon48.png $(DIST)/branding/default48.png
+ cp $(srcdir)/mailicon256.png $(DIST)/branding/default256.png
+endif