summaryrefslogtreecommitdiff
path: root/src/icedove-branding/locales
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2017-05-09 07:21:40 +0200
committerAndreas Grapentin <andreas@grapentin.org>2017-05-09 07:21:40 +0200
commitc46005ffeaeca6442a59db492c9201de86a87f2c (patch)
tree43fee9e19f433da6253908c384eae772892e7adb /src/icedove-branding/locales
parent3281e841d34b2680c84ac5962bf0b374b8e5f27d (diff)
importing 38.6.0-1 sources from https://repomirror.parabola.nu/other/icedove/icedove_38.6.0-1.branding.tar.xz38.6.0-1
Diffstat (limited to 'src/icedove-branding/locales')
-rw-r--r--src/icedove-branding/locales/Makefile.in48
-rw-r--r--src/icedove-branding/locales/en-US/brand.dtd4
-rw-r--r--src/icedove-branding/locales/en-US/brand.properties3
-rw-r--r--src/icedove-branding/locales/jar.mn6
-rw-r--r--src/icedove-branding/locales/moz.build6
5 files changed, 67 insertions, 0 deletions
diff --git a/src/icedove-branding/locales/Makefile.in b/src/icedove-branding/locales/Makefile.in
new file mode 100644
index 0000000..be2acfa
--- /dev/null
+++ b/src/icedove-branding/locales/Makefile.in
@@ -0,0 +1,48 @@
+# ***** BEGIN LICENSE BLOCK *****
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
+#
+# The contents of this file are subject to the Mozilla Public License Version
+# 1.1 (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+# http://www.mozilla.org/MPL/
+#
+# Software distributed under the License is distributed on an "AS IS" basis,
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
+# for the specific language governing rights and limitations under the
+# License.
+#
+# The Original Code is Thunderbird unofficial branding.
+#
+# The Initial Developer of the Original Code is
+# Mozilla Messaging
+# Portions created by the Initial Developer are Copyright (C) 2008
+# the Initial Developer. All Rights Reserved.
+#
+# Contributor(s):
+# Mark Banner <bugzilla@standard8.plus.com>
+#
+# Alternatively, the contents of this file may be used under the terms of
+# either the GNU General Public License Version 2 or later (the "GPL"), or
+# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
+# in which case the provisions of the GPL or the LGPL are applicable instead
+# of those above. If you wish to allow use of your version of this file only
+# under the terms of either the GPL or the LGPL, and not to allow others to
+# use your version of this file under the terms of the MPL, indicate your
+# decision by deleting the provisions above and replace them with the notice
+# and other provisions required by the GPL or the LGPL. If you do not delete
+# the provisions above, a recipient may use your version of this file under
+# the terms of any one of the MPL, the GPL or the LGPL.
+#
+# ***** END LICENSE BLOCK *****
+
+DEPTH = @DEPTH@
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+relativesrcdir = mail/branding/icedove/locales
+
+include $(DEPTH)/config/autoconf.mk
+
+DEFINES += -DAB_CD=$(AB_CD) -DMOZ_DISTRIBUTION_ID_UNQUOTED=$(MOZ_DISTRIBUTION_ID)
+
+include $(topsrcdir)/config/rules.mk
diff --git a/src/icedove-branding/locales/en-US/brand.dtd b/src/icedove-branding/locales/en-US/brand.dtd
new file mode 100644
index 0000000..54fcfe4
--- /dev/null
+++ b/src/icedove-branding/locales/en-US/brand.dtd
@@ -0,0 +1,4 @@
+<!ENTITY brandShortName "Icedove">
+<!ENTITY brandFullName "Icedove">
+<!ENTITY vendorShortName "Mozilla">
+<!ENTITY trademarkInfo.part1 " ">
diff --git a/src/icedove-branding/locales/en-US/brand.properties b/src/icedove-branding/locales/en-US/brand.properties
new file mode 100644
index 0000000..44bf191
--- /dev/null
+++ b/src/icedove-branding/locales/en-US/brand.properties
@@ -0,0 +1,3 @@
+brandShortName=Icedove
+brandFullName=Icedove
+vendorShortName=Mozilla
diff --git a/src/icedove-branding/locales/jar.mn b/src/icedove-branding/locales/jar.mn
new file mode 100644
index 0000000..708e5c9
--- /dev/null
+++ b/src/icedove-branding/locales/jar.mn
@@ -0,0 +1,6 @@
+#filter substitution
+
+@AB_CD@.jar:
+% locale branding @AB_CD@ %locale/@AB_CD@/branding/
+ locale/@AB_CD@/branding/brand.dtd (%brand.dtd)
+ locale/@AB_CD@/branding/brand.properties (%brand.properties)
diff --git a/src/icedove-branding/locales/moz.build b/src/icedove-branding/locales/moz.build
new file mode 100644
index 0000000..e0eb66a
--- /dev/null
+++ b/src/icedove-branding/locales/moz.build
@@ -0,0 +1,6 @@
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+JAR_MANIFESTS += ['jar.mn']