summaryrefslogtreecommitdiff
path: root/src/icedove-branding
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-03-09 20:52:33 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-03-09 20:52:33 +0100
commit62a92d254fa97339c4d26d9fd8fd7d1e2e29e4e2 (patch)
treeff9d9e5bc5fd04fc09bffc09cdbededf23d6de60 /src/icedove-branding
parent23c668a68bed14ed652daea00d76edbc0256784c (diff)
updated branding patches for icedove-60.5.160.5-1
Diffstat (limited to 'src/icedove-branding')
-rw-r--r--src/icedove-branding/Makefile.in29
-rw-r--r--src/icedove-branding/branding.nsi21
-rw-r--r--src/icedove-branding/configure.sh4
-rw-r--r--src/icedove-branding/jar.mn7
-rw-r--r--src/icedove-branding/locales/Makefile.in48
-rw-r--r--src/icedove-branding/locales/en-US/brand.dtd5
-rw-r--r--src/icedove-branding/locales/en-US/brand.properties5
-rw-r--r--src/icedove-branding/moz.build11
-rw-r--r--src/icedove-branding/thunderbird-branding.js11
9 files changed, 48 insertions, 93 deletions
diff --git a/src/icedove-branding/Makefile.in b/src/icedove-branding/Makefile.in
index 456df11..1573672 100644
--- a/src/icedove-branding/Makefile.in
+++ b/src/icedove-branding/Makefile.in
@@ -6,13 +6,24 @@
include $(topsrcdir)/config/rules.mk
-export::
+MAIL_APP_FILES = \
+ default16.png \
+ default22.png \
+ default24.png \
+ default32.png \
+ default48.png \
+ default256.png \
+ $(NULL)
+
+GARBAGE += $(MAIL_APP_FILES)
+
+export:: $(MAIL_APP_FILES)
$(NSINSTALL) -D $(DIST)/branding
-ifdef MOZ_WIDGET_TOOLKIT
- cp $(srcdir)/mailicon16.png $(DIST)/branding/default16.png
- cp $(srcdir)/mailicon22.png $(DIST)/branding/default22.png
- cp $(srcdir)/mailicon24.png $(DIST)/branding/default24.png
- cp $(srcdir)/mailicon32.png $(DIST)/branding/default32.png
- cp $(srcdir)/mailicon48.png $(DIST)/branding/default48.png
- cp $(srcdir)/mailicon256.png $(DIST)/branding/default256.png
-endif
+ cp $^ $(DIST)/branding/
+
+default16.png: SIZE=16
+default22.png: SIZE=22
+default24.png: SIZE=24
+default32.png: SIZE=32
+default48.png: SIZE=48
+default256.png: SIZE=256
diff --git a/src/icedove-branding/branding.nsi b/src/icedove-branding/branding.nsi
index 89e1acf..3ad1594 100644
--- a/src/icedove-branding/branding.nsi
+++ b/src/icedove-branding/branding.nsi
@@ -4,20 +4,13 @@
# NSIS defines for nightly builds.
# The release build branding.nsi is located in other-license/branding/thunderbird/
-!define BrandShortName "Icedove"
# BrandFullNameInternal is used for some registry and file system values
# instead of BrandFullName and typically should not be modified.
-!define BrandFullNameInternal "Icedove Mail/News"
-!define CompanyName "debian.org"
-!define URLInfoAbout "http://www.mozilla.org/"
-!define URLUpdateInfo "http://www.mozilla.org/products/thunderbird/"
-!define SurveyURL "https://survey.mozilla.com/1/Mozilla%20Thunderbird/${AppVersion}/${AB_CD}/exit.html"
-
-# Everything below this line may be modified for Alpha / Beta releases.
-!define BrandFullName "Icedove"
-
-# Add !define NO_INSTDIR_FROM_REG to prevent finding a non-default installation
-# directory in the registry and using that as the default. This prevents
-# Beta releases built with official branding from finding an existing install
-# of an official release and defaulting to its installation directory.
+!define BrandFullNameInternal "Parabola Icedove"
+!define BrandFullName "Parabola Icedove"
+!define CompanyName "Parabola GNU/Linux-libre"
+!define URLInfoAbout "https://wiki.parabola.nu/Icedove"
+!define URLUpdateInfo "https://wiki.parabola.nu/Icedove"
+!define URLSystemRequirements "https://wiki.parabola.nu/Icedove"
+!define SurveyURL "https://wiki.parabola.nu/Icedove"
diff --git a/src/icedove-branding/configure.sh b/src/icedove-branding/configure.sh
index 7d16233..d8c4968 100644
--- a/src/icedove-branding/configure.sh
+++ b/src/icedove-branding/configure.sh
@@ -1,5 +1 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
MOZ_APP_DISPLAYNAME=Icedove
diff --git a/src/icedove-branding/jar.mn b/src/icedove-branding/jar.mn
index d3ceefb..434d05a 100644
--- a/src/icedove-branding/jar.mn
+++ b/src/icedove-branding/jar.mn
@@ -8,8 +8,7 @@ messenger.jar:
content/branding/about-logo.png (content/about-logo.png)
content/branding/about-wordmark.png (content/about-wordmark.png)
content/branding/about.png (content/about.png)
- content/branding/icon48.png (content/icon48.png)
- content/branding/icon64.png (content/icon64.png)
- content/branding/featureConfigurator.jpg (content/featureConfigurator.jpg)
+ content/branding/icon48.png (default48.png)
+ content/branding/icon64.png (default64.png)
content/branding/aboutDialog.css (content/aboutDialog.css)
- ../classic/skin/classic/messenger/icons/new-mail-alert.png (content/icon48.png)
+ ../classic/skin/classic/messenger/icons/new-mail-alert.png (default48.png)
diff --git a/src/icedove-branding/locales/Makefile.in b/src/icedove-branding/locales/Makefile.in
deleted file mode 100644
index be2acfa..0000000
--- a/src/icedove-branding/locales/Makefile.in
+++ /dev/null
@@ -1,48 +0,0 @@
-# ***** BEGIN LICENSE BLOCK *****
-# Version: MPL 1.1/GPL 2.0/LGPL 2.1
-#
-# The contents of this file are subject to the Mozilla Public License Version
-# 1.1 (the "License"); you may not use this file except in compliance with
-# the License. You may obtain a copy of the License at
-# http://www.mozilla.org/MPL/
-#
-# Software distributed under the License is distributed on an "AS IS" basis,
-# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
-# for the specific language governing rights and limitations under the
-# License.
-#
-# The Original Code is Thunderbird unofficial branding.
-#
-# The Initial Developer of the Original Code is
-# Mozilla Messaging
-# Portions created by the Initial Developer are Copyright (C) 2008
-# the Initial Developer. All Rights Reserved.
-#
-# Contributor(s):
-# Mark Banner <bugzilla@standard8.plus.com>
-#
-# Alternatively, the contents of this file may be used under the terms of
-# either the GNU General Public License Version 2 or later (the "GPL"), or
-# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
-# in which case the provisions of the GPL or the LGPL are applicable instead
-# of those above. If you wish to allow use of your version of this file only
-# under the terms of either the GPL or the LGPL, and not to allow others to
-# use your version of this file under the terms of the MPL, indicate your
-# decision by deleting the provisions above and replace them with the notice
-# and other provisions required by the GPL or the LGPL. If you do not delete
-# the provisions above, a recipient may use your version of this file under
-# the terms of any one of the MPL, the GPL or the LGPL.
-#
-# ***** END LICENSE BLOCK *****
-
-DEPTH = @DEPTH@
-topsrcdir = @top_srcdir@
-srcdir = @srcdir@
-VPATH = @srcdir@
-relativesrcdir = mail/branding/icedove/locales
-
-include $(DEPTH)/config/autoconf.mk
-
-DEFINES += -DAB_CD=$(AB_CD) -DMOZ_DISTRIBUTION_ID_UNQUOTED=$(MOZ_DISTRIBUTION_ID)
-
-include $(topsrcdir)/config/rules.mk
diff --git a/src/icedove-branding/locales/en-US/brand.dtd b/src/icedove-branding/locales/en-US/brand.dtd
index 54fcfe4..0abd6d6 100644
--- a/src/icedove-branding/locales/en-US/brand.dtd
+++ b/src/icedove-branding/locales/en-US/brand.dtd
@@ -1,4 +1,5 @@
<!ENTITY brandShortName "Icedove">
-<!ENTITY brandFullName "Icedove">
-<!ENTITY vendorShortName "Mozilla">
+<!ENTITY brandShorterName "Icedove">
+<!ENTITY brandFullName "Parabola Icedove">
+<!ENTITY vendorShortName "Parabola">
<!ENTITY trademarkInfo.part1 " ">
diff --git a/src/icedove-branding/locales/en-US/brand.properties b/src/icedove-branding/locales/en-US/brand.properties
index 44bf191..34ed2a6 100644
--- a/src/icedove-branding/locales/en-US/brand.properties
+++ b/src/icedove-branding/locales/en-US/brand.properties
@@ -1,3 +1,4 @@
brandShortName=Icedove
-brandFullName=Icedove
-vendorShortName=Mozilla
+brandShorterName=Icedove
+brandFullName=Parabola Icedove
+vendorShortName=Parabola
diff --git a/src/icedove-branding/moz.build b/src/icedove-branding/moz.build
index 1da4292..e53e1c4 100644
--- a/src/icedove-branding/moz.build
+++ b/src/icedove-branding/moz.build
@@ -8,3 +8,14 @@ DIRS += ['locales']
JAR_MANIFESTS += ['jar.mn']
JS_PREFERENCE_FILES += ['thunderbird-branding.js']
+
+FINAL_TARGET_FILES.chrome.icons.default += [
+ 'default128.png',
+ 'default16.png',
+ 'default22.png',
+ 'default24.png',
+ 'default256.png',
+ 'default32.png',
+ 'default48.png',
+ 'default64.png',
+]
diff --git a/src/icedove-branding/thunderbird-branding.js b/src/icedove-branding/thunderbird-branding.js
index cf45edb..a6d9e73 100644
--- a/src/icedove-branding/thunderbird-branding.js
+++ b/src/icedove-branding/thunderbird-branding.js
@@ -1,17 +1,8 @@
-/* This Source Code Form is subject to the terms of the Mozilla Public
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
// Default start page
-//pref("mailnews.start_page.url", "chrome://messenger/content/start.xhtml");
pref("mailnews.start_page.url", "about:");
-// first launch welcome page
-//pref("mailnews.start_page.welcome_url", "chrome://messenger/content/start.xhtml");
-pref("mailnews.start_page.welcome_url", "about:");
-
// start page override to load after an update
-//pref("mailnews.start_page.override_url", "chrome://messenger/content/start.xhtml");
pref("mailnews.start_page.override_url", "about:");
-pref("app.vendorURL", "http://www.mozillamessaging.com/%LOCALE%/thunderbird/");
+pref("app.vendorURL", "about:");