summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xrelease.sh4
-rw-r--r--src/icedove-branding/Makefile.in48
-rw-r--r--src/icedove-branding/branding.nsi39
-rw-r--r--src/icedove-branding/configure.sh4
-rw-r--r--src/icedove-branding/content/about.pngbin40468 -> 40474 bytes
-rw-r--r--src/icedove-branding/content/aboutDialog.css4
-rw-r--r--src/icedove-branding/jar.mn8
-rw-r--r--src/icedove-branding/thunderbird-branding.js4
-rw-r--r--src/icedove.xpm204
-rw-r--r--src/patches/debian-hacks/Icedove-branding.patch37
-rw-r--r--src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch39
-rw-r--r--src/patches/icedove/fix-installdir.patch6
-rw-r--r--src/patches/icedove/no-dynamic-nss-softokn.patch21
-rw-r--r--src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch4
-rw-r--r--src/patches/series4
15 files changed, 300 insertions, 126 deletions
diff --git a/release.sh b/release.sh
index 4b85afa..12f77b5 100755
--- a/release.sh
+++ b/release.sh
@@ -3,8 +3,8 @@
set -eu
pkgname=icedove
-pkgver=38.6.0
-pkgrel=2
+pkgver=45.5.0
+pkgrel=1
srcdir=src
distdir=${pkgname}-${pkgver}
diff --git a/src/icedove-branding/Makefile.in b/src/icedove-branding/Makefile.in
index f307264..456df11 100644
--- a/src/icedove-branding/Makefile.in
+++ b/src/icedove-branding/Makefile.in
@@ -1,54 +1,14 @@
-# ***** BEGIN LICENSE BLOCK *****
-# Version: MPL 1.1/GPL 2.0/LGPL 2.1
-#
-# The contents of this file are subject to the Mozilla Public License Version
-# 1.1 (the "License"); you may not use this file except in compliance with
-# the License. You may obtain a copy of the License at
-# http://www.mozilla.org/MPL/
-#
-# Software distributed under the License is distributed on an "AS IS" basis,
-# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
-# for the specific language governing rights and limitations under the
-# License.
-#
-# The Original Code is Thunderbird unofficial branding.
-#
-# The Initial Developer of the Original Code is
-# Mozilla Messaging
-# Portions created by the Initial Developer are Copyright (C) 2008
-# the Initial Developer. All Rights Reserved.
-#
-# Contributor(s):
-# Mark Banner <bugzilla@standard8.plus.com>
-#
-# Alternatively, the contents of this file may be used under the terms of
-# either the GNU General Public License Version 2 or later (the "GPL"), or
-# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
-# in which case the provisions of the GPL or the LGPL are applicable instead
-# of those above. If you wish to allow use of your version of this file only
-# under the terms of either the GPL or the LGPL, and not to allow others to
-# use your version of this file under the terms of the MPL, indicate your
-# decision by deleting the provisions above and replace them with the notice
-# and other provisions required by the GPL or the LGPL. If you do not delete
-# the provisions above, a recipient may use your version of this file under
-# the terms of any one of the MPL, the GPL or the LGPL.
-#
-# ***** END LICENSE BLOCK *****
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
# Branding Makefile for Icedove branding
-DEPTH = @DEPTH@
-topsrcdir = @top_srcdir@
-srcdir = @srcdir@
-VPATH = @srcdir@
-
-include $(DEPTH)/config/autoconf.mk
-
include $(topsrcdir)/config/rules.mk
export::
$(NSINSTALL) -D $(DIST)/branding
-ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
+ifdef MOZ_WIDGET_TOOLKIT
cp $(srcdir)/mailicon16.png $(DIST)/branding/default16.png
cp $(srcdir)/mailicon22.png $(DIST)/branding/default22.png
cp $(srcdir)/mailicon24.png $(DIST)/branding/default24.png
diff --git a/src/icedove-branding/branding.nsi b/src/icedove-branding/branding.nsi
index 9d72455..89e1acf 100644
--- a/src/icedove-branding/branding.nsi
+++ b/src/icedove-branding/branding.nsi
@@ -1,42 +1,11 @@
-# ***** BEGIN LICENSE BLOCK *****
-# Version: MPL 1.1/GPL 2.0/LGPL 2.1
-#
-# The contents of this file are subject to the Mozilla Public License Version
-# 1.1 (the "License"); you may not use this file except in compliance with
-# the License. You may obtain a copy of the License at
-# http://www.mozilla.org/MPL/
-#
-# Software distributed under the License is distributed on an "AS IS" basis,
-# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
-# for the specific language governing rights and limitations under the
-# License.
-#
-# The Original Code is the Mozilla Installer code.
-#
-# The Initial Developer of the Original Code is Mozilla Foundation
-# Portions created by the Initial Developer are Copyright (C) 2006
-# the Initial Developer. All Rights Reserved.
-#
-# Contributor(s):
-# Robert Strong <robert.bugzilla@gmail.com>
-#
-# Alternatively, the contents of this file may be used under the terms of
-# either the GNU General Public License Version 2 or later (the "GPL"), or
-# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
-# in which case the provisions of the GPL or the LGPL are applicable instead
-# of those above. If you wish to allow use of your version of this file only
-# under the terms of either the GPL or the LGPL, and not to allow others to
-# use your version of this file under the terms of the MPL, indicate your
-# decision by deleting the provisions above and replace them with the notice
-# and other provisions required by the GPL or the LGPL. If you do not delete
-# the provisions above, a recipient may use your version of this file under
-# the terms of any one of the MPL, the GPL or the LGPL.
-#
-# ***** END LICENSE BLOCK *****
+# This Source Code Form is subject to the terms of the Mozilla Public
+# # License, v. 2.0. If a copy of the MPL was not distributed with this
+# # file, You can obtain one at http://mozilla.org/MPL/2.0/.
# NSIS defines for nightly builds.
# The release build branding.nsi is located in other-license/branding/thunderbird/
!define BrandShortName "Icedove"
+
# BrandFullNameInternal is used for some registry and file system values
# instead of BrandFullName and typically should not be modified.
!define BrandFullNameInternal "Icedove Mail/News"
diff --git a/src/icedove-branding/configure.sh b/src/icedove-branding/configure.sh
index d8c4968..7d16233 100644
--- a/src/icedove-branding/configure.sh
+++ b/src/icedove-branding/configure.sh
@@ -1 +1,5 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
MOZ_APP_DISPLAYNAME=Icedove
diff --git a/src/icedove-branding/content/about.png b/src/icedove-branding/content/about.png
index 86d8502..c7f68be 100644
--- a/src/icedove-branding/content/about.png
+++ b/src/icedove-branding/content/about.png
Binary files differ
diff --git a/src/icedove-branding/content/aboutDialog.css b/src/icedove-branding/content/aboutDialog.css
index c83aec0..5a4da33 100644
--- a/src/icedove-branding/content/aboutDialog.css
+++ b/src/icedove-branding/content/aboutDialog.css
@@ -1,3 +1,7 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
#clientBox {
background-color: #F7F7F7;
color: #222222;
diff --git a/src/icedove-branding/jar.mn b/src/icedove-branding/jar.mn
index 2545a21..d3ceefb 100644
--- a/src/icedove-branding/jar.mn
+++ b/src/icedove-branding/jar.mn
@@ -1,3 +1,8 @@
+#filter substitution
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
messenger.jar:
% content branding %content/branding/
content/branding/about-logo.png (content/about-logo.png)
@@ -6,4 +11,5 @@ messenger.jar:
content/branding/icon48.png (content/icon48.png)
content/branding/icon64.png (content/icon64.png)
content/branding/featureConfigurator.jpg (content/featureConfigurator.jpg)
-* content/branding/aboutDialog.css (content/aboutDialog.css)
+ content/branding/aboutDialog.css (content/aboutDialog.css)
+ ../classic/skin/classic/messenger/icons/new-mail-alert.png (content/icon48.png)
diff --git a/src/icedove-branding/thunderbird-branding.js b/src/icedove-branding/thunderbird-branding.js
index 7caf6b6..cf45edb 100644
--- a/src/icedove-branding/thunderbird-branding.js
+++ b/src/icedove-branding/thunderbird-branding.js
@@ -1,3 +1,7 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
// Default start page
//pref("mailnews.start_page.url", "chrome://messenger/content/start.xhtml");
pref("mailnews.start_page.url", "about:");
diff --git a/src/icedove.xpm b/src/icedove.xpm
new file mode 100644
index 0000000..bf12bae
--- /dev/null
+++ b/src/icedove.xpm
@@ -0,0 +1,204 @@
+/* XPM */
+static char *icedove[] = {
+/* columns rows colors chars-per-pixel */
+"32 32 166 2 ",
+" c #53575C",
+". c #71787F",
+"X c #55A30C",
+"o c #58A60E",
+"O c #5AA612",
+"+ c #5CAA12",
+"@ c #64AD1E",
+"# c #61B115",
+"$ c #66B21C",
+"% c #69BB1A",
+"& c #519A29",
+"* c #66AF22",
+"= c #69AF26",
+"- c #67B021",
+"; c #6AB324",
+": c #6EBA24",
+"> c #67B52B",
+", c #6DB32A",
+"< c #6FBA29",
+"1 c #71B62E",
+"2 c #70B82C",
+"3 c #66B23A",
+"4 c #6BB03A",
+"5 c #73B632",
+"6 c #75B934",
+"7 c #75B639",
+"8 c #77B838",
+"9 c #7BBB3D",
+"0 c #71C420",
+"q c #75C924",
+"w c #79CE27",
+"e c #72C32E",
+"r c #5A9D44",
+"t c #5A985B",
+"y c #69AD4A",
+"u c #7EBC43",
+"i c #77B548",
+"p c #66A25B",
+"a c #68A45C",
+"s c #6CA95F",
+"d c #74BB52",
+"f c #5A9664",
+"g c #619E6D",
+"h c #6FA966",
+"j c #74AA6B",
+"k c #75B366",
+"l c #77AB71",
+"z c #79AD73",
+"x c #7DB275",
+"c c #7FB479",
+"v c #81BD47",
+"b c #84BE4E",
+"n c #87BF51",
+"m c #88BC74",
+"M c #81B37D",
+"N c #84BB7D",
+"B c #81C046",
+"V c #85C14B",
+"C c #87C251",
+"Z c #8BC355",
+"A c #8EC55A",
+"S c #95C766",
+"D c #95CA63",
+"F c #98CC67",
+"G c #91C569",
+"H c #9ACB6C",
+"J c #9ECD70",
+"K c #A2D076",
+"L c #A6D37B",
+"P c #727B82",
+"I c #649A83",
+"U c #6F9C9A",
+"Y c #73A586",
+"T c #73A19E",
+"R c #7EAA9B",
+"E c #719EA7",
+"W c #759FB2",
+"Q c #799FBB",
+"! c #7EA8B5",
+"~ c #7CA2BD",
+"^ c #7B9FC1",
+"/ c #7FA1C6",
+"( c #83B583",
+") c #8696A8",
+"_ c #93B7A4",
+"` c #80A6B8",
+"' c #88AEBF",
+"] c #9CBABB",
+"[ c #98C681",
+"{ c #9BC884",
+"} c #ADD684",
+"| c #AFD68C",
+" . c #B0D989",
+".. c #B7DB95",
+"X. c #BCDE9B",
+"o. c #A2C6A1",
+"O. c #C0DEA4",
+"+. c #C2E1A4",
+"@. c #C7E4AB",
+"#. c #C8E5AC",
+"$. c #CBE5B3",
+"%. c #C7E0BD",
+"&. c #81A4C0",
+"*. c #85A8C3",
+"=. c #8CACC4",
+"-. c #86A7C8",
+";. c #86A8CF",
+":. c #8EADCC",
+">. c #92AFCB",
+",. c #94B3D3",
+"<. c #99B5D4",
+"1. c #9DBAD2",
+"2. c #A9B4C0",
+"3. c #A3BBD7",
+"4. c #A1BDDA",
+"5. c #ABBFDB",
+"6. c #ABC6C5",
+"7. c #A8C1CA",
+"8. c #B5CDC8",
+"9. c #A7C0DA",
+"0. c #B3C7DE",
+"q. c #B3C9DC",
+"w. c #AFC6E0",
+"e. c #B3C7E1",
+"r. c #B5CBE2",
+"t. c #B9CCE2",
+"y. c #BFD1E6",
+"u. c #CCCDC9",
+"i. c #CED0CB",
+"p. c #D1D3CE",
+"a. c #D2D4D0",
+"s. c #D7D8D5",
+"d. c #D8DAD6",
+"f. c #DBDDD9",
+"g. c #D4E9C0",
+"h. c #D8ECC6",
+"j. c #DEE0DD",
+"k. c #E0E1DE",
+"l. c #E0F1D0",
+"z. c #C3D3E6",
+"x. c #CDD8E6",
+"c. c #C1D4E8",
+"v. c #CEDDEC",
+"b. c #D4DCE5",
+"n. c #D2DDEB",
+"m. c #D5E0ED",
+"M. c #D9E2EE",
+"N. c #D4E2F0",
+"B. c #DBE6F1",
+"V. c #DEE9F4",
+"C. c #E4E5E2",
+"Z. c #E7E8E6",
+"A. c #E8E9E7",
+"S. c #EBECEA",
+"D. c #EFF1ED",
+"F. c #F0F8EA",
+"G. c #E4ECF5",
+"H. c #E9EEF4",
+"J. c #ECF1F6",
+"K. c #ECF3F9",
+"L. c #F3F4F3",
+"P. c #F5FAF0",
+"I. c #F2F5F9",
+"U. c #F6F9FC",
+"Y. c #FEFEFE",
+"T. c None",
+/* pixels */
+"T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.",
+"T.T.d.U.d.Y.d.U.d.P.k.L.Z.S.S.Z.L.f.L.f.U.d.Y.d.U.f.L.k.L.Z.T.T.",
+"T.T.S.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.U.T.T.",
+"T.T.a.Y.3.q._ N N M M z z z z z z z z z >.q.=.Y N M 7.3.U.C.T.T.",
+"T.T.L.Y.] : w 0 $ # # @ X X X X X X X X f G.Y.1.> e q j L.U.T.T.",
+"T.T.p.Y.k q % # O o O X X X X X X X X X X r.Y.U.,.t.3 d I.j.T.T.",
+"T.T.L.Y.k % # o X O @ X X X X X X X X X X U U.Y.y.U.<.y U.Y.T.T.",
+"T.T.p.Y.a + o o O.@ X X X X O O X o o O X & v.Y.Y.K.m.t I.k.T.T.",
+"T.T.L.Y.a o o + O.+ O O @ , 7 u u u 7 = + + 3.Y.Y.Y.U.;.U.Y.T.T.",
+"T.T.a.Y.a + o 1 = O.$.H A Z n n n n A S J S ' Y.Y.Y.Y.4.I.k.T.T.",
+"T.T.S.Y.a * v 8 H F.P.| , @ @ * = * * @ = , T Y.Y.Y.Y.t.L.U.T.T.",
+"T.T.s.Y.a g.F.A 9 O.g.A = = , , , , , ; ; * f K.Y.Y.Y.n.I.Z.T.T.",
+"T.T.A.Y.j $.h., @ ; 9 Z 1 5 6 6 5 5 5 1 1 , r G.Y.Y.Y.n.I.L.T.T.",
+"T.T.f.Y.j V $ $ ; , 2 D Z 9 9 9 u 7 9 8 6 2 f H.Y.Y.Y.n.I.S.T.T.",
+"T.T.C.Y.z 9 $ ; , 2 6 C K Z b V V V v u 9 8 ! Y.Y.Y.Y.n.U.S.T.T.",
+"T.T.k.Y.( 2 ; < 2 6 9 v L } A A A A Z V B i r.Y.Y.Y.Y.n.I.D.T.T.",
+"T.T.f.Y.( ; ; 2 6 9 B V J ..} F F D D A C *.U.Y.Y.Y.Y.n.I.A.T.T.",
+"T.T.S.Y.( : 2 5 p I h Z F X.+.} L K H S -.J.Y.Y.Y.Y.Y.n.I.P.T.T.",
+"T.T.a.Y.M : 4 Q v.U.v.:.G | $.#. .} [ 1.U.Y.Y.Y.Y.Y.Y.n.I.Z.T.T.",
+"T.T.D.Y.x < ~ H.Y.Y.Y.Y.,.{ $.h.@.o.w.Y.Y.Y.Y.Y.Y.Y.Y.n.I.U.T.T.",
+"T.T.i.Y.x g V. x.Y.U.) G.R X.l.8.r.Y.Y.Y.Y.Y.Y.Y.Y.Y.z.I.j.T.T.",
+"T.T.L.Y.x E Y.H.K.Y.V.P H.W @.6.r.Y.Y.Y.K.Y.Y.Y.Y.v.v.e.I.U.T.T.",
+"T.T.u.Y.Y ` Y.Y.2.P S.U.K./ %.e.Y.Y.Y.J.Y.Y.Y.Y.Y.K.n.z.U.f.T.T.",
+"T.T.L.Y.<.9.Y.Y.Y.I.Y.U.J./ ` U.Y.Y.G.Y.Y.Y.Y.Y.Y.Y.U.z.I.Y.T.T.",
+"T.T.i.Y.t.B.Y.Y.Y.Y.Y.U.K.-.1.Y.Y.U.B.Y.Y.Y.Y.Y.Y.Y.V.n.I.j.T.T.",
+"T.T.L.Y.t.m.Y.Y.Y.Y.Y.Y.U.y.3.Y.Y.I.K.Y.Y.Y.Y.Y.J.V.Y.n.I.U.T.T.",
+"T.T.p.Y.5.y.J.J.J.J.J.J.J.J.c.J.J.J.J.J.H.n.v.v.G.J.J.r.U.k.T.T.",
+"T.T.S.Y.b.b.M.b.b.b.M.b.b.b.m.m.b.b.M.b.M.b.b.b.b.m.b.b.Y.U.T.T.",
+"T.T.d.Y.f.f.Y.j.f.k.Y.Z.C.Z.L.L.Z.A.Y.j.Y.j.j.j.j.Y.k.k.Y.Z.T.T.",
+"T.T.A.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.Y.L.T.T.",
+"T.T.j.Y.j.Y.k.Y.C.U.Z.L.A.S.L.Z.P.Z.U.k.Y.f.Y.j.Y.k.U.Z.L.S.T.T.",
+"T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T.T."
+};
diff --git a/src/patches/debian-hacks/Icedove-branding.patch b/src/patches/debian-hacks/Icedove-branding.patch
new file mode 100644
index 0000000..bc57894
--- /dev/null
+++ b/src/patches/debian-hacks/Icedove-branding.patch
@@ -0,0 +1,37 @@
+From: =?utf-8?q?Guido_G=C3=BCnther?= <agx@sigxcpu.org>
+Date: Sat, 24 Nov 2012 11:36:16 +0100
+Subject: Icedove branding
+
+---
+ im/app/application.ini | 2 +-
+ mail/confvars.sh | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/im/app/application.ini b/im/app/application.ini
+index 856b900..9ffa5d8 100644
+--- a/im/app/application.ini
++++ b/im/app/application.ini
+@@ -4,7 +4,7 @@
+
+ #filter substitution
+ [App]
+-Name=Instantbird
++Name=Icedove
+ Version=@APP_VERSION@
+ BuildID=@GRE_BUILDID@
+ #ifdef MOZ_SOURCE_REPO
+diff --git a/mail/confvars.sh b/mail/confvars.sh
+index bbf6f2d..57d0097 100644
+--- a/mail/confvars.sh
++++ b/mail/confvars.sh
+@@ -3,8 +3,8 @@
+ # License, v. 2.0. If a copy of the MPL was not distributed with this
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+-MOZ_APP_BASENAME=Thunderbird
+-MOZ_APP_NAME=thunderbird
++MOZ_APP_BASENAME=Icedove
++MOZ_APP_NAME=icedove
+ MOZ_UPDATER=1
+ MOZ_THUNDERBIRD=1
+ MOZ_APP_STATIC_INI=1
diff --git a/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch b/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
index 95c4b40..aaa72c5 100644
--- a/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
+++ b/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
@@ -8,20 +8,15 @@ addon-checking/installing/updating will work
Closes: #565559
---
- mail/app/profile/all-thunderbird.js | 28 +++++++++++-----------
+ mail/app/profile/all-thunderbird.js | 33 +++++++++++-----------
.../en-US/chrome/messenger/accountCreation.dtd | 2 +-
- 2 files changed, 15 insertions(+), 15 deletions(-)
+ 2 files changed, 18 insertions(+), 17 deletions(-)
diff --git a/mail/app/profile/all-thunderbird.js b/mail/app/profile/all-thunderbird.js
-index e8db9cf..d607136 100644
+index db3b25d..ac240c6 100644
--- a/mail/app/profile/all-thunderbird.js
+++ b/mail/app/profile/all-thunderbird.js
-@@ -1,4 +1,3 @@
--/* -*- Mode: JavaScript; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
- /* This Source Code Form is subject to the terms of the Mozilla Public
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-@@ -120,7 +119,7 @@ pref("app.update.url", "https://aus4.mozilla.org/update/3/%PRODUCT%/%VERSION%/%B
+@@ -118,7 +118,7 @@ pref("app.update.url", "https://aus5.mozilla.org/update/6/%PRODUCT%/%VERSION%/%B
pref("app.update.url.manual", "http://www.getthunderbird.com");
// A default value for the "More information about this update" link
// supplied in the "An update is available" page of the update wizard.
@@ -30,7 +25,15 @@ index e8db9cf..d607136 100644
// User-settable override to app.update.url for testing purposes.
//pref("app.update.url.override", "");
-@@ -149,7 +148,7 @@ pref("toolkit.crashreporter.infoURL",
+@@ -140,14 +140,14 @@ pref("app.update.service.enabled", true);
+ #endif
+
+ // Release notes URL
+-pref("app.releaseNotesURL", "http://live.mozillamessaging.com/%APP%/releasenotes?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
++pref("app.releaseNotesURL", "http://live.mozillamessaging.com/thunderbird/releasenotes?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
+
+ // URL for "Learn More" for Crash Reporter.
+ pref("toolkit.crashreporter.infoURL",
"http://www.mozilla.org/thunderbird/legal/privacy/#crash-reporter");");
// Base URL for web-based support pages.
@@ -39,17 +42,21 @@ index e8db9cf..d607136 100644
// Show error messages in error console.
pref("javascript.options.showInConsole", true);
-@@ -178,18 +177,18 @@ pref("extensions.autoDisableScopes", 15);
+@@ -177,20 +177,20 @@ pref("extensions.autoDisableScopes", 15);
// Preferences for AMO integration
pref("extensions.getAddons.cache.enabled", true);
pref("extensions.getAddons.maxResults", 15);
-pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%");
-pref("extensions.getAddons.getWithPerformance.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
+-pref("extensions.getAddons.link.url", "https://addons.mozilla.org/%LOCALE%/%APP%/");
+-pref("extensions.getAddons.recommended.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
-pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/%APP%/search?q=%TERMS%");
-pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
-pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/%APP%/discovery/pane/%VERSION%/%OS%");
+pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%");
+pref("extensions.getAddons.getWithPerformance.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
++pref("extensions.getAddons.link.url", "https://addons.mozilla.org/%LOCALE%/thunderbird/");
++pref("extensions.getAddons.recommended.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
+pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/search?q=%TERMS%");
+pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
+pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/discovery/pane/%VERSION%/%OS%");
@@ -65,7 +72,7 @@ index e8db9cf..d607136 100644
// Enables some extra Extension System Logging (can reduce performance)
pref("extensions.logging.enabled", false);
-@@ -209,7 +208,8 @@ pref("extensions.update.background.url", "https://versioncheck-bg.addons.mozilla
+@@ -210,7 +210,8 @@ pref("extensions.update.background.url", "https://versioncheck-bg.addons.mozilla
pref("extensions.update.interval", 86400); // Check for updates to Extensions and
// Themes every day
@@ -75,16 +82,16 @@ index e8db9cf..d607136 100644
pref("extensions.dss.switchPending", false); // Non-dynamic switch pending after next
pref("extensions.{972ce4c6-7e08-4474-a285-3208198ce6fd}.name", "chrome://messenger/locale/messenger.properties");
-@@ -424,7 +424,7 @@ pref("browser.helperApps.deleteTempFileOnExit", true);
+@@ -429,7 +430,7 @@ pref("browser.helperApps.deleteTempFileOnExit", true);
pref("spellchecker.dictionary", "");
// Dictionary download preference
-pref("spellchecker.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/%APP%/dictionaries/");
-+pref("spellchecker.dictionaries.download.url", "https://addons.mozilla.com/%LOCALE%/thunderbird/dictionaries/");
++pref("spellchecker.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/thunderbird/dictionaries/");
// profile.force.migration can be used to bypass the migration wizard, forcing migration from a particular
// mail application without any user intervention. Possible values are:
-@@ -559,7 +559,7 @@ pref("mailnews.database.global.logging.console", true);
+@@ -564,7 +565,7 @@ pref("mailnews.database.global.logging.console", true);
pref("mailnews.database.global.search.msg.limit", 1000);
// page to load to find good header add-ons
@@ -93,7 +100,7 @@ index e8db9cf..d607136 100644
// Serif fonts look dated. Switching those language families to sans-serif
// where we think it makes sense. Worth investigating for other font families
-@@ -751,7 +751,7 @@ pref("plugins.hide_infobar_for_carbon_failure_plugin", false);
+@@ -756,7 +757,7 @@ pref("plugins.hide_infobar_for_carbon_failure_plugin", false);
pref("plugins.update.url", "https://www.mozilla.org/%LOCALE%/plugincheck/");
pref("plugins.update.notifyUser", false);
diff --git a/src/patches/icedove/fix-installdir.patch b/src/patches/icedove/fix-installdir.patch
index 36703fd..be2660b 100644
--- a/src/patches/icedove/fix-installdir.patch
+++ b/src/patches/icedove/fix-installdir.patch
@@ -7,10 +7,10 @@ Subject: fix installdir
1 file changed, 9 insertions(+)
diff --git a/mail/app/Makefile.in b/mail/app/Makefile.in
-index 8f81701..a65d48d 100644
+index 74c164b..1c9ea15 100644
--- a/mail/app/Makefile.in
+++ b/mail/app/Makefile.in
-@@ -108,11 +108,20 @@ libs:: $(addprefix icons/$(MOZ_WIDGET_TOOLKIT)/,$(DESKTOP_ICON_FILES))
+@@ -100,11 +100,20 @@ libs:: $(addprefix icons/$(MOZ_WIDGET_TOOLKIT)/,$(DESKTOP_ICON_FILES))
libs:: $(addprefix $(DIST)/branding/,$(BRANDED_ICON_FILES))
$(INSTALL) $(IFLAGS1) $^ $(DIST)/bin/chrome/icons/default
@@ -22,7 +22,7 @@ index 8f81701..a65d48d 100644
+ $(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(installdir)/chrome/icons/default
endif
- ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
+ ifdef MOZ_WIDGET_GTK
libs::
$(INSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DIST)/bin/chrome/icons/default
+
diff --git a/src/patches/icedove/no-dynamic-nss-softokn.patch b/src/patches/icedove/no-dynamic-nss-softokn.patch
deleted file mode 100644
index 330ea12..0000000
--- a/src/patches/icedove/no-dynamic-nss-softokn.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Alexander Sack <asac@debian.org>
-Date: Wed, 27 Jan 2010 19:06:07 +0100
-Subject: no dynamic nss softokn
-
----
- ldap/sdks/c-sdk/component_versions.mk | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ldap/sdks/c-sdk/component_versions.mk b/ldap/sdks/c-sdk/component_versions.mk
-index 2ad6347..5f61b57 100644
---- a/ldap/sdks/c-sdk/component_versions.mk
-+++ b/ldap/sdks/c-sdk/component_versions.mk
-@@ -46,7 +46,7 @@ NSPR_RELEASE_TREE = $(COMPONENTS_DIR)
- # NSS - Network Security Services
- NSSVERS = 3
- NSS_RELEASE_TAG = NSS_3_9_3_RTM
--NSS_DYNAMIC_SOFTOKN = 1
-+NSS_DYNAMIC_SOFTOKN = 0
- NSS_RELEASE_TREE = $(COMPONENTS_DIR)
-
- # SVRCORE - Client/server utility library
diff --git a/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch b/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
index c0a5292..a73af99 100644
--- a/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
+++ b/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
@@ -22,7 +22,7 @@ index ae6dbd2..f71d848 100644
<em:description>An integrated calendar for Thunderbird</em:description>
#ifdef LIGHTNING_PRERELEASE_VERSION
diff --git a/calendar/locales/en-US/chrome/calendar/timezones.properties b/calendar/locales/en-US/chrome/calendar/timezones.properties
-index 882cc70..8b395bd 100644
+index f15d3ab..ee96858 100644
--- a/calendar/locales/en-US/chrome/calendar/timezones.properties
+++ b/calendar/locales/en-US/chrome/calendar/timezones.properties
@@ -4,7 +4,7 @@
@@ -35,7 +35,7 @@ index 882cc70..8b395bd 100644
pref.timezone.floating=Local Time
diff --git a/calendar/locales/en-US/chrome/lightning/lightning.properties b/calendar/locales/en-US/chrome/lightning/lightning.properties
-index 78b15b6..6bf260f 100644
+index 3c61d82..2089f1c 100644
--- a/calendar/locales/en-US/chrome/lightning/lightning.properties
+++ b/calendar/locales/en-US/chrome/lightning/lightning.properties
@@ -3,12 +3,12 @@
diff --git a/src/patches/series b/src/patches/series
index cf3f11b..19b3d86 100644
--- a/src/patches/series
+++ b/src/patches/series
@@ -1,4 +1,4 @@
-icedove/fix-installdir.patch
-icedove/no-dynamic-nss-softokn.patch
+debian-hacks/Icedove-branding.patch
icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
+icedove/fix-installdir.patch
iceowl/Change-extension-s-name-to-Iceowl.patch