summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rwxr-xr-xrelease.sh2
-rw-r--r--src/icedove-branding/Makefile.in29
-rw-r--r--src/icedove-branding/branding.nsi16
-rw-r--r--src/icedove-branding/jar.mn6
-rw-r--r--src/icedove-branding/locales/en-US/brand.dtd1
-rw-r--r--src/icedove-branding/locales/jar.mn6
-rw-r--r--src/icedove-branding/moz.build38
-rw-r--r--src/icedove.appdata.xml39
-rw-r--r--src/patches/icedove/Icedove-branding.patch15
-rw-r--r--src/patches/icedove/branding_migration-wizard_addon-manager.patch78
-rw-r--r--src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch87
-rw-r--r--src/patches/icedove/icedove-branding.patch29
-rw-r--r--src/patches/iceowl/NOTES2
-rw-r--r--src/patches/series5
15 files changed, 189 insertions, 166 deletions
diff --git a/.gitignore b/.gitignore
index b642e30..1341238 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
+# build dirs
+icedove-*/
# release tarballs
*.tar.xz
diff --git a/release.sh b/release.sh
index e9ff22a..7b82418 100755
--- a/release.sh
+++ b/release.sh
@@ -3,7 +3,7 @@
set -eu
pkgname=icedove
-brandingver=68.2
+brandingver=102
brandingrel=1
srcdir=src
diff --git a/src/icedove-branding/Makefile.in b/src/icedove-branding/Makefile.in
deleted file mode 100644
index 1573672..0000000
--- a/src/icedove-branding/Makefile.in
+++ /dev/null
@@ -1,29 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# Branding Makefile for Icedove branding
-
-include $(topsrcdir)/config/rules.mk
-
-MAIL_APP_FILES = \
- default16.png \
- default22.png \
- default24.png \
- default32.png \
- default48.png \
- default256.png \
- $(NULL)
-
-GARBAGE += $(MAIL_APP_FILES)
-
-export:: $(MAIL_APP_FILES)
- $(NSINSTALL) -D $(DIST)/branding
- cp $^ $(DIST)/branding/
-
-default16.png: SIZE=16
-default22.png: SIZE=22
-default24.png: SIZE=24
-default32.png: SIZE=32
-default48.png: SIZE=48
-default256.png: SIZE=256
diff --git a/src/icedove-branding/branding.nsi b/src/icedove-branding/branding.nsi
deleted file mode 100644
index 3ad1594..0000000
--- a/src/icedove-branding/branding.nsi
+++ /dev/null
@@ -1,16 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# # License, v. 2.0. If a copy of the MPL was not distributed with this
-# # file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# NSIS defines for nightly builds.
-# The release build branding.nsi is located in other-license/branding/thunderbird/
-
-# BrandFullNameInternal is used for some registry and file system values
-# instead of BrandFullName and typically should not be modified.
-!define BrandFullNameInternal "Parabola Icedove"
-!define BrandFullName "Parabola Icedove"
-!define CompanyName "Parabola GNU/Linux-libre"
-!define URLInfoAbout "https://wiki.parabola.nu/Icedove"
-!define URLUpdateInfo "https://wiki.parabola.nu/Icedove"
-!define URLSystemRequirements "https://wiki.parabola.nu/Icedove"
-!define SurveyURL "https://wiki.parabola.nu/Icedove"
diff --git a/src/icedove-branding/jar.mn b/src/icedove-branding/jar.mn
index 434d05a..e219bd6 100644
--- a/src/icedove-branding/jar.mn
+++ b/src/icedove-branding/jar.mn
@@ -1,7 +1,4 @@
#filter substitution
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
messenger.jar:
% content branding %content/branding/
@@ -10,5 +7,6 @@ messenger.jar:
content/branding/about.png (content/about.png)
content/branding/icon48.png (default48.png)
content/branding/icon64.png (default64.png)
+ content/branding/icon128.png (default128.png)
content/branding/aboutDialog.css (content/aboutDialog.css)
- ../classic/skin/classic/messenger/icons/new-mail-alert.png (default48.png)
+ ../classic/skin/classic/messenger/icons/new-mail-alert.png (default48.png)
diff --git a/src/icedove-branding/locales/en-US/brand.dtd b/src/icedove-branding/locales/en-US/brand.dtd
index 0abd6d6..0f11c3a 100644
--- a/src/icedove-branding/locales/en-US/brand.dtd
+++ b/src/icedove-branding/locales/en-US/brand.dtd
@@ -1,5 +1,6 @@
<!ENTITY brandShortName "Icedove">
<!ENTITY brandShorterName "Icedove">
<!ENTITY brandFullName "Parabola Icedove">
+<!ENTITY brandProductName "Icedove">
<!ENTITY vendorShortName "Parabola">
<!ENTITY trademarkInfo.part1 " ">
diff --git a/src/icedove-branding/locales/jar.mn b/src/icedove-branding/locales/jar.mn
index 708e5c9..e66c4a9 100644
--- a/src/icedove-branding/locales/jar.mn
+++ b/src/icedove-branding/locales/jar.mn
@@ -1,4 +1,10 @@
#filter substitution
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+[localization] @AB_CD@.jar:
+ branding (en-US/**/*.ftl)
@AB_CD@.jar:
% locale branding @AB_CD@ %locale/@AB_CD@/branding/
diff --git a/src/icedove-branding/moz.build b/src/icedove-branding/moz.build
index e53e1c4..7c8351d 100644
--- a/src/icedove-branding/moz.build
+++ b/src/icedove-branding/moz.build
@@ -7,15 +7,31 @@ DIRS += ['locales']
JAR_MANIFESTS += ['jar.mn']
-JS_PREFERENCE_FILES += ['thunderbird-branding.js']
+@template
+def IcedoveBranding():
+ JS_PREFERENCE_FILES += [
+ 'thunderbird-branding.js',
+ ]
-FINAL_TARGET_FILES.chrome.icons.default += [
- 'default128.png',
- 'default16.png',
- 'default22.png',
- 'default24.png',
- 'default256.png',
- 'default32.png',
- 'default48.png',
- 'default64.png',
-]
+ if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'windows':
+ FINAL_TARGET_FILES += [
+ 'thunderbird.VisualElementsManifest.xml',
+ ]
+ FINAL_TARGET_FILES.VisualElements += [
+ 'VisualElements_150.png',
+ 'VisualElements_70.png',
+ ]
+ elif CONFIG['MOZ_WIDGET_TOOLKIT'] == 'gtk':
+ FINAL_TARGET_FILES.chrome.icons.default += [
+ 'default128.png',
+ 'default16.png',
+ 'default22.png',
+ 'default24.png',
+ 'default256.png',
+ 'default32.png',
+ 'default48.png',
+ 'default64.png',
+ #'TB-symbolic.svg', # TODO: icedove-symbolic.svg
+ ]
+
+IcedoveBranding()
diff --git a/src/icedove.appdata.xml b/src/icedove.appdata.xml
new file mode 100644
index 0000000..277b4ed
--- /dev/null
+++ b/src/icedove.appdata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop-application">
+ <id>icedove.desktop</id>
+ <launchable type="desktop-id">icedove.desktop</launchable>
+ <metadata_license>CC0-1.0</metadata_license>
+ <name>Icedove</name>
+ <summary>Icedove is an e-mail, news-feed, chat, and calendar client</summary>
+ <description>
+ <p>
+ Icedove is an e-mail, news-feed, chat, and calendar client. 'Nuff said :)
+ </p>
+ </description>
+ <categories>
+ <category>Calendar</category>
+ <category>Email</category>
+ <category>Office</category>
+ </categories>
+
+ <url type="homepage">https://wiki.parabola.nu/Icedove</url>
+ <url type="bugtracker">https://labs.parabola.nu/</url>
+ <url type="help">http://forum.parabola.nu/</url>
+
+ <project_group>Parabola</project_group>
+ <project_license>MPL-2.0</project_license>
+ <developer_name>Parabola GNU/Linux-libre</developer_name>
+
+ <icon type="remote" width="256" height="256">https://wiki.parabola.nu/images/e/ea/Icedove_icon.png</icon>
+
+ <mimetypes>
+ <mimetype>message/rfc822</mimetype>
+ <mimetype>x-scheme-handler/mailto</mimetype>
+ <mimetype>text/calendar</mimetype>
+ <mimetype>text/vcard</mimetype>
+ <mimetype>text/x-vcard</mimetype>
+ </mimetypes>
+
+ <!-- distributors: yes, this is a real person -->
+ <update_contact>dev@lists.parabola.nu</update_contact>
+</component>
diff --git a/src/patches/icedove/Icedove-branding.patch b/src/patches/icedove/Icedove-branding.patch
deleted file mode 100644
index ea7f564..0000000
--- a/src/patches/icedove/Icedove-branding.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/comm/mail/confvars.sh b/comm/mail/confvars.sh
-index bbf6f2d..57d0097 100644
---- a/comm/mail/confvars.sh
-+++ b/comm/mail/confvars.sh
-@@ -3,8 +3,8 @@
- # License, v. 2.0. If a copy of the MPL was not distributed with this
- # file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
--MOZ_APP_BASENAME=Thunderbird
--MOZ_APP_NAME=thunderbird
-+MOZ_APP_BASENAME=Icedove
-+MOZ_APP_NAME=icedove
- MOZ_UPDATER=1
-
- if test "$OS_ARCH" = "WINNT"; then
diff --git a/src/patches/icedove/branding_migration-wizard_addon-manager.patch b/src/patches/icedove/branding_migration-wizard_addon-manager.patch
new file mode 100644
index 0000000..883af34
--- /dev/null
+++ b/src/patches/icedove/branding_migration-wizard_addon-manager.patch
@@ -0,0 +1,78 @@
+diff --git a/comm/mail/app/profile/all-thunderbird.js b/comm/mail/app/profile/all-thunderbird.js
+index b95a999797..5ca66d8270 100644
+--- a/comm/mail/app/profile/all-thunderbird.js
++++ b/comm/mail/app/profile/all-thunderbird.js
+@@ -75,7 +75,7 @@ pref("app.update.BITS.enabled", false);
+ #endif
+
+ // Release notes URL
+-pref("app.releaseNotesURL", "https://live.thunderbird.net/%APP%/releasenotes?locale=%LOCALE%&version=%VERSION%&channel=%CHANNEL%&os=%OS%&buildid=%APPBUILDID%");
++pref("app.releaseNotesURL", "https://live.thunderbird.net/thunderbird/releasenotes?locale=%LOCALE%&version=%VERSION%&channel=%CHANNEL%&os=%OS%&buildid=%APPBUILDID%");
+
+ #ifdef XP_MACOSX
+ // If set to true, Thunderbird will automatically restart if it is left
+@@ -106,7 +106,7 @@ pref("datareporting.policy.firstRunURL", "https://www.mozilla.org/thunderbird/le
+ #endif
+
+ // Base URL for web-based support pages.
+-pref("app.support.baseURL", "https://support.thunderbird.net/%APP%/%VERSION%/%OS%/%LOCALE%/");
++pref("app.support.baseURL", "https://support.thunderbird.net/thunderbird/%VERSION%/%OS%/%LOCALE%/");
+
+ // Base url for web-based feedback pages.
+ pref("app.feedback.baseURL", "https://connect.mozilla.org/");
+@@ -163,16 +163,16 @@ pref("extensions.legacy.enabled", true);
+ // Preferences for AMO integration
+ pref("extensions.getAddons.cache.enabled", true);
+ pref("extensions.getAddons.maxResults", 15);
+-pref("extensions.getAddons.get.url", "https://services.addons.thunderbird.net/api/v3/addons/search/?guid=%IDS%&lang=%LOCALE%");
++pref("extensions.getAddons.get.url", "https://www.parabola.nu/packages/?q=icedove-");
+ pref("extensions.getAddons.compatOverides.url", "https://services.addons.thunderbird.net/api/v3/addons/compat-override/?guid=%IDS%&lang=%LOCALE%");
+-pref("extensions.getAddons.link.url", "https://addons.thunderbird.net/%LOCALE%/%APP%/");
+-pref("browser.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/%APP%/language-tools/");
+-pref("extensions.getAddons.recommended.url", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
+-pref("extensions.getAddons.search.browseURL", "https://addons.thunderbird.net/%LOCALE%/%APP%/search/?q=%TERMS%&appver=%VERSION%&platform=%OS%");
+-pref("extensions.getAddons.search.url", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
+-pref("extensions.webservice.discoverURL", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/discovery/pane/%VERSION%/%OS%");
++pref("extensions.getAddons.link.url", "https://www.parabola.nu/packages/?q=icedove-");
++pref("browser.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/thunderbird/language-tools/");
++pref("extensions.getAddons.recommended.url", "https://www.parabola.nu/packages/?q=icedove-");
++pref("extensions.getAddons.search.browseURL", "https://www.parabola.nu/packages/?q=icedove-");
++pref("extensions.getAddons.search.url", "https://www.parabola.nu/packages/?q=icedove-");
++pref("extensions.webservice.discoverURL", "");
+ pref("extensions.getAddons.langpacks.url", "https://services.addons.thunderbird.net/api/v3/addons/language-tools/?app=thunderbird&type=language&appversion=%VERSION%");
+-pref("extensions.getAddons.discovery.api_url", "https://services.addons.thunderbird.net/api/v4/discovery/?lang=%LOCALE%&edition=%DISTRIBUTION%");
++pref("extensions.getAddons.discovery.api_url", "");
+
+ // Blocklist preferences
+ pref("extensions.blocklist.detailsURL", "https://blocked.cdn.mozilla.net/");
+@@ -491,7 +491,7 @@ pref("browser.privatebrowsing.autostart", false);
+
+ pref("spellchecker.dictionary", "");
+ // Dictionary download preference
+-pref("spellchecker.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/%APP%/dictionaries/");
++pref("spellchecker.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/thunderbird/dictionaries/");
+
+ // profile.force.migration can be used to bypass the migration wizard, forcing migration from a particular
+ // mail application without any user intervention. Possible values are:
+diff --git a/toolkit/locales/en-US/toolkit/about/aboutAddons.ftl b/toolkit/locales/en-US/toolkit/about/aboutAddons.ftl
+index 3316df4c71..55d0b440e0 100644
+--- a/toolkit/locales/en-US/toolkit/about/aboutAddons.ftl
++++ b/toolkit/locales/en-US/toolkit/about/aboutAddons.ftl
+@@ -5,7 +5,7 @@
+ addons-page-title = Add-ons Manager
+
+ search-header =
+- .placeholder = Search addons.mozilla.org
++ .placeholder = Search www.parabola.nu/packages
+ .searchbuttonlabel = Search
+
+ search-header-shortcut =
+@@ -478,7 +478,7 @@ shortcuts-heading = Manage Extension Shortcuts
+
+ default-heading-search-label = Find more add-ons
+ addons-heading-search-input =
+- .placeholder = Search addons.mozilla.org
++ .placeholder = Search www.parabola.nu/packages
+
+ addon-page-options-button =
+ .title = Tools for all add-ons
diff --git a/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch b/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
deleted file mode 100644
index d9062b7..0000000
--- a/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From: "Edward J. Shornock" <ed.shornock@gmail.com>
-Date: Mon, 1 Feb 2010 19:16:08 +0100
-Subject: fix branding in migration wizard and the addon manager
-
-Replace /Thunderbird/ with /Icedove/
-Update %APP% with the respective Mozilla names so
-addon-checking/installing/updating will work
-
-Closes: #565559
----
- mail/app/profile/all-thunderbird.js | 33 +++++++++++-----------
- .../en-US/chrome/messenger/accountCreation.dtd | 2 +-
- 2 files changed, 18 insertions(+), 17 deletions(-)
-
-diff --git a/comm/mail/app/profile/all-thunderbird.js b/comm/mail/app/profile/all-thunderbird.js
-index db3b25d..ac240c6 100644
---- a/comm/mail/app/profile/all-thunderbird.js
-+++ b/comm/mail/app/profile/all-thunderbird.js
-@@ -73,7 +73,7 @@ pref("app.update.url", "https://aus.thun
- pref("app.update.url.manual", "https://www.thunderbird.net");
- // A default value for the "More information about this update" link
- // supplied in the "An update is available" page of the update wizard.
--pref("app.update.url.details", "https://www.thunderbird.net/%LOCALE%/%APP%/releases/");
-+pref("app.update.url.details", "https://www.thunderbird.net/%LOCALE%/thunderbird/releases/");
-
- // app.update.promptWaitTime is in branding section
-
-@@ -93,17 +93,17 @@ pref("app.update.BITS.inTrialGroup", fal
- #endif
-
- // Release notes URL
--pref("app.releaseNotesURL", "https://live.thunderbird.net/%APP%/releasenotes?locale=%LOCALE%&version=%VERSION%&channel=%CHANNEL%&os=%OS%&buildid=%APPBUILDID%");
-+pref("app.releaseNotesURL", "https://live.thunderbird.net/thunderbird/releasenotes?locale=%LOCALE%&version=%VERSION%&channel=%CHANNEL%&os=%OS%&buildid=%APPBUILDID%");
-
- // URL for "Learn More" for Crash Reporter.
- pref("toolkit.crashreporter.infoURL",
- "https://www.mozilla.org/thunderbird/legal/privacy/#crash-reporter");
-
- // Base URL for web-based support pages.
--pref("app.support.baseURL", "https://support.thunderbird.net/%LOCALE%/%APP%/%APPBUILDID%/");
-+pref("app.support.baseURL", "https://support.thunderbird.net/%LOCALE%/thunderbird/%APPBUILDID%/");
-
- // Base url for web-based feedback pages.
--pref("app.feedback.baseURL", "https://input.mozilla.org/%LOCALE%/feedback/%APP%/%VERSION%/");
-+pref("app.feedback.baseURL", "https://input.mozilla.org/%LOCALE%/feedback/thunderbird/%VERSION%/");
-
- // Show error messages in error console.
- pref("javascript.options.showInConsole", true);
-@@ -152,11 +152,11 @@ pref("extensions.getAddons.cache.enabled
- pref("extensions.getAddons.maxResults", 15);
- pref("extensions.getAddons.get.url", "https://services.addons.thunderbird.net/api/v3/addons/search/?guid=%IDS%&lang=%LOCALE%");
- pref("extensions.getAddons.compatOverides.url", "https://services.addons.thunderbird.net/api/v3/addons/compat-override/?guid=%IDS%&lang=%LOCALE%");
--pref("extensions.getAddons.link.url", "https://addons.thunderbird.net/%LOCALE%/%APP%/");
--pref("extensions.getAddons.recommended.url", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
--pref("extensions.getAddons.search.browseURL", "https://addons.thunderbird.net/%LOCALE%/%APP%/search/?q=%TERMS%");
--pref("extensions.getAddons.search.url", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
--pref("extensions.webservice.discoverURL", "https://services.addons.thunderbird.net/%LOCALE%/%APP%/discovery/pane/%VERSION%/%OS%");
-+pref("extensions.getAddons.link.url", "https://addons.thunderbird.net/%LOCALE%/thunderbird/");
-+pref("extensions.getAddons.recommended.url", "https://services.addons.thunderbird.net/%LOCALE%/thunderbird/api/%API_VERSION%/list/recommended/all/%MAX_RESULTS%/%OS%/%VERSION%?src=thunderbird");
-+pref("extensions.getAddons.search.browseURL", "https://addons.thunderbird.net/%LOCALE%/thunderbird/search/?q=%TERMS%");
-+pref("extensions.getAddons.search.url", "https://services.addons.thunderbird.net/%LOCALE%/thunderbird/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
-+pref("extensions.webservice.discoverURL", "https://services.addons.thunderbird.net/%LOCALE%/thunderbird/discovery/pane/%VERSION%/%OS%");
- pref("extensions.getAddons.siteRegExp", "^https://.*addons\\.thunderbird\\.net");
- pref("extensions.getAddons.langpacks.url", "https://services.addons.thunderbird.net/api/v3/addons/language-tools/?app=thunderbird&type=language&appversion=%VERSION%");
-
-@@ -403,7 +403,7 @@ pref("browser.helperApps.deleteTempFileO
-
- pref("spellchecker.dictionary", "");
- // Dictionary download preference
--pref("spellchecker.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/%APP%/dictionaries/");
-+pref("spellchecker.dictionaries.download.url", "https://addons.thunderbird.net/%LOCALE%/thunderbird/dictionaries/");
-
- // profile.force.migration can be used to bypass the migration wizard, forcing migration from a particular
- // mail application without any user intervention. Possible values are:
-diff --git a/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd b/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd
-index 3a9c30c..65e6203 100644
---- a/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd
-+++ b/comm/mail/locales/en-US/chrome/messenger/accountCreation.dtd
-@@ -91,7 +91,7 @@
- <!ENTITY changeSettings.label "Change Settings">
- <!ENTITY changeSettings.accesskey "S">
-
--<!ENTITY contactYourProvider.description "&brandShortName; can allow you to get to your mail using the provided configurations. However, you should contact your administrator or email provider regarding these improper connections. See the Thunderbird FAQ for more information.">
-+<!ENTITY contactYourProvider.description "&brandShortName; can allow you to get to your mail using the provided configurations. However, you should contact your administrator or email provider regarding these improper connections. See the Icedove FAQ for more information.">
-
- <!ENTITY insecureServer.tooltip.title "Warning! This is an insecure server.">
- <!ENTITY insecureServer.tooltip.details "Click circle for more details.">
diff --git a/src/patches/icedove/icedove-branding.patch b/src/patches/icedove/icedove-branding.patch
new file mode 100644
index 0000000..63ebc5d
--- /dev/null
+++ b/src/patches/icedove/icedove-branding.patch
@@ -0,0 +1,29 @@
+diff --git a/comm/mail/confvars.sh b/comm/mail/confvars.sh
+index 885654d703..c6871b3b5f 100755
+--- a/comm/mail/confvars.sh
++++ b/comm/mail/confvars.sh
+@@ -3,7 +3,8 @@
+ # License, v. 2.0. If a copy of the MPL was not distributed with this
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+-MOZ_APP_NAME=thunderbird
++MOZ_APP_BASENAME=Icedove
++MOZ_APP_NAME=icedove
+
+ if test "$OS_ARCH" = "WINNT"; then
+ if ! test "$HAVE_64BIT_BUILD"; then
+diff --git a/comm/mail/moz.configure b/comm/mail/moz.configure
+index 53e923a64e..39b015db72 100644
+--- a/comm/mail/moz.configure
++++ b/comm/mail/moz.configure
+@@ -7,8 +7,8 @@
+ set_config("MOZ_THUNDERBIRD", True)
+ set_define("MOZ_THUNDERBIRD", True)
+
+-imply_option("MOZ_APP_BASENAME", "Thunderbird")
+-set_config("MOZ_APPUPDATE_HOST", "aus.thunderbird.net")
++imply_option("MOZ_APP_BASENAME", "Icedove")
++set_config("MOZ_APPUPDATE_HOST", "")
+
+ imply_option("--enable-default-browser-agent", False)
+ imply_option("MOZ_REQUIRE_SIGNING", False)
diff --git a/src/patches/iceowl/NOTES b/src/patches/iceowl/NOTES
new file mode 100644
index 0000000..a475614
--- /dev/null
+++ b/src/patches/iceowl/NOTES
@@ -0,0 +1,2 @@
+'Change-extension-s-name-to-Iceowl.patch' seems to have no application in v78+
+it has been removed from the patch series
diff --git a/src/patches/series b/src/patches/series
index 11bb16d..f324a75 100644
--- a/src/patches/series
+++ b/src/patches/series
@@ -1,4 +1,3 @@
-icedove/Icedove-branding.patch
-icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
+icedove/icedove-branding.patch
+icedove/branding_migration-wizard_addon-manager.patch
icedove/fix-installdir.patch
-iceowl/Change-extension-s-name-to-Iceowl.patch