summaryrefslogtreecommitdiff
path: root/src/patches
diff options
context:
space:
mode:
Diffstat (limited to 'src/patches')
-rw-r--r--src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch117
-rw-r--r--src/patches/icedove/fix-installdir.patch33
-rw-r--r--src/patches/icedove/no-dynamic-nss-softokn.patch21
-rw-r--r--src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch57
-rw-r--r--src/patches/series4
5 files changed, 232 insertions, 0 deletions
diff --git a/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch b/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
new file mode 100644
index 0000000..95c4b40
--- /dev/null
+++ b/src/patches/icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
@@ -0,0 +1,117 @@
+From: "Edward J. Shornock" <ed.shornock@gmail.com>
+Date: Mon, 1 Feb 2010 19:16:08 +0100
+Subject: fix branding in migration wizard and the addon manager
+
+Replace /Thunderbird/ with /Icedove/
+Update %APP% with the respective Mozilla names so
+addon-checking/installing/updating will work
+
+Closes: #565559
+---
+ mail/app/profile/all-thunderbird.js | 28 +++++++++++-----------
+ .../en-US/chrome/messenger/accountCreation.dtd | 2 +-
+ 2 files changed, 15 insertions(+), 15 deletions(-)
+
+diff --git a/mail/app/profile/all-thunderbird.js b/mail/app/profile/all-thunderbird.js
+index e8db9cf..d607136 100644
+--- a/mail/app/profile/all-thunderbird.js
++++ b/mail/app/profile/all-thunderbird.js
+@@ -1,4 +1,3 @@
+-/* -*- Mode: JavaScript; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+ /* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+@@ -120,7 +119,7 @@ pref("app.update.url", "https://aus4.mozilla.org/update/3/%PRODUCT%/%VERSION%/%B
+ pref("app.update.url.manual", "http://www.getthunderbird.com");
+ // A default value for the "More information about this update" link
+ // supplied in the "An update is available" page of the update wizard.
+-pref("app.update.url.details", "http://www.mozilla.org/%LOCALE%/%APP%/releases/");
++pref("app.update.url.details", "http://www.mozilla.org/%LOCALE%/thunderbird/releases/");
+ // User-settable override to app.update.url for testing purposes.
+ //pref("app.update.url.override", "");
+
+@@ -149,7 +148,7 @@ pref("toolkit.crashreporter.infoURL",
+ "http://www.mozilla.org/thunderbird/legal/privacy/#crash-reporter");");
+
+ // Base URL for web-based support pages.
+-pref("app.support.baseURL", "http://support.live.mozillamessaging.com/%LOCALE%/%APP%/%APPBUILDID%/");
++pref("app.support.baseURL", "http://support.live.mozillamessaging.com/%LOCALE%/thunderbird/%APPBUILDID%/");
+
+ // Show error messages in error console.
+ pref("javascript.options.showInConsole", true);
+@@ -178,18 +177,18 @@ pref("extensions.autoDisableScopes", 15);
+ // Preferences for AMO integration
+ pref("extensions.getAddons.cache.enabled", true);
+ pref("extensions.getAddons.maxResults", 15);
+-pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%");
+-pref("extensions.getAddons.getWithPerformance.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
+-pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/%APP%/search?q=%TERMS%");
+-pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
+-pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/%APP%/discovery/pane/%VERSION%/%OS%");
++pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%");
++pref("extensions.getAddons.getWithPerformance.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/guid:%IDS%?src=thunderbird&appOS=%OS%&appVersion=%VERSION%&tMain=%TIME_MAIN%&tFirstPaint=%TIME_FIRST_PAINT%&tSessionRestored=%TIME_SESSION_RESTORED%");
++pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/search?q=%TERMS%");
++pref("extensions.getAddons.search.url", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/api/%API_VERSION%/search/%TERMS%/all/%MAX_RESULTS%/%OS%/%VERSION%/%COMPATIBILITY_MODE%?src=thunderbird");
++pref("extensions.webservice.discoverURL", "https://services.addons.mozilla.org/%LOCALE%/thunderbird/discovery/pane/%VERSION%/%OS%");
+
+ // Blocklist preferences
+ pref("extensions.blocklist.enabled", true);
+ pref("extensions.blocklist.interval", 86400);
+ pref("extensions.blocklist.url", "https://blocklist.addons.mozilla.org/blocklist/3/%APP_ID%/%APP_VERSION%/%PRODUCT%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/%PING_COUNT%/%TOTAL_PING_COUNT%/%DAYS_SINCE_LAST_PING%/");
+-pref("extensions.blocklist.detailsURL", "https://addons.mozilla.org/%LOCALE%/%APP%/blocked/");
+-pref("extensions.blocklist.itemURL", "https://blocklist.addons.mozilla.org/%LOCALE%/%APP%/blocked/%blockID%");
++pref("extensions.blocklist.detailsURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/blocked/");
++pref("extensions.blocklist.itemURL", "https://blocklist.addons.mozilla.org/%LOCALE%/thunderbird/blocked/%blockID%");
+
+ // Enables some extra Extension System Logging (can reduce performance)
+ pref("extensions.logging.enabled", false);
+@@ -209,7 +208,8 @@ pref("extensions.update.background.url", "https://versioncheck-bg.addons.mozilla
+ pref("extensions.update.interval", 86400); // Check for updates to Extensions and
+ // Themes every day
+
+-pref("extensions.dss.enabled", false); // Dynamic Skin Switching
++pref("extensions.getMoreThemesURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/themes/");
++pref("extensions.dss.enabled", false); // Dynamic Skin Switching
+ pref("extensions.dss.switchPending", false); // Non-dynamic switch pending after next
+
+ pref("extensions.{972ce4c6-7e08-4474-a285-3208198ce6fd}.name", "chrome://messenger/locale/messenger.properties");
+@@ -424,7 +424,7 @@ pref("browser.helperApps.deleteTempFileOnExit", true);
+
+ pref("spellchecker.dictionary", "");
+ // Dictionary download preference
+-pref("spellchecker.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/%APP%/dictionaries/");
++pref("spellchecker.dictionaries.download.url", "https://addons.mozilla.com/%LOCALE%/thunderbird/dictionaries/");
+
+ // profile.force.migration can be used to bypass the migration wizard, forcing migration from a particular
+ // mail application without any user intervention. Possible values are:
+@@ -559,7 +559,7 @@ pref("mailnews.database.global.logging.console", true);
+ pref("mailnews.database.global.search.msg.limit", 1000);
+
+ // page to load to find good header add-ons
+-pref("mailnews.migration.header_addons_url","http://live.mozillamessaging.com/%APP%/addons/search?q=header&locale=%LOCALE%&lver=%VERSION%&hver=%VERSION%&os=%OS%");
++pref("mailnews.migration.header_addons_url","http://live.mozillamessaging.com/thunderbird/addons/search?q=header&locale=%LOCALE%&lver=%VERSION%&hver=%VERSION%&os=%OS%");
+
+ // Serif fonts look dated. Switching those language families to sans-serif
+ // where we think it makes sense. Worth investigating for other font families
+@@ -751,7 +751,7 @@ pref("plugins.hide_infobar_for_carbon_failure_plugin", false);
+
+ pref("plugins.update.url", "https://www.mozilla.org/%LOCALE%/plugincheck/");
+ pref("plugins.update.notifyUser", false);
+-pref("plugins.crash.supportUrl", "https://live.mozillamessaging.com/%APP%/plugin-crashed?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
++pref("plugins.crash.supportUrl", "https://live.mozillamessaging.com/thunderbird/plugin-crashed?locale=%LOCALE%&version=%VERSION%&os=%OS%&buildid=%APPBUILDID%");
+
+ // Click-to-play has not been ported for TB yet, see bug 814168.
+ // The default plugin state should be changed to "ask to activate" when this
+diff --git a/mail/locales/en-US/chrome/messenger/accountCreation.dtd b/mail/locales/en-US/chrome/messenger/accountCreation.dtd
+index 3a9c30c..65e6203 100644
+--- a/mail/locales/en-US/chrome/messenger/accountCreation.dtd
++++ b/mail/locales/en-US/chrome/messenger/accountCreation.dtd
+@@ -78,7 +78,7 @@
+ <!ENTITY changeSettings.label "Change Settings">
+ <!ENTITY changeSettings.accesskey "S">
+
+-<!ENTITY contactYourProvider.description "&brandShortName; can allow you to get to your mail using the provided configurations. However, you should contact your administrator or email provider regarding these improper connections. See the Thunderbird FAQ for more information.">
++<!ENTITY contactYourProvider.description "&brandShortName; can allow you to get to your mail using the provided configurations. However, you should contact your administrator or email provider regarding these improper connections. See the Icedove FAQ for more information.">
+
+ <!ENTITY insecureServer.tooltip.title "Warning! This is an insecure server.">
+ <!ENTITY insecureServer.tooltip.details "Click circle for more details.">
diff --git a/src/patches/icedove/fix-installdir.patch b/src/patches/icedove/fix-installdir.patch
new file mode 100644
index 0000000..36703fd
--- /dev/null
+++ b/src/patches/icedove/fix-installdir.patch
@@ -0,0 +1,33 @@
+From: Alexander Sack <asac@debian.org>
+Date: Wed, 27 Jan 2010 19:05:18 +0100
+Subject: fix installdir
+
+---
+ mail/app/Makefile.in | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/mail/app/Makefile.in b/mail/app/Makefile.in
+index 8f81701..a65d48d 100644
+--- a/mail/app/Makefile.in
++++ b/mail/app/Makefile.in
+@@ -108,11 +108,20 @@ libs:: $(addprefix icons/$(MOZ_WIDGET_TOOLKIT)/,$(DESKTOP_ICON_FILES))
+
+ libs:: $(addprefix $(DIST)/branding/,$(BRANDED_ICON_FILES))
+ $(INSTALL) $(IFLAGS1) $^ $(DIST)/bin/chrome/icons/default
++
++install:: $(addprefix icons/$(MOZ_WIDGET_TOOLKIT)/,$(DESKTOP_ICON_FILES))
++ $(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(installdir)/chrome/icons/default
++
++install:: $(addprefix $(DIST)/branding,$(BRANDED_ICON_FILES))
++ $(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(installdir)/chrome/icons/default
+ endif
+
+ ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
+ libs::
+ $(INSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DIST)/bin/chrome/icons/default
++
++install::
++ $(SYSINSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DESTDIR)$(installdir)/chrome/icons/default
+ endif
+
+ libs:: $(srcdir)/profile/prefs.js
diff --git a/src/patches/icedove/no-dynamic-nss-softokn.patch b/src/patches/icedove/no-dynamic-nss-softokn.patch
new file mode 100644
index 0000000..330ea12
--- /dev/null
+++ b/src/patches/icedove/no-dynamic-nss-softokn.patch
@@ -0,0 +1,21 @@
+From: Alexander Sack <asac@debian.org>
+Date: Wed, 27 Jan 2010 19:06:07 +0100
+Subject: no dynamic nss softokn
+
+---
+ ldap/sdks/c-sdk/component_versions.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ldap/sdks/c-sdk/component_versions.mk b/ldap/sdks/c-sdk/component_versions.mk
+index 2ad6347..5f61b57 100644
+--- a/ldap/sdks/c-sdk/component_versions.mk
++++ b/ldap/sdks/c-sdk/component_versions.mk
+@@ -46,7 +46,7 @@ NSPR_RELEASE_TREE = $(COMPONENTS_DIR)
+ # NSS - Network Security Services
+ NSSVERS = 3
+ NSS_RELEASE_TAG = NSS_3_9_3_RTM
+-NSS_DYNAMIC_SOFTOKN = 1
++NSS_DYNAMIC_SOFTOKN = 0
+ NSS_RELEASE_TREE = $(COMPONENTS_DIR)
+
+ # SVRCORE - Client/server utility library
diff --git a/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch b/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
new file mode 100644
index 0000000..c0a5292
--- /dev/null
+++ b/src/patches/iceowl/Change-extension-s-name-to-Iceowl.patch
@@ -0,0 +1,57 @@
+From: agx <agx@squeeze.sigxcpu.org>
+Date: Thu, 3 Nov 2011 22:35:44 +0100
+Subject: Change extension's name to Iceowl
+
+---
+ calendar/lightning/install.rdf | 2 +-
+ calendar/locales/en-US/chrome/calendar/timezones.properties | 2 +-
+ calendar/locales/en-US/chrome/lightning/lightning.properties | 8 ++++----
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/calendar/lightning/install.rdf b/calendar/lightning/install.rdf
+index ae6dbd2..f71d848 100644
+--- a/calendar/lightning/install.rdf
++++ b/calendar/lightning/install.rdf
+@@ -30,7 +30,7 @@
+ </em:targetApplication>
+
+ <em:id>@XPI_EM_ID@</em:id>
+- <em:name>Lightning</em:name>
++ <em:name>Iceowl</em:name>
+ <em:version>@LIGHTNING_VERSION@</em:version> <!-- BuildID=@GRE_BUILDID@ -->
+ <em:description>An integrated calendar for Thunderbird</em:description>
+ #ifdef LIGHTNING_PRERELEASE_VERSION
+diff --git a/calendar/locales/en-US/chrome/calendar/timezones.properties b/calendar/locales/en-US/chrome/calendar/timezones.properties
+index 882cc70..8b395bd 100644
+--- a/calendar/locales/en-US/chrome/calendar/timezones.properties
++++ b/calendar/locales/en-US/chrome/calendar/timezones.properties
+@@ -4,7 +4,7 @@
+
+ # extension:
+ extensions.calendar-timezones@mozilla.org.name=Timezone Definitions for Mozilla Calendar
+-extensions.calendar-timezones@mozilla.org.description=Timezone definitions required by Sunbird and Lightning
++extensions.calendar-timezones@mozilla.org.description=Timezone definitions required by Lightning and Iceowl
+ extensions.calendar-timezones@mozilla.org.creator=Mozilla Calendar Project
+
+ pref.timezone.floating=Local Time
+diff --git a/calendar/locales/en-US/chrome/lightning/lightning.properties b/calendar/locales/en-US/chrome/lightning/lightning.properties
+index 78b15b6..6bf260f 100644
+--- a/calendar/locales/en-US/chrome/lightning/lightning.properties
++++ b/calendar/locales/en-US/chrome/lightning/lightning.properties
+@@ -3,12 +3,12 @@
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+ # addon description:
+-extensions.{e2fda1a4-762b-4020-b5ad-a41df1933103}.name=Lightning
+-extensions.{e2fda1a4-762b-4020-b5ad-a41df1933103}.description=An integrated calendar for Thunderbird
+-extensions.{e2fda1a4-762b-4020-b5ad-a41df1933103}.creator=Mozilla Calendar Project
++extensions.{e2fda1a4-762b-4020-b5ad-a41df1933103}.name=Iceowl
++extensions.{e2fda1a4-762b-4020-b5ad-a41df1933103}.description=An integrated calendar for Icedove
++extensions.{e2fda1a4-762b-4020-b5ad-a41df1933103}.creator=Debian Project
+
+ # Lightning branding
+-brandShortName=Lightning
++brandShortName=Iceowl
+
+ # Task mode title
+ taskModeApplicationTitle=Tasks
diff --git a/src/patches/series b/src/patches/series
new file mode 100644
index 0000000..cf3f11b
--- /dev/null
+++ b/src/patches/series
@@ -0,0 +1,4 @@
+icedove/fix-installdir.patch
+icedove/no-dynamic-nss-softokn.patch
+icedove/fix-branding-in-migration-wizard-and-the-addon-manag.patch
+iceowl/Change-extension-s-name-to-Iceowl.patch