summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-07-29 02:29:58 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-07-29 02:29:58 -0400
commit5bfc0db6769f08792f13f8dc0656312eaf2c22ed (patch)
treed26dc988db2ef188b3b409a0c64ea7565a38f224
parent7c55f85a33343ad56f7a3125ffe04cc07bea3400 (diff)
squashme - binary builds
-rwxr-xr-xbranding-dev-build/branding-dev-build.sh23
1 files changed, 14 insertions, 9 deletions
diff --git a/branding-dev-build/branding-dev-build.sh b/branding-dev-build/branding-dev-build.sh
index 7c5dc0a..61ba90f 100755
--- a/branding-dev-build/branding-dev-build.sh
+++ b/branding-dev-build/branding-dev-build.sh
@@ -1,10 +1,13 @@
#!/bin/bash
# 'branding-dev-build.sh' pre-compiled binary builds for front-end dev
-# 'bootstrap.py' from:
-# https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Artifact_builds
-# recipe from:
+# basic recipe from:
# https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_Firefox_build/Linux_and_MacOS_build_preparation
+# https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Artifact_builds
+
+# this script autoimates as much as possible of the initial setup procedure
+# and the tweak->commit->build->run->verify loop ; but the run->verify stages need to be done
+# on a system running an X-server with a mouse plus eyeballs, for the obvious reasons
# the VCS identity used to commit to the upstream sources will be: 'nobody@nowhere.man'
# the upstream sources are not FSDG-free; and this script does not clean them
@@ -54,9 +57,9 @@ readonly CID_FILE_MSG=" The contents of the ${CID_FILENAME} file will be in
"as a comment into the patch files,
to indicate the upstream checkout-point against which the patch was created.
Be sure to run these commands after pulling upstream sources manually:
- $ cd ${BINARY_BUILD_SRCDIR}
+ $ cd ${BINARY_BUILD_SRCDIR}/
$ ${MARKER_CMD} > ../${CID_FILENAME}
- $ cd ${CWD}"
+ $ cd ../"
read -r -d '' BINARY_BUILD_CFG <<-'BINARY_BUILD_CFG_END'
# download and use pre-compiled C++ components
@@ -96,8 +99,8 @@ PrepareMozillaBinaryBuild()
echo " When prompted to configure the VCS tool, deny."
echo " When prompted to enable telemetry, deny."
echo " The bootstrap script will then download the tooling."
- echo " You should see: \"Your system should be ready to build Firefox for Desktop Artifact Mode! \""
- echo " Ignore the note about the $topsrcdir/mozconfig file; but do open a new shell to continue."
+ echo " You should see: \"Your system should be ready to build Firefox for Desktop Artifact Mode!\""
+ echo " Ignore the note about the \$topsrcdir/mozconfig file; but do open a new shell to continue."
# bootstrap
cd ${BINARY_BUILD_SRCDIR}/ ; ${BOOTSTRAP_CMD} ; cd ${CWD} ;
# mark upstream CID
@@ -145,6 +148,7 @@ ConfigMozillaBinaryBuild()
# eval ${PATCH_CMD}
# exit
+ # commit local changes abd write patch for PKGBUILD
echo
echo "NOTE: Your local changes are about to be committed to the upstream VCS;"
echo " and a patch file against the pristine upstream source will be written."
@@ -162,6 +166,7 @@ ReBuildMozillaBinaryBuild()
{
cd ${BINARY_BUILD_SRCDIR}
+ # rebuild
export MOZBUILD_STATE_PATH=${BINARY_BUILD_OBJDIR}
./mach build
./mach run
@@ -172,5 +177,5 @@ ReBuildMozillaBinaryBuild()
echo -e "\n\n== PrepareMozillaBinaryBuild ==" && PrepareMozillaBinaryBuild && \
echo -e "\n\n== ConfigMozillaBinaryBuild ==" && ConfigMozillaBinaryBuild && \
-# echo -e "\n\n== ReBuildMozillaBinaryBuild ==" && ReBuildMozillaBinaryBuild
-echo -e "\n\n== ReBuildMozillaBinaryBuild ==" && echo out # ReBuildMozillaBinaryBuild
+echo -e "\n\n== ReBuildMozillaBinaryBuild ==" && ReBuildMozillaBinaryBuild && \
+echo -e "\n\n== Done =="