summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-09-27 14:42:10 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-09-27 14:42:10 -0400
commitc3d8da0e89d3f2213933ff85dc0cca7d829442ed (patch)
tree967259a8338aa703195b94a9d5131c00545b0f3a /Makefile
Initial commit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b8971b4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+subcommands = help mvn-basename mvn-install mvn-localrepo
+
+####
+
+subcommand_files = $(addprefix jh-,$(subcommands))
+help_files = $(addsuffic .help.,jh- $(subcommands))
+
+all: PHONY build
+
+####
+
+build: PHONY jh $(subcommand_files) $(help_files)
+install: $(DESTDIR)/usr/bin/jh $(addprefix $(DESTDIR)/usr/share/jh/,$(subcommand_files) $(help_files))
+
+$(DESTDIR)/usr/share/jh/%: %
+ cp '$<' '$@'
+
+$(DESTDIR)/usr/bin/jh: jh
+ cp '$<' '$@'
+
+####
+
+.PHONY: PHONY FORCE
+PHONY FORCE: ; @: