summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 33307fe..810b0c4 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,8 @@
prefix = /usr
bindir = $(prefix)/bin
-pkgdatadir = /usr/share/jh # hardcoded into jh.sh
+# pkgdatadir is hardcoded into jh.sh
+pkgdatadir = /usr/share/jh
+
subcommands = help list-commands mvn-basename mvn-install mvn-localrepo checksource
dirs = $(DESTDIR)$(bindir) $(DESTDIR)$(pkgdatadir)
@@ -19,7 +21,7 @@ install: PHONY $(DESTDIR)$(bindir)/jh $(addprefix $(DESTDIR)$(pkgdatadir)/,$(sub
clean: PHONY
rm -f jh $(subcommand_files)
-$(DESTDIR)$(pkgdaradir)/%: % | $(DESTDIR)$(pkgdatadir)
+$(DESTDIR)$(pkgdatadir)/%: % | $(DESTDIR)$(pkgdatadir)
cp '$<' '$@'
$(DESTDIR)$(bindir)/jh: jh | $(DESTDIR)$(bindir)