summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 4794be4..70b1ec1 100644
--- a/Makefile
+++ b/Makefile
@@ -4,14 +4,14 @@ dirs = $(DESTDIR)/usr/share/jh $(DESTDIR)/usr/bin
####
subcommand_files = $(addprefix jh-,$(subcommands))
-help_files = $(addsuffix .help.txt,jh- $(subcommand_files))
+help_files = $(addsuffix .help.txt,$(subcommand_files))
all: PHONY build
####
-build: PHONY jh $(subcommand_files) $(help_files)
-install: $(DESTDIR)/usr/bin/jh $(addprefix $(DESTDIR)/usr/share/jh/,$(subcommand_files) $(help_files))
+build: PHONY jh $(subcommand_files)
+install: PHONY $(DESTDIR)/usr/bin/jh $(addprefix $(DESTDIR)/usr/share/jh/,$(subcommand_files) $(help_files))
$(DESTDIR)/usr/share/jh/%: % | $(DESTDIR)/usr/share/jh
cp '$<' '$@'