summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b8971b4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+subcommands = help mvn-basename mvn-install mvn-localrepo
+
+####
+
+subcommand_files = $(addprefix jh-,$(subcommands))
+help_files = $(addsuffic .help.,jh- $(subcommands))
+
+all: PHONY build
+
+####
+
+build: PHONY jh $(subcommand_files) $(help_files)
+install: $(DESTDIR)/usr/bin/jh $(addprefix $(DESTDIR)/usr/share/jh/,$(subcommand_files) $(help_files))
+
+$(DESTDIR)/usr/share/jh/%: %
+ cp '$<' '$@'
+
+$(DESTDIR)/usr/bin/jh: jh
+ cp '$<' '$@'
+
+####
+
+.PHONY: PHONY FORCE
+PHONY FORCE: ; @: