summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2012-01-21 11:16:42 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2012-01-21 11:16:42 -0300
commit0985429b68d8da1016bf4a84b2a2d32fb8c3027c (patch)
tree67969e3a9b185548772593818e29b81546bb3e5a
parent918e09f1a47dc3d23440f08a91d91d31d62dcb5a (diff)
Merging fullpkg
-rwxr-xr-xfullpkg8
-rw-r--r--fullpkg-find9
2 files changed, 9 insertions, 8 deletions
diff --git a/fullpkg b/fullpkg
index 227f329..fe74432 100755
--- a/fullpkg
+++ b/fullpkg
@@ -19,14 +19,6 @@ usage() {
}
-# Finds a PKGBUILD on toru's path cache
-# Look in all caches but pick the first one
-# TODO move to a toru flag (-p?)
-where_is() {
- grep -m1 "^${1}:" "${TORUPATH}/paths" 2>/dev/null| \
- cut -d: -f2 2>/dev/null
-}
-
while getopts 'haA:l:nm:' arg; do
case "$arg" in
h) usage ;;
diff --git a/fullpkg-find b/fullpkg-find
index 25565ae..d253913 100644
--- a/fullpkg-find
+++ b/fullpkg-find
@@ -11,6 +11,14 @@ guess_repo() {
basename $(dirname $(pwd))
}
+# Finds a PKGBUILD on toru's path cache
+# Look in all caches but pick the first one
+# TODO move to a toru flag (-p?)
+where_is() {
+ grep -m1 "^${1}:" "${TORUPATH}/paths" 2>/dev/null| \
+ cut -d: -f2 2>/dev/null
+}
+
# return : full version spec, including epoch (if necessary), pkgver, pkgrel
# usage : get_fullver( ${epoch:-0}, $pkgver, $pkgrel )
get_fullver() {
@@ -71,6 +79,7 @@ find_deps() {
for _dep in ${deps[@]}; do
local found=false
+# TODO change for where_is or toru-path
local pkgdir=$(toru -p ${_dep})
if [ -n "$pkgdir" -a -d "${pkgdir}" ]; then