summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2011-11-24 11:09:23 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2011-11-24 11:09:23 -0300
commit40fa0a4c04a34740b40c88a75b7ef1c816cda195 (patch)
treeeff09bbb2894dc2cc8e48588490bb0880d4ed947
parent22a9fdddd1f6fd02e1b8d8ca9022398cd64c68b2 (diff)
Toru-path fixes
-rwxr-xr-xtoru-path6
-rwxr-xr-xtoru-utils6
2 files changed, 8 insertions, 4 deletions
diff --git a/toru-path b/toru-path
index 82378a4..bdf2f23 100755
--- a/toru-path
+++ b/toru-path
@@ -7,8 +7,6 @@ LASTSYNCFILE=${TORUPATH}/lastsync.paths
# TODO pass other paths via flags
pkgbuilds=($(get_pkgbuilds ${ABSROOT}))
paths=()
-# TODO create a --ignore flag
-ignore=($@)
msg "Updating path cache"
msg2 "${#pkgbuilds[@]} PKGBUILDs to update"
@@ -21,8 +19,8 @@ for _pkgbuild in ${pkgbuilds[@]}; do
fullpath=$(dirname $(readlink -f ${_pkgbuild}))
- for _pkg in ${pkgname[@]}; do
- paths+=(${_pkg}:${fullpath})
+ for _pkg in ${pkgname[@]} ${provides[@]}; do
+ paths+=(${_pkg/[<>=]*}:${fullpath})
done
done
diff --git a/toru-utils b/toru-utils
index e930273..bb0aef4 100755
--- a/toru-utils
+++ b/toru-utils
@@ -44,6 +44,12 @@ lastsync() {
touch ${lastsyncfile}
}
+get_dbs() {
+ local _db
+ for _db in /var/lib/pacman/sync/*.db; do
+ bsdtar tf ${_db} | cut -d'/' -f1 | sort -u
+ done
+}
# repo paths
get_pkgbuilds() {