summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Masłowski <mtjm@mtjm.eu>2012-03-30 11:01:00 +0200
committerMichał Masłowski <mtjm@mtjm.eu>2012-03-30 11:01:00 +0200
commitaa229eb53be49987b35a95e3a2dcfb2d8e21a08c (patch)
tree18240ec1c45fdc914d3fe16909199ee7f15049d5
parent27b946270520befdb810dba04cfa0e7cab9a6bf9 (diff)
fullpkg-find: correctly find CARCH-specific depends and don't needlessly rebuild kdebase.
-rwxr-xr-xfullpkg-find7
1 files changed, 6 insertions, 1 deletions
diff --git a/fullpkg-find b/fullpkg-find
index 9ddfa08..64c1790 100755
--- a/fullpkg-find
+++ b/fullpkg-find
@@ -34,6 +34,7 @@ get_fullver() {
# Checks ABSROOT and look for target pkg deps. Adds them if not built or outdated.
find_deps() {
# Check this level
+ source /etc/makepkg.conf
source PKGBUILD
local repo="${repo:-$(guess_repo)}"
@@ -47,7 +48,11 @@ find_deps() {
fi
fi
- if is_built "${pkgbase}" "${fullver}"; then
+ # Checking any package built, since otherwise e.g. kdebase would
+ # be always considered outdated: there is no package built named kdebase.
+ # TODO: maybe check for the package requested in case of recursive calls,
+ # instead of the first one listed?
+ if is_built "${pkgname[0]}" "${fullver}"; then
exit 0 # pkg is built and updated
fi