summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-11-28 02:48:39 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-11-28 02:48:39 -0600
commitbcb8f2ab77a59d572d2a62217c2ac1fb683a581e (patch)
treedf815a6af59e630df8ec21b152217e0efc731ff4
parentd899caa8de20db4b4fca9d74b5f1c077d8008ccc (diff)
parent73f4d0e6498dd590f0181ac8c1c2015d29ad168d (diff)
Merge branch 'master' of gitpar:libretools
-rwxr-xr-xaur4
-rw-r--r--cleansystem3
-rwxr-xr-xlibremakepkg40
3 files changed, 17 insertions, 30 deletions
diff --git a/aur b/aur
index 35783c5..ca7d587 100755
--- a/aur
+++ b/aur
@@ -76,9 +76,11 @@ for _pkg in ${@}; do
fi
for _dep in ${depends[@]} ${makedepends[@]}; do
+ _dep=${_dep/[<>=]*/}
if ! is_built $_dep; then
if ! find ${ABSROOT} -maxdepth 2 -type d -name "$_dep" | egrep "*" >/dev/null ; then
- missing_deps=(${missing_deps} $_dep)
+ msg2 "$_dep will be get from AUR"
+ missing_deps+=($_dep)
fi
else
msg2 "$_dep is on repos"
diff --git a/cleansystem b/cleansystem
index 5c44d17..3f92b95 100644
--- a/cleansystem
+++ b/cleansystem
@@ -124,6 +124,3 @@ wpa_supplicant
xfsprogs
xz
zlib
-libgssglue
-libtirpc
-
diff --git a/libremakepkg b/libremakepkg
index ef72526..bac9e30 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -136,9 +136,7 @@ if [ ${UID} -ne 0 ]; then
fi
if [ ! -r PKGBUILD ]; then # Check if we are actually on a build directory. Do this early.
-
- error "This isn't a build directory"; usage
-
+ error "This isn't a build directory"; usage
fi
msg "Checking PKGBUILD for non-free issues"
@@ -156,33 +154,23 @@ fi
buildenv
msg "Creating the package"
-if [ -d "${CHROOTDIR}/${CHROOTNAME}" ]; then # use chroot
-
- if [ "${CLEAN_FIRST}" = 'y' ]; then
- msg "Cleaning"
- clean_chroot
- fi
-
- if [ "${UPDATE_FIRST}" = 'y' ]; then
- msg "Updating the chroot in use..."
- mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOTNAME}" # -c option is for cache
- fi
-
- makechrootpkg -r "${CHROOTDIR}" -l "${CHROOTNAME}" -- "${MAKEPKG_ARGS}"
- ev=$? # exit value
-
-else # build new chroot before using
-
- if [ "${UPDATE_FIRST}" = 'y' ]; then # update CHROOT
- msg "Updating the chroot in use..."
- mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOT}" # -c option is for cache
- fi
+if [ ! -d "${CHROOTDIR}/${CHROOTNAME}" ]; then # use chroot
+ mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOT}" # -c option is for cache
+fi
- makechrootpkg -c -r "${CHROOTDIR}" -l "${CHROOTNAME}" -- "${MAKEPKG_ARGS}"
- ev=$? # exit value
+if [ "${CLEAN_FIRST}" = 'y' ]; then
+ msg "Cleaning"
+ clean_chroot
+fi
+if [ "${UPDATE_FIRST}" = 'y' ]; then
+ msg "Updating the chroot in use..."
+ mkarchroot -c ${CACHEDIR} -u "${CHROOTDIR}/${CHROOTNAME}" # -c option is for cache
fi
+makechrootpkg -r "${CHROOTDIR}" -l "${CHROOTNAME}" -- "${MAKEPKG_ARGS}"
+ev=$? # exit value
+
copy_log
exit $ev