summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2012-02-06 03:00:34 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2012-02-06 03:00:34 -0300
commitebc66c503aad4df99f8660f2e4557c23cdc24fd3 (patch)
tree7e3e72fa33dc72d7b1705bdc0881053dc55f28ac
parent94b94c9ea476e4e791219bd2c017741a3274bbc5 (diff)
_pkg contained the depth also
-rwxr-xr-xmips64el/mipsrelease5
-rwxr-xr-xtreepkg2
2 files changed, 6 insertions, 1 deletions
diff --git a/mips64el/mipsrelease b/mips64el/mipsrelease
index 0d14c72..5d0034d 100755
--- a/mips64el/mipsrelease
+++ b/mips64el/mipsrelease
@@ -34,6 +34,11 @@ get_full_version() {
repo=$1; shift
+if [ -z "${repo}" ]; then
+ error "Empty repo"
+ exit 1
+fi
+
# Get all needed sources
source PKGBUILD
fullver=$(get_full_version ${epoch:-0} ${pkgver} ${pkgrel})
diff --git a/treepkg b/treepkg
index 167ccbd..bd95253 100755
--- a/treepkg
+++ b/treepkg
@@ -158,7 +158,7 @@ if [ ${DEPTH} -eq 0 ]; then
pushd "${BUILDDIR}/${_pkg}" >/dev/null
${FULLBUILDCMD}
# Run local release hook with $1 = $repo
- ${HOOKLOCALRELEASE} $(egrep ";${_pkg};" "${BUILDORDER}" | cut -d';' -f6)
+ ${HOOKLOCALRELEASE} $(egrep ";${_pkg#*_};" "${BUILDORDER}" | cut -d';' -f6)
popd >/dev/null
done