summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2012-02-27 11:35:55 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2012-02-27 11:35:55 -0300
commitda785c8272457a70f21942bf4943bfc69f4fbeb8 (patch)
treeaca06d323bbe7720cba7189e8ac1c56bbc08f104
parentb3047be050482448ef6487aefe8193bf911807d6 (diff)
Use only one find
-rwxr-xr-xtoru-path2
-rwxr-xr-xtoru-utils9
2 files changed, 5 insertions, 6 deletions
diff --git a/toru-path b/toru-path
index 22b991b..71dc85c 100755
--- a/toru-path
+++ b/toru-path
@@ -27,6 +27,8 @@ for _pkgbuild in ${pkgbuilds[@]}; do
done
# TODO remove old paths
+# by joining new paths to old paths and exclude the joining points from the
+# cache (sort of a sql join)
echo ${paths[@]} | tr ' ' "\n" | sort >> ${TORUPATH}/paths
lastsync ${LASTSYNCFILE}
diff --git a/toru-utils b/toru-utils
index bb0aef4..2488091 100755
--- a/toru-utils
+++ b/toru-utils
@@ -59,17 +59,14 @@ get_pkgbuilds() {
$QUIET || warning "Forcing upgrade"
# Get all PKGBUILDs
- pkgbuilds=($(find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD'))
-
+ extra=""
else
-
# Only find newer than lastsyncfile and read everything else from cache
- pkgbuilds=($(find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' -newer ${LASTSYNCFILE}))
-
+ extra=" -newer ${LASTSYNCFILE}"
fi
# Return all PKGBUILDs found
- echo ${pkgbuilds[@]}
+ find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' ${extra}
}
# End inmediately but print a useful message