summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2021-01-18 15:32:32 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2022-08-29 10:27:59 -0400
commit22383041ab4dfa9e47432739a46c385e19222ca0 (patch)
tree043ec9029638622bbdbb73506bf31a5e9236afec
parentf886663afed27f9c014c5f5473ce7d03689d1639 (diff)
delete split-pkg functions from mksource temporary PKGBUILD
it was previously not possible to use mksource() in a split-package the mksource temporary PKGBUILD over-rides the package() function; but conflicting package_*() functions were left in tact
-rwxr-xr-xsrc/librefetch/librefetch3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 1ab6190..d5192a8 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -364,6 +364,9 @@ prepare() { :; }
build() { msg "Starting mksource()"; mksource; }
check() { :; }
package() { cp -a "$srcdir"/*/ "$pkgdir/"; }
+if [[ "$(declare -p pkgname 2> /dev/null)" =~ ^"declare -a " ]]
+then for pkg in ${pkgname[*]} ; do unset package_${pkg} ; done ;
+fi
'
modified_pkgbuild() {