summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-09-29 19:33:29 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-10-01 17:35:22 -0400
commit81d9c89b7ddd758161793ae85547dea537924e7a (patch)
tree35456227c6c411f3418378668c9df3de0bd98303
parent6d46e7611e8b0258ef4843ad08349b7f42bede3a (diff)
test: librefetch: sed -i s,tmpdir/srcdest,tmpdir/workdir/srcdest,g
For consistency with other tests.
-rw-r--r--test/librefetch-test.sh24
1 files changed, 12 insertions, 12 deletions
diff --git a/test/librefetch-test.sh b/test/librefetch-test.sh
index 22aab8c..43b34fc 100644
--- a/test/librefetch-test.sh
+++ b/test/librefetch-test.sh
@@ -7,7 +7,7 @@ KEYSERVER=hkp://pool.sks-keyservers.net
GPG="gpg --quiet --batch --no-tty --no-permission-warning --keyserver ${KEYSERVER}"
common_before() {
- mkdir -p "$XDG_CONFIG_HOME"/{pacman,libretools} "$tmpdir/srcdest"
+ mkdir -p "$XDG_CONFIG_HOME"/{pacman,libretools} "$tmpdir/workdir/srcdest"
cat <<EOF > "$XDG_CONFIG_HOME/pacman/makepkg.conf"
DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
@@ -16,7 +16,7 @@ DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %
'rsync::/usr/bin/rsync --no-motd -z %u %o'
'scp::/usr/bin/scp -C %u %o')
BUILDDIR=""
-SRCDEST=$tmpdir/srcdest
+SRCDEST=$tmpdir/workdir/srcdest
source ${_librelib_conf_sh_sysconfdir}/makepkg.d/librefetch.conf
EOF
@@ -57,7 +57,7 @@ it_fails_with_bad_flags() {
[[ $status != 0 ]]
empty $tmpdir/stdout
not empty $tmpdir/stderr
- not test -e $tmpdir/srcdest/$srcball
+ not test -e $tmpdir/workdir/srcdest/$srcball
}
# This test used to be called "it_cleans_src_libre_first", but let's
@@ -90,10 +90,10 @@ it_runs_with_mksource() {
# - The files in the srcball are in the correct order (if the
# order isn't ensured, then this would only sometimes fail,
# unfortunately).
- bsdtar tf "$tmpdir/srcdest/$srcball" > list-pkg.txt
+ bsdtar tf "$tmpdir/workdir/srcdest/$srcball" > list-pkg.txt
diff -u list.txt list-pkg.txt
# Verify that the signature was created and matches
- gpg --quiet --verify "$tmpdir/srcdest/$srcball"{.sig,} 2>/dev/null
+ gpg --quiet --verify "$tmpdir/workdir/srcdest/$srcball"{.sig,} 2>/dev/null
}
it_runs_with_srcbuild() {
@@ -120,10 +120,10 @@ it_runs_with_srcbuild() {
# - The files in the srcball are in the correct order (if the
# order isn't ensured, then this would only sometimes fail,
# unfortunately).
- bsdtar tf "$tmpdir/srcdest/$srcball" > list-pkg.txt
+ bsdtar tf "$tmpdir/workdir/srcdest/$srcball" > list-pkg.txt
diff -u list.txt list-pkg.txt
# Verify that the signature was created and matches
- gpg --quiet --verify "$tmpdir/srcdest/$srcball"{.sig,} 2>/dev/null
+ gpg --quiet --verify "$tmpdir/workdir/srcdest/$srcball"{.sig,} 2>/dev/null
}
it_recurses() {
@@ -133,9 +133,9 @@ it_recurses() {
mv PKGBUILD{-recurse,}
makepkg -g
- bsdtar tf "$tmpdir/srcdest/$srcball" > list-pkg.txt
+ bsdtar tf "$tmpdir/workdir/srcdest/$srcball" > list-pkg.txt
diff -u list.txt list-pkg.txt
- gpg --quiet --verify "$tmpdir/srcdest/$srcball"{.sig,} 2>/dev/null
+ gpg --quiet --verify "$tmpdir/workdir/srcdest/$srcball"{.sig,} 2>/dev/null
}
it_doesnt_recurse_extra() {
@@ -144,8 +144,8 @@ it_doesnt_recurse_extra() {
cd "$tmpdir"
mv PKGBUILD{-recurse,}
- :> "$tmpdir/srcdest/$srcball"
+ :> "$tmpdir/workdir/srcdest/$srcball"
makepkg -g
- empty "$tmpdir/srcdest/$srcball"
- gpg --quiet --verify "$tmpdir/srcdest/$srcball"{.sig,} 2>/dev/null
+ empty "$tmpdir/workdir/srcdest/$srcball"
+ gpg --quiet --verify "$tmpdir/workdir/srcdest/$srcball"{.sig,} 2>/dev/null
}