summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 19:08:32 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 21:27:19 -0400
commit619cd45359e7ca762d2055f7ef4de2c12f85e9b2 (patch)
tree0a8ee3376ea1670e9b5dc73a3f90b282dcb4eee6
parent5691f389185d30211214a68346b74452e3390224 (diff)
Makefile: fix at-modules warnings
-rw-r--r--build-aux/Makefile.each.tail/00-mod.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/build-aux/Makefile.each.tail/00-mod.mk b/build-aux/Makefile.each.tail/00-mod.mk
index d6514dd..c0c8b05 100644
--- a/build-aux/Makefile.each.tail/00-mod.mk
+++ b/build-aux/Makefile.each.tail/00-mod.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016, 2018 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -38,6 +38,8 @@ $(addprefix $(outdir)/at-modules/,$(_mod.modules)): $(outdir)/at-modules/%:
@printf ' %s\n' $(call quote.shell-each,$(call at.relto,$(topsrcdir),$(sort $(mod.$*.files) $(wildcard $(topsrcdir)/build-aux/Makefile.*/??-$*.mk))))
@echo 'Documentation :'
@printf '%s\n' $(call quote.shell,$(mod.$*.doc)) | sed -e 's/^# / /' -e 's/^#//'
+.PHONY: $(outdir)/at-modules $(addprefix $(outdir)/at-modules/,$(_mod.modules))
+at.targets += $(outdir)/at-modules $(addprefix $(outdir)/at-modules/,$(_mod.modules))
$(outdir)/at-noop:
.PHONY: $(outdir)/at-noop