summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-18 19:09:56 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-18 19:09:56 -0500
commit702cc20bd94cdb2939e0c163e8e9671c920c5b19 (patch)
treea2ab4b166b7e73f5ad0d27f42ab6c5a056af2437
parent1c7f5b8c2807f08df766d6845e8565a13c46b333 (diff)
exec find before LOCALHOOKRELEASE
-rwxr-xr-xfullpkg25
1 files changed, 13 insertions, 12 deletions
diff --git a/fullpkg b/fullpkg
index 1349e9a..be9ed70 100755
--- a/fullpkg
+++ b/fullpkg
@@ -202,17 +202,17 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
-# elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
-# "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
-# then
-# _dir=$(dirname $(echo $_dir | cut -d: -f1))
-# plain "guess for $_dep -> $_dir"
-# pushd $_dir > /dev/null
-# $0 -c -d ${build_dir} -l ${next_level}
-## Circular deps must fail
-# [ $? -eq 20 ] && return 20
-# popd > /dev/null
-# break 1 # found, go to next dep
+ elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
+ "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
+ then
+ _dir=$(dirname $(echo $_dir | cut -d: -f1))
+ plain "guess for $_dep -> $_dir"
+ pushd $_dir > /dev/null
+ $0 -c -d ${build_dir} -l ${next_level}
+# Circular deps must fail
+ [ $? -eq 20 ] && return 20
+ popd > /dev/null
+ break 1 # found, go to next dep
else
echo "dep_not_found:$_dep:$_repo" >> $build_dir/log
@@ -279,7 +279,8 @@ function _pkg_build () {
# Calls a local release script if it's used
[ -z $HOOKLOCALRELEASE ] || \
- $HOOKLOCALRELEASE $repo *.pkg.tar.?z
+ find -name "*.pkg.tar.?z" -print0 | \
+ xargs -0 $HOOKLOCALRELEASE $repo
# Stage for releasing
librestage $repo || {