summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-04 19:16:30 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-04 19:16:30 -0300
commit0dd66858186c4830d29b7b0011d9053739e87819 (patch)
tree9d14d2eaafc40a0cce525aabe8792a9a60d1a387
parent569a3ad411489a31ccadcd484f6851d31e691518 (diff)
parentaf74e1a5884a23e29289c661c74fadbf72d794e7 (diff)
Merge branch 'master' of ssh://vparabola/srv/git/projects/libretools
-rwxr-xr-xfullpkg3
1 files changed, 2 insertions, 1 deletions
diff --git a/fullpkg b/fullpkg
index 213bf5e..14c4e9f 100755
--- a/fullpkg
+++ b/fullpkg
@@ -162,8 +162,9 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 | \
- "xargs" -0 -e grep -HEw "pkgname|pkgbase|provides" | grep $_dep 2>&1));
+ "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep $_dep 2>&1));
then
+ plain "guess for $_dep -> $_dir"
pushd $(dirname $(echo $_dir | cut -d: -f1)) > /dev/null
$0 -c -d ${build_dir} -l ${next_level}
# Circular deps must fail