summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-02 15:07:26 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-05-02 15:07:26 -0400
commit467d14a0bc73c8eba81d1c814dc18d49e446e6ab (patch)
tree100385bcba6502e5da5ee71ef3339afe4d1788cb
parentd9d355db20cbb62706a66ea0daaced5430fd8a92 (diff)
deprecate rePKGBUILD/librerepkg
-rw-r--r--rePKGBUILD.proto29
-rwxr-xr-xsrc/librerepkg69
2 files changed, 0 insertions, 98 deletions
diff --git a/rePKGBUILD.proto b/rePKGBUILD.proto
deleted file mode 100644
index c8b19bf..0000000
--- a/rePKGBUILD.proto
+++ /dev/null
@@ -1,29 +0,0 @@
-# This is an example rePKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Maintainer: Your Name <youremail@domain.com>
-source PKGBUILD
-unset build package md5sums source
-_repo= # Put the repo here
-_mirror=http://mirrors.kernel.org/archlinux # Put mirror here
-source=(PKGBUILD
- "${_mirror}/${_repo}/os/${CARCH}/${pkgname%-libre}-$pkgver-$pkgrel-$CARCH$PKGEXT"
- # files for pkg modifications below this line
- )
-
-build() {
- cd "${srcdir}/"
- rm .{INSTALL,PKGINFO}
- # put actions for package modifications below this line
-
-}
-
-package() {
- find ${srcdir} -maxdepth 1 -type l -delete
- cp -a ${srcdir}/* ${pkgdir}
-}
-
-
-# vim:set ts=2 sw=2 et:
diff --git a/src/librerepkg b/src/librerepkg
deleted file mode 100755
index 85c58d9..0000000
--- a/src/librerepkg
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/bin/bash
-# Copyright 2011 Joshua Ismael Haase Hernandez
-
-# ---------- GNU General Public License 3 ----------
-
-# This file is part of Parabola.
-
-# Parabola is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# Parabola is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# You should have received a copy of the GNU General Public License
-# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-
-. /etc/libretools.conf
-. /etc/makepkg.conf
-. /etc/abs.conf
-
-cmd=${0##*/}
-
-usage() {
- echo "cd to a dir with a rePKGBUILD and other file info and run"
- echo "$cmd [makepkg flags]"
- echo ""
- echo "This script will repackage an arch package without compiling"
-}
-
-main() {
- while getopts 'h' arg; do
- case $arg in
- h) usage; exit 0 ;;
- esac
- done
- makepkgflags=("$@")
-
- if [[ ! -r rePKGBUILD ]]; then
- error "This build does not contains a rePKGBUILD."
- exit 1
- fi
- . rePKGBUILD
-
- tempdir="$(mktemp --tmpdir -d ${PWD##*/}.XXXXX)"
-
- msg "Copying files"
- cp ./* "${tempdir}/"
-
- for _arch in "${arch[@]}"; do
- msg "Repackaging: $pkgname $pkgver-$pkgrel ($(date -u))"
- stdnull pushd "${tempdir}"
-
- msg2 "Updating md5sums"
- makepkg -gp rePKGBUILD >> rePKGBUILD
-
- echo "export CARCH=${_arch}" >> rePKGBUILD
-
- msg "Repackaging using makepkg"
- makepkg -Lcdp rePKGBUILD "${makepkgflags[@]}"
-
- stdnull popd "${tempdir}"
- done
-}
-
-main "$@"