summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-07-26 19:25:43 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-07-26 19:25:43 -0400
commitce56ba16a3cfb485cd052e31206593dc0f395f34 (patch)
treeed198e3c5950c67a84aa0d929ef0ccf84cc7e31f
parent68975fd77b4339f3f1e5cf557a350bf130f7da22 (diff)
test: update librestage tests
-rw-r--r--test/librestage-test.sh15
1 files changed, 7 insertions, 8 deletions
diff --git a/test/librestage-test.sh b/test/librestage-test.sh
index 178728f..edcfc36 100644
--- a/test/librestage-test.sh
+++ b/test/librestage-test.sh
@@ -16,6 +16,7 @@ before() {
echo 'PKGEXT=.pkg.tar.gz' > $HOME/.makepkg.conf
echo "PKGDEST='$tmpdir/workdir/pkgdest'" >> $HOME/.makepkg.conf
+ echo "PACKAGER='Test Suite <test@localhost>'" >> $HOME/.makepkg.conf
mkdir -p "$tmpdir/workdir/pkgdest"
}
@@ -61,19 +62,17 @@ it_stages_split_packages_with_different_versions() {
[[ -f $tmpdir/workdir/staging/~lukeshu/emacs-mdmua-0.72-4-any.pkg.tar.gz ]]
}
-it_stages_packages_to_multiple_repos() {
- cp librestage.d/PKGBUILD-hello "$tmpdir/PKGBUILD"
- cd "$tmpdir"
+it_guesses_the_repo() {
+ mkdir -p -- "$tmpdir/reponame/libretools-hello"
+ cp librestage.d/PKGBUILD-hello "$tmpdir/reponame/libretools-hello/PKGBUILD"
+ cd "$tmpdir/reponame/libretools-hello"
makepkg
- librestage repo1 repo2 repo3
+ librestage
- [[ -f $tmpdir/workdir/staging/repo1/libretools-hello-1.0-1-any.pkg.tar.gz ]]
- [[ -f $tmpdir/workdir/staging/repo2/libretools-hello-1.0-1-any.pkg.tar.gz ]]
- [[ -f $tmpdir/workdir/staging/repo3/libretools-hello-1.0-1-any.pkg.tar.gz ]]
+ [[ -f $tmpdir/workdir/staging/reponame/libretools-hello-1.0-1-any.pkg.tar.gz ]]
}
-
it_stages_packages_without_PKGDEST() {
echo "PKGDEST=''" >> $HOME/.makepkg.conf