summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2010-09-23 11:03:42 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2010-09-23 11:03:42 -0300
commit5bb70212a669aaaced79819a3600f6668135ec10 (patch)
treec9df9e69644b0e8821f5a2c14b9c656918e6a4ee
parent4ac274c48e2cd0fdedf23044383c39a8ee15a141 (diff)
Added help and error messages
-rwxr-xr-xlibrerelease36
1 files changed, 33 insertions, 3 deletions
diff --git a/librerelease b/librerelease
index 5b5c575..920b734 100755
--- a/librerelease
+++ b/librerelease
@@ -1,18 +1,48 @@
#!/bin/bash
-host=parabola
+# Librerelease
+# Uploads packages into free/ repo
+
+# Config
+# SSH host, it's better if you have it configured on ~/.ssh/config
+# with ControlMaster auto (and a shell opened somewhere else)
+#
+# Example:
+# Host *
+# Protocol 2
+# ControlMaster auto
+# ControlPath /tmp/ssh-%r@%h:%p
+#
+# Host parabola
+# Port 22
+# HostName parabolagnulinux.org
+# User parabolavnx
+# IdentityFile ~/.ssh/id_rsa
+#
+# $ cd pkgbuild/dir
+# $ ssh parabola -fN
+# $ librerelease extra
+
+host=parabola
dir=parabolagnulinux.org/repo/free
batchfile=/tmp/librerelease_batchfile.$$
+# End Config
repo=${1}
-if [ ${#repo} -eq 0 ]; then exit 1; fi
+if [ ${#repo} -eq 0 ]; then
+ echo "Usage: $0 <repo>"
+ exit 1;
+fi
function to_sftp() {
echo "$@" >> $batchfile
}
-if [ ! -e ./PKGBUILD ]; then exit 1; fi
+if [ ! -e ./PKGBUILD ]; then
+ echo "PKGBUILD not found"
+ exit 1;
+fi
source PKGBUILD
source /etc/makepkg.conf