summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-11-25 13:42:22 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-11-25 13:42:22 -0600
commit9da438699587b0c7c71fbef834900587d043cd9a (patch)
tree58ad536c2c2958fe0741b11fbb5178c174602f97
parentafa6d104c91ad41d1746f96a4dad7e7c2852c7fc (diff)
truly rename librepatch to librediff
-rwxr-xr-xlibrediff65
1 files changed, 65 insertions, 0 deletions
diff --git a/librediff b/librediff
new file mode 100755
index 0000000..08e7bb7
--- /dev/null
+++ b/librediff
@@ -0,0 +1,65 @@
+#!/bin/bash
+# Generates a patch for a nonfree PKGBUILD
+#
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+usage() {
+ echo "Usage: $0 <pkgname> [<pkgname2> ...]"
+ echo "Requirements:"
+ echo "* Have a <pkgname>/ directory with nonfree build scripts inside"
+ echo "* Have a <pkgname>-libre/ directory with libre build scripts inside"
+}
+
+# Load custom config or system-wide config
+custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
+if [ -e $custom_config ]; then
+ source $custom_config
+else
+ source /etc/libretools.conf
+fi
+
+# Print usage if no package has been given
+[[ -z "$@" ]] && {
+ usage
+ exit 1
+}
+
+
+for package in $@; do
+# Continue on errors
+ [[ ! -d ./${package} || ! -d ./${package}-libre ]] && {
+ echo "Error: no matching ${package} and ${package}-libre found"
+ continue
+ }
+
+ [[ ! -f ./${package}/PKGBUILD || ! -f ./${package}-libre/PKGBUILD ]] && {
+ echo "Error: no matching PKGBUILDs found for ${package}-libre"
+ continue
+ }
+
+ source ./${package}-libre/PKGBUILD
+ [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
+
+# Generate a diff file, no -r since we don't want to patch src/ nor pkg/
+ diff -auN ${package} ${package}-libre > $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
+
+done
+
+exit 0