summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-11-25 13:41:28 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2010-11-25 13:41:28 -0600
commitafa6d104c91ad41d1746f96a4dad7e7c2852c7fc (patch)
tree3a4994f423388cacd66eda5e3fdcf79f52b2a078
parenteb1613be26161b476769e00ae6e1cf2c40d516a4 (diff)
rename librepatch to librediff
-rwxr-xr-xlibrepatch65
1 files changed, 0 insertions, 65 deletions
diff --git a/librepatch b/librepatch
deleted file mode 100755
index 08e7bb7..0000000
--- a/librepatch
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/bin/bash
-# Generates a patch for a nonfree PKGBUILD
-#
-# Copyright 2010 Nicolás Reynolds
-
-# ---------- GNU General Public License 3 ----------
-
-# This file is part of Parabola.
-
-# Parabola is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-
-# Parabola is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-
-# You should have received a copy of the GNU General Public License
-# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-
-usage() {
- echo "Usage: $0 <pkgname> [<pkgname2> ...]"
- echo "Requirements:"
- echo "* Have a <pkgname>/ directory with nonfree build scripts inside"
- echo "* Have a <pkgname>-libre/ directory with libre build scripts inside"
-}
-
-# Load custom config or system-wide config
-custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
-if [ -e $custom_config ]; then
- source $custom_config
-else
- source /etc/libretools.conf
-fi
-
-# Print usage if no package has been given
-[[ -z "$@" ]] && {
- usage
- exit 1
-}
-
-
-for package in $@; do
-# Continue on errors
- [[ ! -d ./${package} || ! -d ./${package}-libre ]] && {
- echo "Error: no matching ${package} and ${package}-libre found"
- continue
- }
-
- [[ ! -f ./${package}/PKGBUILD || ! -f ./${package}-libre/PKGBUILD ]] && {
- echo "Error: no matching PKGBUILDs found for ${package}-libre"
- continue
- }
-
- source ./${package}-libre/PKGBUILD
- [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
-
-# Generate a diff file, no -r since we don't want to patch src/ nor pkg/
- diff -auN ${package} ${package}-libre > $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
-
-done
-
-exit 0