summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-05-15 22:25:43 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-05-15 22:25:43 -0400
commit22bb572086ff1c1667d553ac8233fc053a1556f2 (patch)
treedcca9c189644d16e66584b871b84ca77a13bf1a2
parent9bb1ddbaf5f0585f5854ee2c25204bda56b32974 (diff)
librefetch: clean up documentationv20140515
-rwxr-xr-xsrc/librefetch/librefetch3
-rw-r--r--src/librefetch/librefetch.8.ronn15
2 files changed, 13 insertions, 5 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 11cf380..8b02205 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -53,7 +53,8 @@ usage() {
prose "The default build script is 'PKGBUILD', or 'SRCBUILD' if it
exists."
echo
- prose "Unrecognized options are passed straight to makepkg."
+ prose "Other options, if they are valid \`makepkg\` options, are passed
+ straight to makepkg."
echo
prose "%s does NOT support getopt-style flag combining. You must use
'-a -b', not '-ab'." "$cmd"
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index d7b8edc..bb2e561 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -12,9 +12,9 @@ librefetch(8) -- downloads or creates a liberated source tarball
tarballs for `PKGBUILD(5)` files.
If a URL mentioned in the `source` array in a `PKGUILD` is in a
-location that Parabola uploads "custom" source tarballs (or configured
-locations), and no file is at that URL, librefetch will automatically
-create it for you.
+location that Parabola uploads "custom" source tarballs to (or
+configured locations), and no file is at that URL, librefetch will
+automatically create it for you.
This works because a post-install script for the package configures
`librefetch` as the download agent for `https://` URLs in
@@ -53,6 +53,9 @@ fails, it may choose to try `create` mode.
script.
* `-h` | `--help`: Use `help` mode: Show useage information.
+Other options, if they are documented in `makepkg -h`, are passed to
+the modified copy of makepkg created during `create` mode.
+
## DOWNLOAD MODE
If <SOURCE-URL> begins with the string `libre://`, it is replaced with
@@ -97,7 +100,7 @@ remain intact.
As explained in the `CREATE MODE` section, in `create` mode, this
program generates an `SRCBUILD` file. For debugging purposes, this
-file can be printed instead of executed with `print` mode.
+file can be printed instead of executed with `srcbuild` mode.
### PRE-EXISTING SRCBUILD
@@ -184,6 +187,10 @@ The following modifications are made to makepkg:
* append `-libre` to `$pkgbasedir` (which becomes `$pkgdir`)
* Don't check if the package has already been built.
+For debugging purposes, this modified makepkg can be printed instead
+of executed with `makepkg` mode. Before it is run in create mode,
+`PKGEXT`, `PKGDEST`, and `pkg_file` are set as environment variables.
+
## CONFIGURATION
See `librefetch.conf(5)` for details on configuring librefetch using