summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-28 04:59:22 -0700
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-28 04:59:22 -0700
commit4704e612377ff0e20acfcb13f1a991ca5058d60a (patch)
tree01c0c82126f93c909722abcc036f0d207e8f63d3
parent8749c71ef4069c4a451a01a9c87723abff4272c2 (diff)
Fixed pkgbuild-check-nonfree, added librerepkg (not done)v20110328
-rw-r--r--librerepkg22
-rwxr-xr-xpkgbuild-check-nonfree14
2 files changed, 27 insertions, 9 deletions
diff --git a/librerepkg b/librerepkg
new file mode 100644
index 0000000..f943c2a
--- /dev/null
+++ b/librerepkg
@@ -0,0 +1,22 @@
+#!/bin/bash
+# Copyright 2011 Joshua Ismael Haase Hernandez
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+source /etc/libretools.conf
+
diff --git a/pkgbuild-check-nonfree b/pkgbuild-check-nonfree
index 6f3837b..178cd0f 100755
--- a/pkgbuild-check-nonfree
+++ b/pkgbuild-check-nonfree
@@ -56,18 +56,14 @@ source ./PKGBUILD
# The `pkgname', `depends', `makedepends' arrays have been sourced from
# ./PKGBUILD.
msg "Looking for unfree dependencies"
-for where in pkgname depends makedepends ; do
- msg2 " Cheking in «${where}»:"
-
+for item in (${pkgname[@]} ${depends[@]} ${makedepends[@]}) ; do
# We cycle through all of the programs in the array (if any), and check if
# they are in the `unfree' array.
- for item in ${!where[@]} ; do
- if in_array $item ${unfree[@]}
+ if in_array $item ${unfree[@]}
then
- ev=15
- plain $item
- fi
- done
+ ev=15
+ msg2 "found $item"
+ fi
done
exit $ev \ No newline at end of file