summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-10 05:16:39 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-10 05:16:39 -0500
commit6e075397e14d65a039ed954ff0a6ab6400e4f02c (patch)
tree8cf1aa92f427ee5d9a3d1654cdab236afbc2a509
parent6749a07b4c114613f94aa915f603f00d26c16e0c (diff)
parentf21fd2185aaef0b2e9054c5eb0d4369597bcc0ff (diff)
Merge branch 'master' of vparabola:~/projects/libretools
-rwxr-xr-xfullpkg7
-rwxr-xr-xlibremakepkg2
-rwxr-xr-xpkgbuild-check-nonfree24
3 files changed, 23 insertions, 10 deletions
diff --git a/fullpkg b/fullpkg
index dfdba45..b417994 100755
--- a/fullpkg
+++ b/fullpkg
@@ -242,9 +242,16 @@ function _pkg_build () {
0)
plain "The build was succesful."
source .INFO && [ -n $repo ] && {
+# Release locally
+ mipsrelease *.pkg.tar.?z
+
+# Stage for releasing
librestage $repo || {
echo "unstaged:$(basename $PWD)" >> $build_dir/log
}
+
+ msg "Updating pacman db and packages"
+ sudo pacman -Syu --noconfirm
}
echo "built:$(basename $PWD)" >> $build_dir/log
cleanup "$(basename $PWD)"
diff --git a/libremakepkg b/libremakepkg
index e83bee7..af18e8e 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -63,7 +63,7 @@ while getopts ${libremakepkgargs} arg ; do
esac
done
-if [ $UID -ne 0 ]; then
+if [ ! -w / ]; then
error "This script must be run as root"
exit 1
fi
diff --git a/pkgbuild-check-nonfree b/pkgbuild-check-nonfree
index f3fcd95..e947a39 100755
--- a/pkgbuild-check-nonfree
+++ b/pkgbuild-check-nonfree
@@ -59,17 +59,23 @@ source ./PKGBUILD
# ./PKGBUILD.
msg "Looking for unfree dependencies"
for item in ${pkgname[@]} ${depends[@]} ${makedepends[@]} ; do
- # We cycle through all of the programs in the array (if any), and check if
- # they are in the `unfree' array.
+# We cycle through all of the programs in the array (if any), and check if
+# they are in the `unfree' array.
if in_array $item ${unfree[@]} ; then
- # if item has a free replacement, use error 16.
- if in_array $item-libre ${freerep[@]} ; then
- warning "$item -> $item-libre"
- else
- ev=15
+# If the package has a replacement of the same name, skip
+ if in_array $item ${freerep[@]} ; then
+ warning "$item is repackaged with the same name."
+ ev=0
+ continue
+# if item has a free replacement, use error 16.
+ elif in_array $item-libre ${freerep[@]} ; then
+ warning "$item -> $item-libre"
+ ev=16
+ else
+ ev=15
msg2 "found $item"
- fi
+ fi
fi
done
-exit $ev \ No newline at end of file
+exit $ev