summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-01-17 21:21:57 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-01-17 21:21:57 -0500
commit6eb6aa42f9860b7a46bedd72d2bb313ebd48c809 (patch)
tree977062a31d35200868b3efe78217f136e09c4d71
parentc79e6971d56c347cee39fe2e601226865ac2ae1e (diff)
Integrate devtools into the build systemv20130117
-rw-r--r--Makefile6
-rw-r--r--src/devtools/Makefile4
2 files changed, 6 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 92017f3..65a8ac9 100644
--- a/Makefile
+++ b/Makefile
@@ -16,12 +16,12 @@ docdir=$(datarootdir)/doc
################################################################################
# these are directories
-pseudo-packages=abslibre-tools chroot-tools fullpkg lib mips64el-tools toru
+pseudo-packages=abslibre-tools chroot-tools devtools fullpkg lib mips64el-tools toru
# these are the resulting packages
packages=libretools libretools-pr libretools-mips64el
# and which directories they contains
-libretools=abslibre-tools lib chroot-tools fullpkg toru misc
+libretools=abslibre-tools lib chroot-tools devtools fullpkg toru misc
libretools-mips64el=mips64el-tools
################################################################################
@@ -36,7 +36,7 @@ install: PHONY install-libretools install-doc
$(MAKE) -C src $*
build-%: PHONY src/%
- $(MAKE) -C src/$* build
+ $(MAKE) -C src/$*
install-%: PHONY src/%
$(MAKE) -C src/$* install
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 8b94f80..94f1f6b 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -1,6 +1,8 @@
V=20121128.6
-PREFIX = /usr/local
+#prefix = /usr/local
+prefix = /usr
+PREFIX = $(prefix)
pkgdatadir=$(PREFIX)/share/devtools
BINPROGS = \