summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-12 17:33:03 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-12 17:33:03 -0500
commit911eacc4274ef1f9ce3b78833a0cd4e4a81d440f (patch)
treea802b0936c5a7d47f7b87a251545a08787d462f0
parent16e41597e98333f6383a3cb9aa6e9371f64522bf (diff)
parent487602793c43a5858b734fde4bbb8d0fdb80e96b (diff)
Merge branch 'libretools.conf'v20121112
-rw-r--r--src/libretools.conf148
1 files changed, 82 insertions, 66 deletions
diff --git a/src/libretools.conf b/src/libretools.conf
index 8032397..631ca89 100644
--- a/src/libretools.conf
+++ b/src/libretools.conf
@@ -1,38 +1,62 @@
+#!/bin/bash
+
+################################################################################
+# misc #
+################################################################################
+
## Blacklist URL
+## Used by `pkgbuild-check-nonfree`
BLACKLIST=http://repo.parabolagnulinux.org/docs/blacklist.txt
-# Diff tool (vimdiff, gvimdiff, meld, etc)
-DIFFTOOL=vimdiff
+## Diff tool (vimdiff, gvimdiff, meld, etc)
+## Used by `aur`, `diff-unfree`
+DIFFTOOL=`which vimdiff gvimdiff meld colordiff 2>/dev/null|sed 's/\s.*//'`
-# The dir where you work on
-WORKDIR=/home/$USER/packages
-# The repos you'll be packaging for
-#
+## The repos you'll be packaging for
+## Used by `toru`, `createworkdir`, `prfullpkg`
# Tip: As early repos take precedence on $REPOS loops, you can use this as
# inverted order of precedence. Put testing repos first so fullpkg find new
# PKGBUILDs first, for instance. Toru-path uses reverse order to enforce repo
# precedence on the path cache (the last path added replaces the rest)
-REPOS=('core' 'libre' 'extra' 'community' 'libre-testing' 'social' 'sugar')
+REPOS=('core' 'libre' 'extra' 'community' 'libre-testing' 'social' 'sugar' 'pcr' 'java')
-# The architectures
+## The architectures
+## Used by `librestage`
ARCHES=('i686' 'x86_64' 'mips64el' 'any')
+################################################################################
+# chroot #
+################################################################################
+
## The directory where the chroots are stored
CHROOTDIR=/home/chroot
-# Extra packages to have installed on the chroot (besides base base-devel and sudo)
-CHROOTEXTRAPKG=(distcc ccache tsocks tokyocabinet)
+## Extra packages to have installed on the chroot (besides base base-devel and sudo)
+CHROOTEXTRAPKG=(distcc ccache tsocks libretools)
+## The meaning of this changes based on the version of libretools+devtools
+## do NOT set it to 'root'
+CHROOT=default
-## The working chroot
-## A chroot is useful to build packages isolated from the current system and avoid
-## unwanted (as in not in dependencies) automatic library linking
-# CHROOT=$SUDO_USER
-# CHROOT=root
+################################################################################
+# abslibre #
+################################################################################
-## Obtains CacheDir from pacman.conf
-CACHEDIR=`grep "^#\?CacheDir" /etc/pacman.conf | cut -d'=' -f2`
+# The dir where you work on
+WORKDIR=/home/$USER/packages
-## Parabola hostname (should be the same used on ssh_config
+## Package signing
+# Leave commented to disable signing
+#SIGEXT=".sig"
+#SIGID="0xYOURID"
+
+## Parabola hostname
PARABOLAHOST=parabola
+## Assumes something similar in your .ssh/config:
+
+## Repo server
+# Host parabola
+# Port 1863
+# HostName repo.parabolagnulinux.org
+# User repo
## Server destination of libre packages
# Don't change unless you know what you're doing and you won't screw
@@ -45,9 +69,13 @@ ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git
## Commit Command
## Should be git or hg
## Uncomment only one of those
-#COMMITCMD=git
+COMMITCMD=git
#COMMITCMD=hg
+################################################################################
+# fullpkg #
+################################################################################
+
## Uncomment one of those or make one of your choice
# Normal fullpkg
FULLBUILDCMD="sudo libremakepkg -cuN"
@@ -68,55 +96,43 @@ HOOKPRERELEASE="ssh -fN parabola"
# succesfully
# HOOKLOCALRELEASE=""
-## Toru
+################################################################################
+# toru #
+################################################################################
+
# Section for toru's vars
TORUPATH=/var/lib/libretools/toru
-## Package signing
-# Leave commented to disable signing
-#SIGEXT=".sig"
-#SIGID="0xYOURID"
-
-# Checks if vars aren't empty
-
-for VAR in CHROOTDIR CHROOT CACHEDIR PARABOLAHOST LIBREDESTDIR \
- BLACKLIST WORKDIR REPOS ARCHES ABSLIBREGIT \
- COMMITCMD DIFFTOOL FULLBUILDCMD; do
-
- ret=0
- [[ -z ${!VAR} ]] && {
- echo "Configure $VAR var in /etc/libretools.conf"
- ret=1
- }
- [ $ret -ne 0 ] && exit 1
+################################################################################
+# This probably shouldn't be in a .conf file... #
+################################################################################
+
+if [[ -z $XDG_CONFIG_HOME ]]; then
+ if [[ -n $SUDO_USER ]]; then
+ SUDO_HOME="$(eval echo ~$SUDO_USER)"
+ export XDG_CONFIG_HOME="${SUDO_HOME}/.config"
+ unset SUDO_HOME
+ else
+ export XDG_CONFIG_HOME="${HOME}/.config"
+ fi
+fi
+if [[ -e "$XDG_CONFIG_HOME/libretools/libretools.conf" ]]; then
+ . "$XDG_CONFIG_HOME/libretools/libretools.conf"
+fi
+
+ret=0
+for VAR in CHROOTDIR CHROOT PARABOLAHOST LIBREDESTDIR \
+ BLACKLIST WORKDIR REPOS ARCHES ABSLIBREGIT \
+ COMMITCMD DIFFTOOL FULLBUILDCMD; do
+
+ if [[ -z ${!VAR} ]]; then
+ echo "Configure $VAR var in /etc/libretools.conf"
+ ret=1
+ fi
done
+if [[ $ret != 0 ]]; then
+ exit 1
+fi
+unset ret
-source /usr/bin/libremessages
-
-## These are architecture specific files.
-## Uncomment them if you installed libretools-mips64el
-# source /etc/libretools.d/mips64el.conf
-
-## Recommended SSH Config follows
-# SSH host, it's better if you have it configured on ~/.ssh/config
-# with ControlMaster auto (and a shell opened somewhere else)
-#
-# Example:
-# Host *
-# Protocol 2
-# ControlMaster auto
-# ControlPath /tmp/ssh-%r@%h:%p
-#
-## Repo server
-# Host parabola
-# Port 22
-# HostName repo.parabolagnulinux.org
-# User parabolavnx
-# IdentityFile ~/.ssh/id_rsa
-#
-## Git server
-# Host vparabola
-# Port 1863
-# HostName parabolagnulinux.org
-# User parabola
-# IdentityFile ~/.ssh/id_rsa
+. /usr/bin/libremessages