summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-11-03 13:34:33 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-11-03 13:34:33 -0300
commit958043bd456f8e60f54a2b2e3a601439394558ca (patch)
tree090ad46f7ff09d68b30b5c9c59cf688c94d49898
parent91b6dce69dc0737133bf82d3e1fd602c9d99a571 (diff)
parent04af64022ed0a0bf618e23c0ed7512c168d479c7 (diff)
Merge branch 'tokyo'
-rw-r--r--libretools.conf6
-rwxr-xr-xtoru-path8
2 files changed, 11 insertions, 3 deletions
diff --git a/libretools.conf b/libretools.conf
index 40f92dc..88ba515 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -7,10 +7,12 @@ DIFFTOOL=vimdiff
# The dir where you work on
WORKDIR=/home/$USER/packages
# The repos you'll be packaging for
+#
# Tip: As early repos take precedence on $REPOS loops, you can use this as
# inverted order of precedence. Put testing repos first so fullpkg find new
-# PKGBUILDs first, for instance.
-REPOS=('core' 'extra' 'community' 'libre' 'libre-testing' 'social' 'sugar')
+# PKGBUILDs first, for instance. Toru-path uses reverse order to enforce repo
+# precedence on the path cache (the last path added replaces the rest)
+REPOS=('core' 'libre' 'extra' 'community' 'libre-testing' 'social' 'sugar')
# The architectures
ARCHES=('i686' 'x86_64' 'mips64el' 'any')
diff --git a/toru-path b/toru-path
index 7f1d599..957f49b 100755
--- a/toru-path
+++ b/toru-path
@@ -3,6 +3,7 @@
source $(dirname $(command -v $0))/toru-utils
TORUPATH=${T:-${TORUPATH}}
+VERBOSE=${V:-false}
if [ ! -w "$TORUPATH" ]; then
error "Toru's path isn't writable. Please check $TORUPATH"
@@ -18,7 +19,11 @@ fi
# TODO pass other paths via flags
# ABSROOT has trailing slash
-fullrepos=($(for _repo in ${REPOS[@]}; do echo "${ABSROOT}${_repo}"; done))
+fullrepos=()
+for (( i = ${#REPOS[@]}-1 ; i >= 0 ; i-- )); do
+ ${VERBOSE} && msg "Processing [%s]" ${REPOS[$i]}
+ fullrepos+=("${ABSROOT}${REPOS[$i]}")
+done
pkgbuilds=($(get_pkgbuilds ${fullrepos[@]}))
msg "Updating path cache"
@@ -33,6 +38,7 @@ for _pkgbuild in ${pkgbuilds[@]}; do
fullpath=$(dirname ${_pkgbuild})
for _pkg in ${pkgbase} ${pkgname[@]} ${provides[@]}; do
+ $VERBOSE && msg2 "${_pkg} -> ${fullpath}"
tcamgr put ${PATHFILE} ${_pkg/[<>=]*} ${fullpath}
done