summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-04-18 00:07:55 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-04-18 00:07:55 -0400
commitad77b246574f7126a87e5202fc202ff1c0708681 (patch)
tree9e6f1c767ba5e605882e782747dc60dcf7cdeec6
parent54586bd5a3406413813abb559887548feb6b97a4 (diff)
Makefile: Only check $(devtoolsdir) existence if it's needed.v20160418
The check was creating problems with release tarballs, for obvious reasons.
-rw-r--r--common.each.tail.mk8
-rw-r--r--common.once.head.mk4
2 files changed, 7 insertions, 5 deletions
diff --git a/common.each.tail.mk b/common.each.tail.mk
index 58dfa8e..ffc4f47 100644
--- a/common.each.tail.mk
+++ b/common.each.tail.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015 Luke Shumaker
+# Copyright (C) 2015, 2016 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -13,6 +13,12 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+ifneq ($(sort $(wildcard $(addprefix $(srcdir)/,$(devtools-files)))),$(sort $(addprefix $(srcdir)/,$(devtools-files))))
+ifeq ($(wildcard $(devtoolsdir)/),)
+$(error config.mk:devtoolsdir points to a non-existant directory: $(devtoolsdir))
+endif
+endif
+
am_src_files += $(libretools-srcs)
am_gen_files += .srcfiles.mk $(devtools-files)
am_out_files += $(filter-out $(am_src_files) $(am_gen_files),$(libretools-files)) \
diff --git a/common.once.head.mk b/common.once.head.mk
index 45d51b4..d7faab8 100644
--- a/common.once.head.mk
+++ b/common.once.head.mk
@@ -20,10 +20,6 @@ MAKEFLAGS += --no-builtin-rules --no-builtin-variables
.PHONY: FORCE
-ifeq ($(wildcard $(devtoolsdir)/),)
-$(error config.mk:devtoolsdir points to a non-existant directory: $(devtoolsdir))
-endif
-
write-ifchanged = $(topsrcdir)/write-ifchanged
# Magic for tracking variables that affect files. If a file changes