summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-15 18:25:30 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-15 18:25:30 -0400
commitc24cf05d2f9a3d06ca272c7a7fcf8de505334261 (patch)
tree703d72010f8deee63033ed345d3b28272fe5b5eb
parent3356f339077ed317cd645768092649e9e7369f6c (diff)
test/: Use `librechroot install-name` rather than `librechroot run pacman`v20180815
-rw-r--r--test/librechroot-test.sh8
-rw-r--r--test/libremakepkg-test.sh2
2 files changed, 5 insertions, 5 deletions
diff --git a/test/librechroot-test.sh b/test/librechroot-test.sh
index 6ccff6f..00ca2ed 100644
--- a/test/librechroot-test.sh
+++ b/test/librechroot-test.sh
@@ -50,7 +50,7 @@ it_handles_CHROOTEXTRAPKG_correctly() {
not testsudo librechroot -l "$roundup_test_name" run lsof
echo "CHROOTEXTRAPKG=(lsof)" >> "$XDG_CONFIG_HOME"/libretools/chroot.conf
- testsudo librechroot -l "$roundup_test_name" run pacman -S --noconfirm lsof
+ testsudo librechroot -l "$roundup_test_name" install-name lsof
testsudo librechroot -l "$roundup_test_name" clean-pkgs
testsudo librechroot -l "$roundup_test_name" run lsof
echo "CHROOTEXTRAPKG=()" >> "$XDG_CONFIG_HOME"/libretools/chroot.conf
@@ -65,12 +65,12 @@ it_obeys_depends_in_PKGBUILD() {
# Make sure it's not in the base install
not testsudo librechroot -l "$roundup_test_name" run lsof
# Make sure it removes it without the PKGBUILD
- testsudo librechroot -l "$roundup_test_name" run pacman -S --noconfirm lsof
+ testsudo librechroot -l "$roundup_test_name" install-name lsof
testsudo librechroot -l "$roundup_test_name" run lsof
testsudo librechroot -l "$roundup_test_name" clean-pkgs
not testsudo librechroot -l "$roundup_test_name" run lsof
# Make sure it leaves it with the PKGBUILD
- testsudo librechroot -l "$roundup_test_name" run pacman -S --noconfirm lsof
+ testsudo librechroot -l "$roundup_test_name" install-name lsof
testsudo librechroot -l "$roundup_test_name" run sh -c 'printf "%s\n" "$1" > /startdir/PKGBUILD' -- "$(cat librechroot.d/PKGBUILD)"
# uid=99 is 'nobody', but we say '99' because sometimes 'nobody' is uid=65534.
# https://bugs.archlinux.org/task/56828
@@ -158,7 +158,7 @@ it_deletes_subvolumes_recursively() {
require network sudo btrfs || return 0
libremessages msg 'Creating a chroot, may take a few minutes' &>/dev/tty
testsudo librechroot -l "$roundup_test_name" make
- testsudo librechroot -l "$roundup_test_name" run pacman -S --noconfirm btrfs-progs
+ testsudo librechroot -l "$roundup_test_name" install-name btrfs-progs
test -d "$chrootdir/default/$roundup_test_name"
not test -e "$chrootdir/default/$roundup_test_name/var/subvolume"
testsudo librechroot -l "$roundup_test_name" run btrfs subvolume create /var/subvolume
diff --git a/test/libremakepkg-test.sh b/test/libremakepkg-test.sh
index 0d24b43..0482638 100644
--- a/test/libremakepkg-test.sh
+++ b/test/libremakepkg-test.sh
@@ -143,7 +143,7 @@ it_detects_distcc_files() {
echo "CHROOTEXTRAPKG+=(distcc-nozeroconf socat)" >> "$XDG_CONFIG_HOME"/libretools/chroot.conf
trap 'sed -i /CHROOTEXTRAPKGs+=/d "$XDG_CONFIG_HOME"/libretools/chroot.conf' RETURN
libremessages msg 'Creating a chroot, may take a few minutes' &>/dev/tty
- testsudo librechroot -l "$roundup_test_name" run pacman -S --noconfirm distcc-nozeroconf socat
+ testsudo librechroot -l "$roundup_test_name" install-name distcc-nozeroconf socat
# first make sure that the engine works
testsudo libremakepkg -l "$roundup_test_name"