summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-03-28 16:04:00 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-03-28 16:04:00 -0300
commit32d067fb569628d97e7b73acca0e3a6a1dacb002 (patch)
tree0a1d6cc168235f6ef1b576261ae58263c1fe6a8d
parentd84746f9cb204617c71e2e4f906ac6fca6feab97 (diff)
Script to add 'mips64el' to the arch array
-rwxr-xr-xadd-mips64el6
1 files changed, 6 insertions, 0 deletions
diff --git a/add-mips64el b/add-mips64el
new file mode 100755
index 0000000..e06d857
--- /dev/null
+++ b/add-mips64el
@@ -0,0 +1,6 @@
+#!/bin/bash
+# Change all arch array that aren't any or mips64el already
+
+find -name 'PKGBUILD' -exec sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" '{}' \;
+
+exit $?