summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-28 04:09:01 -0700
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-03-28 04:09:01 -0700
commiteb9b162a91f5f378d62231a2bd123a2561835a3e (patch)
treea21ad8425b1168be921f62dacfb2632765062fac
parent850a13383fe16da9784bb3974b2ac4723ceca2ec (diff)
Using cachedir in mkarchroot
-rwxr-xr-xfullpkg4
-rwxr-xr-xlibremakepkg3
2 files changed, 3 insertions, 4 deletions
diff --git a/fullpkg b/fullpkg
index c723f8e..8af6ad3 100755
--- a/fullpkg
+++ b/fullpkg
@@ -86,7 +86,7 @@ quit() {
}
source PKGBUILD
-msg ":: Building ${pkgbase} ${pkgname[@]}"
+msg "Building ${pkgbase} ${pkgname[@]}"
trap "quit" SIGTERM SIGKILL
@@ -111,7 +111,7 @@ deps=$(echo "${depends[@]} ${makedepends[@]} ${pkgdeps[@]}" | \
sort -u)
msg "Checking dependencies"
-plain "$_deps"
+plain "${deps[@]}"
msg "Syncing database"
sudo pacman -Sy
diff --git a/libremakepkg b/libremakepkg
index 78ebefb..8cce89d 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -39,8 +39,7 @@ pkgbuild-check-nonfree ||{
CLEAN="-c"
msg "Updating the main chroot"
- mount -o bind ${CACHEDIR} ${CHROOTDIR}/${CHROOT}/var/cache/pacman/pkg || exit 1
- mkarchroot -u -- ${CHROOTDIR}/${CHROOT}
+ mkarchroot -c ${CACHEDIR} -u -- ${CHROOTDIR}/${CHROOT}
mount -o bind ${CACHEDIR} ${CHROOTDIR}/${CHCOPY}/var/cache/pacman/pkg || exit 1
}