summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-04-03 22:29:31 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-04-03 22:29:31 -0300
commitccc61420fca233f9a0c7f850f936b4cf9ec4ebe2 (patch)
treeb1b9a792de035cd1dbf43c22cee07b7b98932826
parent44ec529c8915322143fb3de451d0bc76e1ac2a0b (diff)
Diff-Unfree is a tool to diff unfree PKGBUILDs against ABSLibre
-rwxr-xr-xdiff-unfree82
-rw-r--r--libretools.conf5
2 files changed, 86 insertions, 1 deletions
diff --git a/diff-unfree b/diff-unfree
new file mode 100755
index 0000000..0086db9
--- /dev/null
+++ b/diff-unfree
@@ -0,0 +1,82 @@
+#!/bin/bash
+# This script will help you diff a *-libre PKGBUILD against the unfree one
+# to check for updates.
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+source /etc/libretools.conf
+custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
+
+[[ "$1" == "--help" ]] && {
+ msg "Diff-Unfree helps you diff build scripts from ABSLibre against
+ (Unfree) ABS. Package name and repo will we guessed if you don't
+ specify them."
+ msg2 "Usage: $0 [unfree-package] [repo]"
+}
+
+[[ ! -r PKGBUILD ]] && {
+ error "This is not a build dir."
+ exit 1
+}
+
+package_guess=$(basename $PWD)
+
+package=${1:-${package_guess/-libre}}
+repo=${2:-$(basename $(dirname $PWD))}
+
+tmp_dir=$(mktemp -d /tmp/${package}.XXXXXX)
+unfree_dir="${tmp_dir}/packages/${package}/trunk"
+
+svnrepo="packages"
+case $repo in;
+ community*)
+ svnrepo="community"
+ ;;
+ multilib*)
+ svnrepo="community"
+ ;;
+ *)
+ ;;
+esac
+
+[[ ! -d "${tmp_dir}" ]] && {
+ error "Can't create temp dir"
+ exit 1
+}
+
+stdnull 'pushd "${tmp_dir}"'
+
+msg "Getting diff from $repo/$package..."
+
+stdnull 'svn checkout --depth=empty svn://svn.archlinux.org/$svnrepo'
+
+cd packages
+svn update ${package}
+
+# Back to start dir
+stdnull popd
+
+msg "Diffing files"
+
+for _file in ${unfree_dir}/*; do
+ msg2 "$(basename "${_file}")"
+ ${DIFFTOOL} "$PWD/$(basename "${_file}")" "${_file}"
+done
+
+exit $?
diff --git a/libretools.conf b/libretools.conf
index 108b001..da8d9d8 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -1,6 +1,9 @@
## Blacklist URL
BLACKLIST=http://repo.parabolagnulinux.org/docs/blacklist.txt
+# Diff tool (vimdiff, gvimdiff, meld, etc)
+DIFFTOOL=vimdiff
+
# The dir where you work on
WORKDIR=/home/$USER/packages
# The repos you'll be packaging for
@@ -70,7 +73,7 @@ ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git/
# Checks if vars aren't empty
#
for VAR in CHROOTDIR CHROOT CHCOPY CACHEDIR PARABOLAHOST LIBREDESTDIR \
- LIBRESRCDIR BLACKLIST WORKDIR PATCHDIR REPOS ARCHES ABSLIBREGIT COMMITCMD; do
+ LIBRESRCDIR BLACKLIST WORKDIR PATCHDIR REPOS ARCHES ABSLIBREGIT COMMITCMD DIFFTOOL; do
[[ -z ${!VAR} ]] && {
echo "Configure $VAR var in $0"