summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2011-03-28 16:04:39 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2011-03-28 16:04:39 -0300
commite382fc1cf297db85f17c67c32920b6c84211da33 (patch)
treefeee3da61ab102ba2348e8b447dfdc85d6369e31
parent32d067fb569628d97e7b73acca0e3a6a1dacb002 (diff)
Check if we're on a PKGBUILD dir
-rwxr-xr-xfullpkg8
1 files changed, 6 insertions, 2 deletions
diff --git a/fullpkg b/fullpkg
index b75bf32..434b793 100755
--- a/fullpkg
+++ b/fullpkg
@@ -4,9 +4,13 @@
# * Detect circular builds
# * Detect pkgnames by provides, replaces, etc. instead of dir tree
+[[ ! -r PKGBUILD ]] && {
+ echo "This isn't a build directory"
+ exit 1
+}
-tmp_dir=$(mktemp -d)
-queue_file=$(mktemp)
+tmp_dir=$(mktemp -d /tmp/$(basename $PWD).XXXXXX)
+queue_file=$(mktemp /tmp/queue.XXXXXX)
[[ ! -w $queue_file ]] && exit 1
source /etc/makepkg.conf